Hide Table of Contents

Command Reference: Commands by Menu Order

Application menu

Menu Description Command
About Displays information about the program About
Preferences Configures program operating parameters Options
Services Opens a submenu containing Apple Macintosh Tools
Hide Hides the application
Hide Others Hides all other open applications
Show All Shows all open applications
Quit Exits the program Exit

File

Menu Description Command
New... Creates a new drawing file New
Open... Opens an existing drawing file Open
Close Exits the drawing but not the program Close
Save Saves the drawing under the current file name or a specified name Save
Save As... Saves an unnamed drawing with a file name or renames the current drawing SaveAs
Export  
Publish eDrawings Starts the eDrawings® application to create, view, and share 3D models and 2D drawings eDrawings
Sheet Creates, copies, renames, or deletes Sheet tabs (layout mode to set up a printout) Sheet
Print Configuration Manager... Defines Print Configurations to use as printing defaults for the Model and for Sheets PrintConfiguration
Print Preview Shows a preview for printing or plotting the drawing Preview
Print... Prints a drawing to a plotter, printer, or file Print
Properties... Displays and edits the standard properties of the current drawing file and creates custom properties for the file DrawingProperties
Error Check Evaluates the integrity of a drawing and corrects errors if possible Check
Clean... Removes unused user-defined objects from the drawing, such as Blocks or Layers Clean
Recover... Repairs a damaged drawing if possible Recover
Preview Recent Documents... Browses recent documents and opens them from the Recent Documents preview list Recent
Exit Exits the program Exit
Exit Exits the program Exit

 

    ^ Top of Page

File > Export

Menu Description Command
Export... Saves the entire drawing, specified entities, or views to other vector or image file formats Export
PDF Export Saves the current view of the graphics display to a PDF (Portable Document Format) file ExportPDF
Export Drawing Writes entities, Blocks, or the entire drawing to a new drawing file ExportDrawing

 

    ^ Top of Page

Edit

Menu Description Command
Undo Reverses the most recent command U
Redo Reverses the effects of the previous U or UndoN command Redo
Cut Copies entities to the clipboard and deletes the entities Cut
Copy Copies entities to the clipboard ClipboardCopy
Copy with Reference Point Copies entities with a specified reference point to the clipboard Copy@
Paste Inserts data from the clipboard Paste
Paste to Active Layer Inserts data from the clipboard onto the active Layer Paste
Paste as Block Inserts entities from the clipboard as Block PasteAsBlock
Paste Selected Format... Pastes entities from the OS clipboard by specifying a format PasteSelected
Erase Removes entities from a drawing Delete
Select All Selects all drawing entities for subsequent modification commands SelectAll
Find... Finds and replaces Text in Notes, Annotations, and Dimension Text Find

 

    ^ Top of Page

View

Menu Description Command
Rebuild Rebuilds the drawing display and refreshes the active ViewTile Rebuild
Rebuild All Rebuilds the drawing display and refreshes all ViewTiles RebuildAll
Refresh All Refreshes the display of all ViewTiles RefreshAll
Pan  
Zoom  
Named Views... Saves and restores user-defined views Views
View Tiles Creates and controls single or multiple model ViewTiles or Sheet Viewports ViewTiles, -Viewport
3D Orbit  
Hide Creates a hidden line view HideView
Shade Determines the ShadeView mode ShadeView
Animated Rendering Displays the rendered drawing in a separate window ARender
Clean Screen Toggles fullscreen mode on and off Fullscreen, HideFullscreen
Display  

 

    ^ Top of Page

View > Pan

Menu Description Command
Dynamic Moves the drawing display in the active ViewTile (dynamic pan) Pan
Point Moves the drawing display in the active ViewTile by pointing a displacement -Pan
Left Pans to the left PanLeft
Right Pans to the right PanRight
Up Pans up PanUp
Down Pans down PanDown

 

    ^ Top of Page

View > Zoom

Menu Description Command
Dynamic Increases or decreases the visible part of the drawing Zoom
Center Zooms to an area determined by a center point and a magnification or height Zoom Center
Factor Zooms by a factor ZoomFactor
Previous Zooms to previous view ZoomBack
Selected Zooms to an area determined by the extents of specified entities Zoom Selected
Window Zooms to a region of the drawing specified by a box ZoomWindow
In Zooms in to the drawing ZoomIn
Out Zooms out from the drawing ZoomOut
Bounds Zooms the entire drawing Zoom Bounds
Fit Zooms to the drawing extents ZoomFit

 

    ^ Top of Page

View > 3D Orbit

Menu Description Command
Constrained Orbit Rotates the view in 3D space RollView
Free Orbit Rotates the view in 3D space without constraining roll RollViewFree
Continuous Orbit Rotates the view in 3D space with continuous motion about a specified pivot point RollViewContinuous
Vertical Orbit Tilts the view in 3D space vertically (up and down) about an imaginary horizontal axis RollViewVertical
Horizontal Orbit Swivels the view in 3D space horizontally (left and right) about an imaginary vertical axis RollViewHorizontal
Orbit Center Sets the center of rotation for constraint orbit view and starts constraint orbit view RollViewCenter

 

    ^ Top of Page

View > Display

Menu Description Command
Block Attributes Defines visibility of BlockAttributes DisplayBlockAttributes
Command History Opens the separate command history window CommandHistory
CCS Icon Sets the visibility and position of the coordinate system icon CSIcon

 

    ^ Top of Page

Insert

Menu Description Command
Insert Block Inserts a Block or another drawing into the drawing InsertBlock
Hyperlink... Attaches a hyperlink to entities or modifies an existing hyperlink Hyperlink
Attach Drawing Attaches a drawing file as a Reference to the drawing AttachDrawing
Attach Image Attaches an image file as a Reference to the drawing AttachImage
Attach PDF Attaches one or multiple pages of a PDF document to your drawing AttachPDF
Attach PDF Attaches one or multiple pages of a PDF document to your drawing AttachPDF
Field... Creates Fields for annotations that are used to update information such as modification date, drawing name, and author Field
Rebuild Fields Manually updates Fields in specified annotations RebuildField
Object... Displays data from other programs in drawings (such as text documents, spreadsheets, or images) InsertObject

 

    ^ Top of Page

Format

Menu Description Command
Layer... Controls Layers and Layer properties Layer
Layer Tools  
Line Style... Lets you create, load, and set LineStyles LineStyle
PDF Layer... Controls the layer visibility of a PDF Underlay LayersPDF
PDF Layer... Controls the layer visibility of a PDF Underlay LayersPDF
Line Style... Lets you create, load, and set LineStyles LineStyle
Line Color... Sets the LineColor for new entities LineColor
Line Weight... Sets LineWeight options LineWeight
Dimension Style... Creates and modifies DimensionStyles DimensionStyle
Point Style... Defines the type and size of point entities PointFormat
Print Style... Manages named PrintStyles PrintStyle
RichLine Styles... Creates and manages RichLineStyles RichLineStyle
Scale List... Customizes the list of scales for printing, managing PrintConfigurations, and scaling Viewports in layout Sheets EditScaleList
Table Style... Creates and manages TableStyles TableStyle
Text Style... Creates or modifies user-defined TextStyles and sets the active TextStyle TextStyle
Drawing Boundary Sets and controls drawing bounds DrawingBounds
Unit System... Sets coordinate and angle display formats and precision UnitSystem
Rename... Changes the names of objects Rename

 

    ^ Top of Page

Format > Layer Tools

Menu Description Command
Layer States Manager Saves, restores, and manages configurations of layer properties and states LayerState
Hide Layer Turns off the Layer of the specified entity HideLayer
Show All Layers Turns on all Layers ShowLayers
Freeze Layer Freezes the Layers of specified entities FreezeLayer
Thaw All Layers Thaws all Layers ThawLayers
Lock Layer Locks the Layers of specified entities LockLayer
Unlock Layer Unlocks locked Layers UnlockLayer
Isolate Layer Isolates the Layers of specified entities IsolateLayer
Unisolate Layer Undoes Layer isolation UnisolateLayer
Activate Layer Activates the Layer of a specified entity ActivateLayer
Entity to Active Layer Changes the Layers of specified entities to the active Layer ToActiveLayer
Change Entity's Layer Changes the Layer of specified entities to match a destination Layer MatchLayer
Delete Deletes Layers of specified entities and the entities themselves DeleteLayer
Restore Layer's State Restores previous Layer settings UndoLayer
Layer Preview... Previews the content of layers one by one for a set of specified layers LayerPreview

 

    ^ Top of Page

Dimension

Menu Description Command
Smart Creates Dimensions with a dimension type determined by the entity selected SmartDimension
Aligned Creates an aligned linear Dimension ParallelDimension
Linear Creates a linear Dimension LinearDimension
Baseline Continues a linear, angular, or ordinate Dimension from the baseline of the previous or specified Dimension BaselineDimension
Continue Continues a linear, angular, or ordinate Dimension from the second extension line of the previous or specified Dimension ContinueDimension
Ordinate Creates ordinate point Dimensions OrdinateDimension
CenterMark Creates a center mark or center lines for Circles and Arcs CenterMark
Diameter Creates diameter Dimensions for Circles and Arcs DiameterDimension
Radius Creates radial Dimensions for Circles and Arcs RadiusDimension
Angular Creates angular Dimensions AngleDimension
Arc Length Creates arc length Dimensions ArcLengthDimension
Jogged Creates jogged radius Dimensions for Circles and Arcs JoggedDimension
Leader Draws Leader lines and annotations SmartLeader
Tolerance... Creates datum indicators and basic dimension notation Tolerance
Align Text  
Oblique Modifies the orientation of existing linear Dimensions EditDimension Oblique
Override Overrides DimensionStyle variables OverrideDimensionStyle
Relate Dimension Reestablishes the relation of specified Dimensions to entities RelateDimension
Rebuild Updates Dimensions with the active DimensionStyle RebuildDimension, or -DimensionStyle Apply

 

    ^ Top of Page

Dimension > Align Text

Menu Description Command
Angle Rotates Dimension text EditDimensionText Angle
Center Centers Dimension text on the Dimension line EditDimensionText Center
Reset Undoes the movement of Dimension text ResetDimensionText, EditDimensionText Home
Left Left-justifies Dimension text along the Dimension line EditDimensionText Left
Right Right-justifies Dimension text along the Dimension line EditDimensionText Right

 

    ^ Top of Page

Draw

Menu Description Command
Line Creates straight line segments Line
InfiniteLine Draws infinite construction lines InfiniteLine
RichLine Creates RichLines RichLine
Ray Draws semi-infinite construction Lines Ray
3D Polyline Creates 3D PolyLines of straight line segments in 3D space PolyLine3D
PolyLine Creates 2D PolyLines PolyLine
Polygon Creates equilateral closed PolyLines Polygon
Rectangle Creates rectangular PolyLines Rectangle
Sketch Creates freehand lines Sketch
Arc Creates Arcs Arc
Circle Creates Circles Circle
Ring Creates filled Circles or Rings Ring
Spline Creates quadratic or cubic spline (NURBS) curves Spline
Ellipse Creates Ellipses or elliptical Arcs Ellipse
Point   
Centerline Creates CenterLines between pairs of Lines, Arcs, and PolyLine segments CenterLine
Block   
Cloud Creates revision clouds to indicate that certain areas require or contain revisions Cloud
Table... Creates Tables Table
Bound Area... Creates a PolyLine or Region from an enclosed area AreaBoundary
Hatch/Fill... Fills a specified boundary with a pattern, solid color, or gradient color Hatch, FillArea
Region Transforms an entity that encloses an area into a Region Region
Mask Covers existing entities with a blank area Mask
Shape   
Text   
Mesh   

 

    ^ Top of Page

Draw > Point

Menu Description Command
Multiple Points Creates multiple point entities Point Multiple
Single Point Creates a point entity Point
Mark Divisions Places evenly spaced point entities or Blocks along the length or perimeter of an entity MarkDivisions
Mark Lengths Places point entities or Blocks at measured intervals on an entity MarkLengths

 

    ^ Top of Page

Draw > Block

Menu Description Command
Define... Defines a Block from specified entities MakeBlock
Define BlockAttributes... Creates a BlockAttribute definition MakeBlockAttribute

 

    ^ Top of Page

Draw > Shape

Menu Description Command
Define Inserts a shape from a shape file into the drawing InsertShape
Load... Loads shape files for the use by the Shape command LoadShape

 

    ^ Top of Page

Draw > Text

Menu Description Command
Note Creates multiline Text entities Note
SimpleNote Creates singleline Text entities SimpleNote

 

    ^ Top of Page

Draw > Mesh

Menu Description Command
2D Solid Creates solid-filled 2D faces Solid
3D Face Creates 3D faces Face
3D Mesh Creates 3D PolygonMeshes Mesh
Revolved Creates rotated surfaces about specified axes RevolvedMesh
Tabulated Creates tabulated surfaces from path curves and direction vectors TabulatedMesh
Edge Creates 3D PolygonMeshes based on four adjoining edges EdgeMesh
Ruled Creates ruled surfaces between two curves RuledMesh

 

    ^ Top of Page

Modify

Menu Description Command
Properties Displays the Properties palette to modify properties of drawing entities Properties
Property Painter Applies properties of one entity to other entities PropertyPainter
Annotation Scaling  
Clip  
Entity  
Component  
Pattern... Creates multiple copies of entities in a pattern Pattern
Delete Removes entities from a drawing Delete
Discard Duplicates Removes duplicate entities or overlapping parts of entities from the drawing DiscardDuplicates
Copy Duplicates entities Copy
Offset Offsets linear entities in parallel orientation Offset
Mirror Creates a mirror image copy of entities Mirror
Change Length Lengthens or shortens entities EditLength
Move Displaces entities a specified distance in a specified direction Move
Rotate Rotates entities about a base point Rotate
Scale Enlarges or reduces specified entities equally in the X, Y, and Z directions Scale
Stretch Moves or stretches entities Stretch
Quick Modify Copies, moves, rotates, and scales entities in one operation QuickModify
Split Erases parts of entities or splits entities in two Split
Weld Joins two entities into a single entity Weld
Chamfer Bevels the edges of entities Chamfer
Fillet Rounds and fillets the edges of entities Fillet
Extend Extends entities to meet other entities Extend
Trim Trims entities at a cutting edge defined by other entities Trim
Explode Breaks complex objects into their component entities Explode

 

    ^ Top of Page

Modify > Annotation Scaling

Menu Description Command
Add/Remove Scales Adds and removes annotation scales for specified annotative entities AnnEntityScale
Add Current Scale Updates annotative entities to support the drawing's active annotation scale AnnEntityScaleAdd
Remove Current Scale Updates annotative entities to remove the drawing's active annotation scale from the entities' annotation scales AnnEntityScaleRemove
Match Scale Positions Resets all scale representations of specified annotative entities to their original positions AnnReset

 

    ^ Top of Page

Modify > Clip

Menu Description Command
Reference Defines clipping boundaries to suppress display of portions of a Block or Referenced drawing ClipReference
Image Defines a clipping boundary to hide portions of a referenced image ClipImage
PDF Underlay Clips a PDF Underlay at a specified boundary ClipPDF
PDF Underlay Clips a PDF Underlay at a specified boundary ClipPDF
Viewport Clips the display of Viewports on the active Sheet at irregular shapes ClipViewport

 

    ^ Top of Page

Modify > Entity

Menu Description Command
Block Attribute Modifies BlockAttributes EditBlockAttribute, -EditBlockAttribute
Annotation... Edits items such as single-line Text, Dimension text, Leader annotation, and BlockAttribute definitions EditAnnotation
Hatch... Modifies existing Hatches or color gradient fills EditHatch
PolyLine Edits PolyLines, PolyLine vertices, and 3D PolygonMeshes EditPolyLine
RichLine... Edits intersecting and adjoining RichLines, breaks and welds RichLines, and adds or deletes vertices to or from existing RichLines EditRichLine
Tolerance... Modifies geometric Tolerances EditTolerance
Table Text... Changes text in a Table cell EditTable
Table Cells Inserts, deletes, merges, or resizes cells, rows, and columns in Tables EditTableCell

 

    ^ Top of Page

Modify > Component

Menu Description Command
Edit... Edits in-place individual Elements within Blocks or References EditComponent
Add Elements Adds Elements to Block definitions or References ChangeElements Add
Remove Elements Remove Elements from Block definitions or References ChangeElements Remove
Edit Base Point Sets new insertion base points for Block definitions EditBasePoint
Save and Close Saves modifications done during in-place editing of Block defintions or References and exits Component editing mode SaveComponent
Close Terminates in-place editing of a Block definition or a Reference CloseComponent

 

    ^ Top of Page

Tools

Menu Description Command
Properties... Displays/hides the Properties palette Properties, HideProperties
References Manager... Displays/hides the References palette References, HideReferences
Display Order Changes the display order of drawing entities and inserted images in the drawing DisplayOrder
Inquiry  
Open Reference Opens a Referenced drawing in a new drawing window OpenReference
Run Script... Executes a sequence of commands from a script LoadScript
Load Application... Loads applications for use in the program LoadApplication
CCS Manager... Manages Custom Coordinate Systems (CCSs) CSStyle
New CCS Sets, saves, and restores Custom Coordinate Systems CCS
Standards  
Entity Group  
Customize Interface... Manages customized user interface elements such as menus, toolbars, shortcut menus, keyboard shortcuts, and mouse actions Customize
Options... Configures program operating parameters Options
Options... Configures program operating parameters Options
Mouse Gestures... Customizes mouse gestures Gesture

 

    ^ Top of Page

Tools > Inquiry

Menu Description Command
Get Area Calculates the area and perimeter of entities or of defined areas GetArea
Get Distance Measures the distance and angle between two points GetDistance
Get Coordinate Displays the coordinate values of a location GetXY
Get Properties Displays information about specified entities GetProperties

 

    ^ Top of Page

Tools > Standards

Menu Description Command
Drawing Standards... Associates drawing standards to the current drawing, determines the drawing categories to check, and sets notification and audit options DrawingStandards
Verify Standards... Verifies that the drawing conforms to industry, corporate, and custom standards VerifyStandards

 

    ^ Top of Page

Tools > Entity Group

Menu Description Command
Quick Group Quickly creates EntityGroups QuickGroup
Quick Ungroup Quickly ungroups EntityGroups QuickUngroup
Edit EntityGroup Adds and removes entities to or from EntityGroups, or renames EntityGroups EditEntityGroup

 

    ^ Top of Page

Window

Menu Description Command
Close Closes the drawing but does not exit the program Close
Close all Closes all open drawings but does not exit the program CloseAll
Cascade Cascades drawing windows Windows Cascade
Tile Horizontally Tiles drawing windows horizontally Windows Tile Horizontal
Tile Vertically Tiles drawing windows vertically Windows Tile Vertical

 

    ^ Top of Page

Help

Menu Description Command
Help... Displays online help Help
License... Displays the license agreement ShowLicense
License... Displays the license agreement ShowLicense
About... Displays information about the program About
About... Displays information about the program About

 

    ^ Top of Page



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Command Reference: Commands by Menu Order
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.