Hide Table of Contents

Customizing the User Interface

The Customize command lets you customize user interface elements such as menus, toolbars, ribbon tabs and panels, quick access toolbar, and working spaces.

The Customize command lets you customize menus and toolbars.

The Customize command lets you customize menus and toolbars.

This topic discusses:

Managing Customization Files

You can manage the customization files you use. Customization files store the elements that comprise the user interface.

To manage customization files:

  1. Do one of the following:
    • Click Tools > Customize Interface on the menu.
    • Click Manage > Customization > Interface on the ribbon.
    • Type Customize at the command prompt.
  2. In the Customize dialog box, in Source, select one of the following:
    • All Customization Files to become the base for adding or modifying interface elements.
    • A specific customization file (.xml format) on which to work.
  3. Click Load customization file  to load a customization file located outside the default folder for customization files.
  4. Click Create customization file  to create a new customization file. In the Create Customization File dialog box, for:
    1. Name, type the name for the new customization file.
    2. Path, accept the location for the new file or browse to a location.

Managing Commands

Use the Commands page of the Customize dialog box to manage commands and command sequences for use in user interface elements.

To manage commands for use in user interface elements:

  1. In the Customize dialog box, click Commands .
  2. To add a command to the list of commands, click Add Command .

    An empty command entry is added to the commands list, labeled "Command" as placeholder for a new command.

    See below for a description to edit command entries.

  3. To remove a command from the commands list, click Remove Command .
  4. To expand the Icon Explorer, click Show icon explorer .

    In Filter, select whether to show All Icons, Small Icons, or Large Icons in the Icon Explorer.

    In Filter, select whether to show All Icons, Light Icons, Dark Icons, or a specific group of icons (such as Command Icons, Dimensioning Icons, Zoom Icons) in the Icon Explorer.

    In Filter, select whether to show All Icons, Small Icons, or Large Icons in the Icon Explorer.

    In Filter, select whether to show All Icons or a specific group of icons (such as Command Icons, Dimensioning Icons, Zoom Icons) in the Icon Explorer.

  5. Click OK.

To edit command entries:

  1. In the Customize dialog box, in the commands list, select a command entry.
  2. In the Name field, label the command entry.
  3. For Command string, type a command, command sequence, or command option.

    Start the expression with ^C^C to ensure a running command is cancelled when invoking the command or command sequence.

  4. To expand the Icon Explorer, click Show icon explorer .
  5. From the Icon Explorer drag a small icon and a large icon to the corresponding Small and Large fields of the new command entry. These icons are used for menus and toolbars.

    From the Icon Explorer drag a light icon and a dark icon to the corresponding Light and Dark fields of the new command entry. These icons are used for menus and toolbars.

    From the Icon Explorer drag an icon to the Icon field of the new command entry. The icons are used for menus and toolbars.

    The location and file name of the icons appear in Small icon location and Large icon location.

    The location and file name of the icons appear in Light icon location and Dark icon location.

    The location and file name of the icons appear in Small icon location and Large icon location.

    The location and file name of the icon appear in Icon location.

  6. For Description, type a description to display in the status line when you move the pointer over the corresponding command in a menu or toolbar.

Managing the Interface

Managing the Interface: Menus and Toolbars

Managing the Interface: Menus and Toolbars

Use the Interface page of the Customize dialog box to create and modify quick access toolbars, ribbon tabs and panels, menus, and toolbars.

Use the Interface page of the Customize dialog box to create and modify menus and toolbars.

Use the Interface page of the Customize dialog box to create and modify menus and toolbars.

You can rearrange existing items, add new items, and modify entries and command sequences associated with them.

To remove a UI item, select it and click Remove .

This section discusses:

Quick Access Toolbar

The Quick Access Toolbar is a small toolbar that lets you access frequently used commands.

To manage quick access toolbars:

  1. In the Customize dialog box, click Interface .
  2. Expand Quick Access Toolbars.
  3. In Quick Access Toolbar, select whether to display All Quick Access Toolbars of the current customization source or a specific quick access toolbar.
  4. Expand the quick access toolbar you want to edit.

    The command entries of the toolbar and their icons display.

  5. Click Show command explorer to expand the Command Explorer.
  6. In Command Explorer, select a command entry and drag it to the quick access toolbar.
  7. Use the Find box to type a search string to reduce the entries in the Command Explorer.

To create a new quick access toolbar:

  1. In the Customize dialog box, expand Quick Access Toolbars.
  2. In the list of quick access toolbars, right-click and click New Quick Access Toolbar.

    A new quick access toolbar is added to the list.

  3. Right-click the quick access toolbar and click Rename to edit the name.
  4. Add command items to the quick access toolbar.

To add commands to a quick access toolbar:

  1. In the Customize dialog box, expand a quick access toolbar.
  2. Navigate to the location in the quick access toolbar where you want to place the new item.
  3. Click Show command explorer to expand the Command Explorer.
  4. In Command Explorer, select a command entry and drag it to the quick access toolbar.

To rename an entry in a quick access toolbar:

  1. In the Customize dialog box, expand a quick access toolbar.
  2. Right-click the entry to rename and click Rename.
  3. Type new text for the quick access toolbar entry.

    Note: The command sequence behind the entry does not change.

To delete an entry from a quick access toolbar:

  1. In the Customize dialog box, expand a quick access toolbar.
  2. Right-click the entry to delete and click Delete.

Ribbon Tabs and Panels

Ribbons provide tabs that organize application feature categories, such as drafting and modification (on the Home tab), inserting, and viewing.

Each ribbon tab is composed of panels, which are a set of closely related commands needed to complete a task.

To manage ribbon tabs:

  1. In the Customize dialog box, click Interface .
  2. Expand Ribbon, then Tabs.
  3. In Tabs, select whether to display All Tabs of the current customization source or a specific tab.
  4. Expand the tab to view or edit.

    The tab panels display.

  5. Click Show ribbon explorer  to expand the Ribbon Explorer.
  6. Click a panel in the Tabs tree view to view a panel in the Panel Preview.

To create new ribbon tabs:

  1. On the Interface page of the Customize dialog box, expand Ribbon, then Tabs.
  2. In the Tabs tree view, right-click and click New Tab.

    A new tab is added to the list.

  3. Click Show ribbon explorer to expand the Ribbon Explorer.
  4. In Appearance, edit the tab name in Display text.
  5. Add panels to the tab.

To add panels to ribbon tabs:

  1. On the Interface page of the Customize dialog box, expand Ribbon, then Tabs.
  2. Click Show ribbon explorer to expand the Ribbon Explorer.
  3. Select an entry in Ribbon Panel Explorer and drag it into a tab.

    Note: You can drag a panel to another position in the Tabs tree view list at any time.

  In the Tabs tree view, right-click to create, rename, duplicate, or delete tabs.

To manage ribbon panels:

  1. In the Customize dialog box, click Interface .
  2. Expand Ribbon, then Panels.
  3. In Panels, select whether to display All Panels of the current customization source or a specific panel.
  4. Expand the panel to view or edit.

    The panel items display.

  5. Click Show ribbon explorer  to expand the Ribbon Explorer.
  6. Click a panel in the Panels tree view to view a panel in the Panel Preview.
  7. Click a command in the Panels tree view to highlight a command button in the Panel Preview.

To create new ribbon panels:

  1. On the Interface page of the Customize dialog box, expand Ribbon, then Panels.
  2. Click Show ribbon explorer to expand the Ribbon Explorer.
  3. In the Panels tree view, right-click and click New Panel.

    A new panel is added to the list.

  4. In Appearance, edit the panel name in Display text.
  5. Add panel items to the panel as described next.

To add new items to a new ribbon panel:

  1. On the Interface page of the Customize dialog box, expand Ribbon, then Panels.
  2. Click Show ribbon explorer to expand the Ribbon Explorer.
  3. In the Panels tree view, right-click and click New Row.

    A new row is added to the list.

  4. From the Command Explorer, drag a command entry onto the new row.
  5. Click In Appearance, specify the Button style.
  6. Add more panel elements (see Ribbon Panel Elements).

Ribbon Panel Elements

A panel can contain the following elements:

Type Description
Row Contains sub-panels, drop-down menus, and command buttons.
Sub-panel Creates an area with rows within a panel. They cannot contain drop-down menus or command buttons.
Drop-down menu Contains command buttons. In Appearance, specify the drop-down behavior, split button list style, and button style for the commands.
Command button Executes commands from a ribbon. Command buttons usually have icons associated with them. In Appearance, specify the button style of the command button.
Separator Separates groups of similar commands in drop-down menus.

Placing Panel Elements

To create a new row, sub-panel, or drop-down menu, right-click in the Panels tree view.

To place a command button or a control element in a panel, drag it from the Command Explorer into a panel row or panel drop-down menu.

Setting the Appearance of Drop-down Menu Buttons and Command Buttons

The Appearance area of the Ribbon Explorer lets you specify the display mode of drop-down menu buttons (split buttons) and command buttons.

Drop-down Behavior

You can define the display mode of split buttons that display drop-down menus in panels:

Type Description
Split with recent Displays the icon and text of the recently selected drop-down menu item.
Split with recent (Static) Displays the icon of the recently selected drop-down menu item, but the text is static (the text you defined as the drop-down menu title in the panel tree view).
Split Uses a fixed icon. The drop-down menu displays text items. If the icon is not specified, Split behaves like Split with recent.
Drop-down menu with recent Same as Split with recent.
Drop-down menu Same as Split.
Split Button List Styles

You can define the display of drop-down menu list buttons. The default is Icons and Text, but you can specify Icons and Bold Text or Icons only.

Button Styles

You can define the button style for drop-down menu buttons and command buttons: Large buttons with text (vertical), Large buttons without text, Small buttons with text, or Small buttons without text. Do not use small buttons on stacked rows on panels.

  In the Panels tree view, right-click to create, rename, duplicate, or delete panels. Right-click panel items to add command buttons, drop-down lists, rows, sub-panels, and separators.

Menus and Toolbars

To manage menus and toolbars:

  1. In the Customize dialog box, click Interface .
  2. Expand Menus.
  3. In Menu, select whether to display All Menus of the current customization source or a specific menu (such as File, Edit, or View).
  4. Expand the menu you want to edit.

    The command entries of the menu and their icons or sub menus display.

  5. Expand Toolbars.
  6. In Toolbar, select whether to display All Toolbars of the current customization source or a specific toolbar (such as Standard, Layers, or Properties).
  7. Expand the toolbar you want to edit.

    The command entries of the toolbar and their icons display.

  8. To remove a selected command from a menu or toolbar, click Remove .
  9. To expand the Command Explorer, click Show command explorer .
  10. To insert a command or option in a menu or toolbar, select an entry in Command Explorer and drag it to a menu or toolbar.
  11. Use the Find box to type a search string to reduce the entries in the Command Explorer.

Note: Use the Commands section of the Customize dialog box to add and edit commands. You cannot edit the command or command sequence behind a menu or toolbar entry in the Interface section.

To create a new menu or new toolbar:

  1. In the Customize dialog box, expand Menus or Toolbars.
  2. In the list of menus or toolbars, right-click and click New menu or New toolbar.

    A new menu or toolbar is added to the list.

  3. Right-click the menu or toolbar and click Rename to edit the name.
  4. Add command items to the menu or toolbar as described next.

To insert an entry into a menu or toolbar:

  1. In the Customize dialog box, expand a menu or toolbar.
  2. Navigate to the location in the menu or toolbar where you want to place the new item.
  3. Click Show command explorer to expand the Command Explorer.
  4. In Command Explorer, select a command entry and drag it to the menu or toolbar.
  5. Right-click a menu or toolbar and click New separator to insert a separator.
  6. Right-click a menu and click New sub menu to insert a sub menu.

To rename an entry in a menu or toolbar:

  1. In the Customize dialog box, expand a menu or toolbar.
  2. Right-click the entry to rename and click Rename.
  3. Type new text for the menu or toolbar item.

    Note: The command sequence behind the item does not change.

To delete an entry in a menu or toolbar:

  1. In the Customize dialog box, expand a menu or toolbar.
  2. Right-click the entry to delete and click Delete.

Setting Mouse Actions

Use the Mouse Actions page of the Customize dialog box to define what happens when you right-click or double-click the mouse. You can also define common and contextual shortcut menus.

To define actions for right-clicks:

  1. In the Customize dialog box, click Mouse Actions .
  2. Expand Right Clicks.
  3. For Right Click, Shift+Right Click, Ctrl+Right Click, and Ctrl+Shift+Right Click select a menu, command, command sequence, or option to issue.

To define actions for double-clicks:

  1. In the Customize dialog box, expand Double Clicks.
  2. In Entity, select an entity type.
  3. In Command Name, select a command to execute when you double-click the specified entity.
  4. To add an entity type to the list, click Add .
  5. To expand the Command Explorer to drag a command name to an entity type in the list, click Show command explorer .
  6. To remove an entity type from the list, click Remove .

To manage shortcut menus:

  1. In the Customize dialog box, click Mouse Actions .
  2. Expand Shortcut Menus > Common or Contextual.
  3. In Menu, or in the list of shortcut menus, select a shortcut menu. You can edit common shortcut menus:
    • The Default Menu displays if you right-click when no command is active.
    • The Edit Menu displays if you right-click when drawing entities are selected.
    • The Command Menu displays if you right-click when a command is active and no shortcut menu is defined for that command.
    • The contextual menus display if you right-click when a specific command is active.
  4. To insert a command or option in a shortcut menu:
    1. Click Show command explorer .
    2. Under Command Explorer, select an item and drag it to a menu or toolbar.
  5. To replace a command or option, select an item in a shortcut menu, then select another command or option in Command.
  6. To remove a command from a shortcut menu, select an item in a shortcut menu and click Remove (the option is available for contextual shortcut menus only).

Managing Keyboard Shortcuts

Use the Keyboard page of the Customize dialog box to adjust keyboard shortcuts.

To manage keyboard shortcuts:

  1. In the Customize dialog box, click Keyboard .
  2. Expand Keyboard Shortcuts > Shortcut Keys and Keyboard Shortcuts > Override Keys.
  3. To add new shortcuts to the lists, click Add , and in the Key column of the new row that appears in the list, hold a special key like Ctrl, Alt, or Shift and press another key on the keyboard for the shortcut.
  4. To associate an existing command sequence to a shortcut, click Show command explorer to expand the Command Explorer, then drag the command sequences to a new or existing keyboard shortcut in the list.

    For override keys, type a Function description and create a Macro.

  5. To remove a keyboard shortcut from the list, click Remove .

  See the Keyboard Shortcuts appendix for a summary of built-in function keys, keyboard shortcuts, and temporary overrides.

Managing User Interface Profiles

Use the UI Profile page of the Customize dialog box to manage user interface elements such as quick access toolbars, ribbon tabs, menus, toolbars, and other elements in individual UI profiles (also referred to as workspaces).

Use the UI Profile page of the Customize dialog box to manage menus, toolbars, and other elements in individual UI profiles (also referred to as workspaces).

Use the UI Profile page of the Customize dialog box to manage menus, toolbars, and other elements in individual UI profiles (also referred to as workspaces).

Customization files store the UI profiles (workspaces) that comprise the user interface. See Managing Customization Files.

To manage user interface profiles:

  1. In the Customize dialog box, click UI Profiles .

    Note: You can also use the UIProfile command to open the UI Profiles page of the Customize dialog box.

  2. In Show, select one of the following:
    • All UI Profiles to become the base for adding or modifying user interface profiles.
    • A specific user interface profile.
  3. Expand UI Profiles.
  4. In the list, select a user interface profile (workspace).
  5. Do any of the following:
    • Double-click the Active column to make a workspace the current workspace.
    • Click New  to create a new workspace.
    • Click Delete  to remove the selected workspace. The Delete option is irrevocable after you click OK or Apply.
    • Right-click and click Rename to rename a workspace.
    • Double-click a Description cell to add or edit a workspace description.
  6. Click Apply.

To assign a quick access toolbar to a workspace:

  1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Quick Access Toolbar.
  2. In the list, click the Quick Access Toolbar cell of a workspace entry and select a quick access toolbar name.
  3. Click Apply.

To assign a ribbon tab to a workspace:

  1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Ribbon Tabs.
  2. Click Show ribbon tab explorer to expand the Ribbon Tab Explorer.
  3. In Ribbon Tab Explorer, select a ribbon tab name and drag it to the Ribbon Tabs cell of a workspace.
  4. You can:
    • Drag a ribbon tab entry to another position in the ribbon.
    • Right-click a ribbon tab entry and click Remove entry to delete the entry.
  5. Click Apply.

  Note: Do not assign ribbon tabs to workspaces that are designed to work with menus.

To assign menus to a workspace:

  1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Menu Bar.
  2. Click Show menu explorer to expand the Menu Explorer.
  3. In Menu Explorer, select a menu name and drag it to the Menu Bar cell of a workspace.
  4. You can:
    • Drag a menu entry to another position in the menu bar.
    • Right-click a menu entry and click Remove entry to delete the entry.
  5. Click Apply.

  Note: Do not assign menus to workspaces that are designed to work with ribbons.

To assign toolbars to display to a workspace:

  1. In the Customize dialog box, on the UI Profiles section, expand UI Profiles > Toolbars.
  2. Click Show toolbar explorer to expand the Toolbar Explorer.
  3. In Toolbar Explorer, select a toolbar name and drag it to the Toolbars Displayed cell of a workspace.

    The order of the toolbar entries does not matter.

  4. To delete an entry from the list of toolbars, right-click the entry and click Remove entry.
  5. Click Apply.

  Note: For workspaces that are designed to work with ribbons, the list of toolbars to display typically remains empty.

To set the UI elements to display when the workspace changes:

  1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Elements.
  2. Double-click cells in the table to select or clear the UI elements to display when the workspace changes:
    • Status Bar
    • Command Window
    • Tool Matrix
    • Options toolbar
    • Properties palette
    • Layers Manager palette
    • References palette
    • Design Resources palette
    • Lighting palette
    • Cloud Storage palette
  3. Click Apply.

Access

Command: Customize

Menu: Tools > Customize Interface

Ribbon: Manage > Customization > Interface



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Customizing the User Interface
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.