Hide Table of Contents

Working with TextStyles

Use the TextStyle command to create, edit, activate, or delete TextStyles in drawings.

When you add Notes or SimpleNotes to a drawing, it uses the active TextStyle. A TextStyle is defined by font, type face characteristics, size, and other properties.

You can use TrueType fonts or compiled shape fonts (of type .shx).

The TextStyle command loads fonts from files and customizes them to the drawing requirements.

You can define TextStyles to apply annotative scaling for Notes and SimpleNotes.

To create TextStyles:

  1. Click Format > Text Style (or type TextStyle).

    In the Options dialog box, the Drafting Styles page opens and Text expands.

  2. Click New.
  3. In the Create new TextStyle dialog box, type a new name and click OK.

    The new TextStyle appears in Style.

  4. Under Text, set:
    • Font. Lists all installed TrueType fonts provided with your operating system by font family name. Fonts of type .shx are listed by the name of the file where they are stored.
    • Format. Lists formats you can apply to the font (Normal, Italic, Bold, Bold Italic, for example, for TrueType fonts). While creating a TextStyle, the command displays a default font style dependent on the selected font name. When you make changes to the default name in Style, a new default name is no longer suggested and your changes become the new default.
    • Big font. Lists all files that have big fonts which are stored in .shx files.
  5. Under Height, set:
    • Annotative Scaling. Specifies whether annotative scaling is used for Notes and SimpleNotes which apply the TextStyle you define. In Style, annotative TextStyles are marked with an .
    • Match text orientation to Sheet. Specifies whether the orientation of Notes and SimpleNotes in Viewports of layout Sheets follows the Sheet orientation.

      This option is available only if you selected annotative scaling.

    • Height or Sheet text height. Sets the TextStyle height in drawing units.
      • Height. If the TextStyle is not defined for annotative scaling: A numeric value sets the font at a fixed height that you cannot change when inserting a Text entity that uses the selected Font. Set Height to 0.0 if you need to change the TextStyle height.
      • Sheet text height. If the TextStyle is defined for annotative scaling: A numeric value sets the font at a fixed height that you cannot change when inserting a Text entity that uses the selected Font. Set Height to 0.0 if you need to change the TextStyle height.
  6. Under Orientation, set:
    • Backwards. Displays a mirror-image of the text. Applies to SimpleNotes, not Notes.
    • Upside down. Displays text upside down. Applies to SimpleNotes, not Notes.
    • Vertical. Aligns the text vertically. Applies to SimpleNotes, not Notes. This option is available only for *.shx font files that support dual orientation.
    • Angle. Defines the inclination of the characters in relation to a horizontal (X-axis) line. Values between 0 and 84.90 result in an inclination to the right (forward), values between 0 and -84.9 result in an inclination to the left (backward).
    • Spacing. Controls the width of the characters in relation to the height. This relation is called the aspect ratio.

    You can combine these settings, although in some cases the combination of properties can interfere with each other. Some fonts do not support all options.

  The Preview area displays the TextStyle you define with the specified font and parameters. You can edit the Preview text.

To edit TextStyles:

When you edit TextStyles, all existing Text entities that use the TextStyle automatically update to reflect the modified style.

  1. Click Format > Text Style (or type TextStyle).

    In the Options dialog box, the Drafting Styles page opens and Text expands.

  2. In Style, select a TextStyle.

    The Style list contains all TextStyles that are defined in the drawing. You cannot change the name of the Standard TextStyle, but you can edit its settings.

  3. Set options under Text and Orientation.

To activate a TextStyle:

The active TextStyle is used for the Note and SimpleNote commands.

  1. Click Format > Text Style (or type TextStyle).

    In the Options dialog box, the Drafting Styles page opens and Text expands.

  2. In Style, select a TextStyle.
  3. Click Activate.

To rename TextStyles:

  1. Select Format > Text Style (or type TextStyle).

    In the Options dialog box, the Drafting Styles page opens and Text expands.

  2. In Style, select a TextStyle.
  3. Click Rename.
  4. Type a new name in the Rename TextStyle dialog box and click OK.

To delete TextStyles:

  1. Click Format > Text Style (or type TextStyle).

    In the Options dialog box, the Drafting Styles page opens and Text expands.

  2. In Style, select a TextStyle.
  3. Click Delete.

    Note: You cannot delete a TextStyle that is currently used in the drawing.

  TextStyles are saved with the drawing file only with a reference to the corresponding font file. They are available any time you open the drawing if the corresponding font file exists in the program folders.

Access

Command: TextStyle

Menu: Format > Text Style



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Working with TextStyles
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.