Hide Table of Contents

Loading and Setting LineStyles

Use the LineStyle command to load and set LineStyles. Choose a LineStyle to display on the currently active segment of the drawing.

To set the LineStyles pattern definition and LineStyles definition file syntax, refer to Customizing LineStyles.

To load LineStyles:

  1. Click Format > Line Style (or type LineStyle).
  2. In the dialog box, click Load.

    The Load LineStyles dialog box displays the LineStyles contained in the .lin file.

  3. Click Browse to select a LineStyle file, and click Open.
  4. Select one or more LineStyles in the list.

    To select more than one LineStyle, press Ctrl and select multiple LineStyles.

  5. Click OK.

    The selected LineStyles appear in the Line Style dialog box. However, a selected LineStyle does not become the active LineStyle automatically. It is only added to the list of LineStyles that are available. You have to set the active LineStyle explicitly.

  6. Click OK.

To set the active LineStyle:

  1. Click Format > Line Style (or type LineStyle).
  2. In Show, select the LineStyles you want to appear in the dialog box:
    • All LineStyles
    • LineStyles in Use
    • Referenced LineStyles
  3. Click Reverse Filter to invert the option you selected.
  4. For example, reversing LineStyles in Use shows all unused LineStyles.
  5. The LineStyle list shows the dash-dot patterns for the LineStyles. These LineStyles can be loaded from LineStyle definition files or inherited from drawings.
  6. Every drawing has three LineStyle definitions:
    • Continuous. Solid line without a pattern.
    • ByBlock. Entities are drawn as continuous lines until they are grouped into a Block. The entities then inherit the LineStyle setting when you insert the Block into the drawing.
    • ByLayer. New entities adopt the LineStyle of the Layer on which they are placed.
  7. Select the LineStyle you want to activate.
  8. Click Activate.

    The LineStyle is used when you draw a new entity. The LineStyle of the active Layer does not change.

To delete a LineStyle:

  1. Click Format > Line Style (or type LineStyle).
  2. Select one or more LineStyles in the list.
  3. Click Delete.

  You can only delete LineStyles that are currently not in use.

To edit a LineStyle:

  1. Click Format > Line Style (or type LineStyle).
  2. Select a LineStyle in the list.
  3. Click Show Parameters, and under Parameters, edit the options:
    • Name. Specifies the name of the LineStyle definition to store in the drawing.
    • Description. Specifies a Note or symbolic representation for the LineStyle to display in the Line Style dialog box.
    • Global scale. Scales the LineStyles so they fit to the units of measurement.
    • Entities scale. Sets a LineStyle scale factor for new entities relative to the general LineStyle scale factor.
    • Scale based on sheet's units. Forces LineStyles to be drawn at the same scale as the Viewport scale. Clear the option to scale LineStyles equally in the model and Sheet.

To modify the LineStyle of existing drawing entities:

Do one:

  • Change the LineStyle property in the Properties palette.
  • Select one or more entities in the drawing and select a different LineStyle in the Properties toolbar.
  • Use the ModifyProperties command. You must use the exact name of the loaded LineStyle you want to apply.

Access

Command: LineStyle

Menu: Format > Line Style



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Loading and Setting LineStyles
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.