Hide Table of Contents

Creating Regions

The Region command transforms an entity that forms a closed shape into a 2D Region entity. You can use the command to combine all entities of any closed loop – such as closed PolyLines (including polygons and Rings), Circles, Ellipses, and closed Splines – into one entity.

After creating a Region, there is little visual difference on screen except when the original entity had a width, thickness, or LineWeight. This information is lost when you create a region from such entities.

A Region is a planar solid entity. If you set ShadeView mode to Flat, you will see that the Region is a surface, not simply a boundary contour.

If the source entities of the Region are hatched, the Hatch loses associativity to the boundary. You must apply the Hatch to the Region entity again.

You can also create Regions with the AreaBoundary command by setting the resulting entity type for boundaries to Region.

To create Regions:

  1. Click Draw > Region (or type Region).
  2. In the graphics area, select closed drawing entities to transform into a Region.
  3. Press Enter.

Access

Command: Region

Menu: Draw > Region



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Creating Regions
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP04

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.