Hide Table of Contents

Constructing Splines

A Spline is a smooth curve that is fit to a set of points. You can create a non-uniform rational B-spline or NURBS curve for any number of fit points. You can also fit the Spline to the specified points within a specified tolerance value.

To construct Splines:

  1. Click Draw > Spline (or type Spline).
  2. In the graphics area, specify the:
    1. Start point of the Spline.
    2. Next fit point of the Spline.
  3. Do one:
    • In the graphics area, specify successive points to continue the Spline.
    • Specify the Fit tolerance option to define a fit tolerance and specify other spline points.
  4. To conclude the Spline, do one:
    • Press Enter and click in the graphics area to define the tangents at the start and end points of the curve.
    • Specify the Close option to close the Spline curve and click in the graphics area to define the tangent to the curve at the closing point.

   

  After you specify a fit tolerance, the fit tolerance applies to all fit points until you change it. Setting the fit tolerance to zero forces the Spline to pass through the fit points.

Note: You can use EditPolyLine to convert a PolyLine to a Spline.

Access

Command: Spline

Menu: Draw > Spline



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Constructing Splines
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.