Hide Table of Contents

Creating Patterns of Entities

Use the Pattern command to create copies of specified entities

Use the Pattern command to create copies of specified entities in a circular pattern or in a linear matrix.

The copied entities inherit all properties of the original entities such as Layers, LineColors, LineStyles, and LineWeights.

Circular patterns

To create a circular pattern:

  1. Do one of the following:
    • On the ribbon, click Home > Modify > Pattern.
    • On the menu, click Modify > Pattern.
    • Type Pattern.
  2. In the dialog box, under Pattern type, select Circular.
  3. Click Specify entities , select the entities to generate the pattern, and press Enter to complete the selection.

    The dialog box disappears when your selection is complete.

    In the dialog box, the collection of specified entities is referred to as elements.

  4. Under Settings, set:
    • Base pattern on. Select an option:
      • Angle Between and Total Number of Elements
      • Fill Angle and Angle Between Elements
      • Fill Angle and Total Number of Elements
    • Angle between (if required). Specifies the included angle between the base points of the pattern entities and the center of the pattern. Type a positive value or click Pick angle between items .
    • Fill angle (if required). Type a positive or negative value or click Pick angle to fill . The default for the angle to fill is 360° - a full circle pattern. A value of zero is not allowed.
    • Total number (if required). Specifies the resulting number of copies in the circular patten (including the source).
  5. Under Element base point, set:
    • Use last entity selected. Uses the base point from the last entity you specified.
    • X and Y. Type values or click Pick base point  to specify the base point in the graphics area.
  6. Under Axis point, for X and Y, type values for the center point of the pattern or click Pick center point .
  7. Select Orient elements about axis to rotate the copies as they are patterned, otherwise they maintain the alignment of the source entities.
  8. Click OK.

  Note: In the Pattern dialog box, click Preview to check the resulting pattern without creating it. You can use this option and return to the dialog box as many times as needed, then click OK to generate the pattern.

Linear patterns

To create a linear pattern:

  1. Do one of the following:
    • On the ribbon, click Home > Modify > Pattern.
    • On the menu, click Modify > Pattern.
    • Type Pattern.
  2. In the dialog box, under Pattern type, select Linear.
  3. Click Specify entities , select the entities to generate the pattern, and press Enter to complete the selection.

    The dialog box disappears when your selection is complete.

    In the dialog box, the collection of specified entities is referred to as elements.

  4. Under Settings, set:
    • For Horizontal axis and Vertical axis, type the number of copies.
    • For Spacing between elements on, define spacing between the copies and an angle for the pattern:
      • Horizontal axis. Specifies the distance between columns. Click Select column offset  to identify the offset using two points in the drawing. If the column offset is a negative value, columns are added to the left.
      • Vertical axis. Specifies the distance between rows. Click Select row offset  to identify the offset using two points in the drawing. If the row offset is a negative value, rows are added downward.
      • Pattern angle. Specifies the angle to control how the copies are arranged. Click Select angle  to specify the angle using the pointer.
  5. Click OK.

  Note: In the Pattern dialog box, click Preview to check the resulting pattern without creating it. You can use this option and return to the dialog box as many times as needed, then click OK to generate the pattern.

Patterns along a path

To create a pattern along a path:

  1. Do one of the following:
    • On the ribbon, click Home > Modify > Pattern.
    • On the menu, click Modify > Pattern.
    • Type Pattern.
  2. In the dialog box, under Pattern type, select Path.
  3. Click Specify entities , select the entities to align along a path, and press Enter to complete the selection.

    The dialog box disappears when your selection is complete.

    In the dialog box, the collection of specified entities is referred to as elements.

  4. Click Specify path  and select the entity that defines the path to align the specified entities along.

    The path can be a Line, PolyLine, Arc, Circle, Ellipse, or Spline.

  5. In Settings, set:
    • Base pattern on. Select an option:
      • Distance Between and Total Number of Elements. Allocates the copies along the path at specified intervals with the specified total number. If the calculated pattern length exceeds the length of the path, the distance between the copies is reduced.
      • Divide Equally. Allocates the number of copies evenly along the total length of the path.
      • Measure Equally. Allocates the copies along the path at intervals you specify.
    • Distance (if required). Specifies the intervals between the copies. Click Specify spacing between elements  to identify the distance in the graphics area.
    • Total number (if required). Specifies the resulting number of pattern copies in the path patten (including the source).
  6. Under Element base point, set:
    • Use last entity selected. Uses the base point from the last entity you specified.
    • X and Y. Type values or click Pick base point  to specify the base point in the graphics area.
  7. Under Rows, set:
    • Count. Specifies the number of rows in the pattern.
    • Distance. Specifies the distance between the rows. If the distance is a negative value, rows are added downward. Click Specify spacing between elements  to identify the distance in the graphics area.
  8. Under Element alignment, set:
    • Align elements with path. Aligns each pattern copy to be tangent to the path direction. Otherwise the copied entities maintain the orientation of the source entities.
    • Specify tangent direction . Specifies two points in the graphics area which represent the tangency of the copies relative to the path. Use EntitySnaps to refer to the geometry of source entities.

      Click Remove tangent direction to clear the tangent direction you previously specified.

    • Angle from tangent. Specifies the rotation angle for the copies relative to the specified tangent direction.
  9. Click OK.

  Note: In the Pattern dialog box, click Preview to check the resulting pattern without creating it. You can use this option and return to the dialog box as many times as needed, then click OK to generate the pattern.

Access

Command: Pattern

Ribbon: Home > Modify > Pattern

Menu: Modify > Pattern



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Creating Patterns of Entities
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.