Hide Table of Contents

Applying Chamfers

Use the Chamfer command to connect two Lines with a beveled corner. The selected entities do not have to intersect and they can overlap. If the entities overlap, they are trimmed to create the beveled corner.

You can specify a chamfer distance from the corner of adjacent Lines of both entities for nonsymmetrical chamfers. You can also define the connecting Line using a length and an angle.

Use Chamfer in plan view because chamfering operates on selection points and end points of entities.

  If you chamfer two Lines and both Lines are on the same Layer, the command places the chamfer Line on that Layer. If the Layers of the Lines differ, the command places the chamfer Line on the current Layer.

To apply chamfers:

  1. Click Modify > Chamfer (or type Chamfer).
  2. In the graphics area, select the first Line or specify an option:
    • Angle. Sets a chamfer length on the Line you first select and an angle for the second Line to create a chamfer Line.
    • Distance. Sets the chamfer distances. The default value for the first chamfer distance is the most recently used distance. The default value for the second distance is the value specified for the first chamfer distance. If you specify zero for both chamfer distances, the two Lines extend until they meet, if possible. In this way, the command implements an intersection and does not draw a chamfer Line.
    • Method. Indicates whether to use two distances (specified by the Distance option) or a length and an angle (specified by the Angle option) as the default for creating the chamfer.
    • Multiple. Lets you apply chamfers to multiple entities. By default, you complete a single chamfer. You are prompted repeatedly to select a first and a second entity to chamfer until you press Enter to complete the command. You can then change the chamfer distances or toggle the trim mode between chamfer operations.
    • Polyline. Lets you chamfer PolyLines treated as a single entity. The command chamfers all vertices of a PolyLine or polygon in one step and inserts chamfers at each vertex of the PolyLine where two Lines meet, if applicable. The Polyline option prompts for a 2D PolyLine, then reports the number of Lines processed and the number of Lines too short to be chamfered. The generated chamfer segments become part of the PolyLine.
    • Trim mode. Indicates whether to erase the Line segments that lie beyond the chamfer.
    • Undo. Reverses the previous chamfer, only if Multiple mode is active.
  3. Select the second Line.

    You can instead apply an acute corner by pressing Shift and specifying the second drawing entity. This method creates acute corners without changing the chamfer distances to join two end points.

Access

Command: Chamfer

Menu: Modify > Chamfer

Related Topics

Applying Fillets



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Applying Chamfers
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.