Hide Table of Contents

Extending Entities

Use the Extend command to edit entities so they have common boundary edges. Extend expands parts of entities to the intended boundary edge, letting you close polygons precisely or extend entities to the proper boundary edge. As drawing a entity expands, they do not change direction. A Line remains a Line, and an Arc remains an Arc.

To extend entities:

  1. Click Modify > Extend (or type Extend).
  2. In the graphics area, select entities to make up the boundary edges.

    The Extend operation does not affect these entities.

  3. Press Enter.
  4. In the graphics area, select the entity to extend or specify an option:
    • Crossing. Selects entities within and crossing a rectangle determined by two opposite points. If a crossing selection is not distinct, Extend resolves the selection by following the defined rectangle clockwise from the first point to the first entity encountered.
    • Crossline. Uses the fence selection method to extend the selected drawing entities.
    • Edge. Extends to a boundary edge that if extended, intersects the entity. The entities to extend do not have to actually intersect the boundary edge. To stretch to an implied intersection, select Edge followed by Extend.
    • Erase. Deletes unneeded entities without exiting the Extend command.
    • Project. Sets the projection mode to CCS (the X-Y plane of the current custom coordinate system), None, or View.
    • Undo. Reverses the most recent extend operation.
    • Shift + select. Lets you trim entities while you hold down Shift and select entities to trim.

    After you select entities, the selected entities are extended.

    If there is more than one way to extend an entity, the expansion of the selected entity occurs from the end point nearest to the pointer when you select the entity. If more than one boundary edge lies in the direction of the entity to extend, the entity is extended to the first boundary edge first.

    Clicking a second time continues the expansion to the second boundary edge.

  5. Press Enter.

Access

Command: Extend

Menu: Modify > Extend



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Extending Entities
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.