Hide Table of Contents

Setting User Preferences

The User Preferences page of the Options dialog box lets you define:

To set Drafting Options:

To set options for Geometric and Dimensional Constraints:

To set Custom Block Editor Options:

  • See the CBOptions command which opens the corresponding section of the Options dialog box.

To set Mouse Options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click User Preferences .

    • Type UserPreferences.
  2. Expand Mouse Options.
  3. Expand Options to set:
    • Reverse the zoom wheel direction. Changes the zoom direction of the mouse wheel.
    • Enable Click and drag. Lets you draw selection windows or use the Crossing method by clicking a point (and holding down the mouse button) and dragging the pointer to a second point. When cleared, you can draw selection windows or use the Crossing method by clicking two separate points.
    • Edit by double-clicking. Enables double-click editing behavior in the graphics area.
    • Display shortcut menus by right-clicking. Displays the context-sensitive shortcut menu when you right-click in the graphics area.
  4. Expand Fast Enter behavior to set Enable Enter on fast right-click. This executes Enter when you click in the time set for Fast click time. Click longer to display a context-sensitive shortcut menu.
  5. Expand Currently processing other command to set right-click behavior when running commands:
    • Displays the shortcut menu
    • Displays the shortcut menu only if command options are available
    • Is the same as pressing Enter (for example, to accept a command's option or to terminate a command)
  6. Expand Selected Entities to set right-click behavior when entities are selected and no command is active:
    • Displays the shortcut menu
    • Repeats the last command
  7. Expand Unselected Entities to set right-click behavior when no entities are selected and no command is active:
    • Displays the shortcut menu
    • Repeats the last command

To create and manage Aliases:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click User Preferences .

    • Type UserPreferences.
  2. Expand Aliases to manage keyboard shortcuts.

    Examples for alias commands include L for Line, C for Circle, or A for Arc.

  3. Use the following options:
    • New. Creates a new keyboard shortcut in the alias list. An entry is added to the list where you can type the command representing the keyboard shortcut and the alias name.
    • Delete. Removes the selected keyboard shortcut from the alias list.
    • Import. Imports an alias file (.xml, .ica, or .pgp files).
    • Export. Writes an .xml file to save the alias settings.

  Use the Find option to search for items in the Options dialog box.

Access

Command: UserPreferences, or Options

Menu: Tools > Options

Menu: Tools > Options

Menu: Application menu > Preferences



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Setting User Preferences
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.