Hide Table of Contents

Attaching Hyperlinks to Entities

The Hyperlink command attaches a hyperlink to an entity or modifies an existing hyperlink. Hyperlinks provide jumps to Web sites, email addresses, drawing files, or user-defined views in the current drawing.

To open the Hyperlink dialog box:

  1. Click Insert > Hyperlink (or type Hyperlink).
  2. Specify entities in the graphics area to which you want to apply hyperlinks, then press Enter.
  3. The Hyperlink dialog box appears.

To create a hyperlink to an existing file or web page:

  1. In the Hyperlink dialog box, click Existing File or Web Page.
  2. For Text, type a description for the hyperlink. Use this if the link itself is not meaningful enough.
  3. For Address, type the hyperlink.
  4. - or, click -
    • Current Folder to navigate to the file you to which you want to hyperlink. The drive or folder in Look In determines the content of the file list.
    • Browsed Pages (lists recently browsed Web sites from your Internet browser), then select a page from the list.
    • Recent Files (lists files recently used), then select a file from the list.
    • Click  to select a file in the Open dialog box.
    • Click Target Frame to select a location in a drawing file to which to hyperlink.
    • Click  to open your standard web browser to search for web site addresses.
  5. Click OK.

To create a hyperlink to a named view in the current drawing:

  1. In the Hyperlink dialog box, click Place in This Drawing.
  2. In Select a place in this drawing, select a user-defined view.
  3. Click OK.

To create a hyperlink to an email address:

  1. In the Hyperlink dialog box, click Email Address.
  2. For Email address, type an address.
  3. - or -
  4. In List of recent email addresses, select an email address.
  5. For Subject, type text to set a subject for the email.
  6. Click OK.
  7. When the hyperlink is invoked, your email software creates an email to the specified address.

To display the hyperlink tooltip:

  • Hover the pointer over an entity that contains a hyperlink.

To open the hyperlink:

  • Press Ctrl and click the entity that contains the hyperlink.

  Use the DetachLink command to detach hyperlinks from entities.

Access

Command: Hyperlink

Menu: Insert > Hyperlink

Keyboard Shortcut: Ctrl + K

Keyboard Shortcut: Ctrl + K

Keyboard Shortcut: Command + K



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Attaching Hyperlinks to Entities
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.