Performance Improvements

SOLIDWORKS 2019 includes performance and workflow changes across many areas for increased workflow complexity and larger models.

Installation Manager

The SOLIDWORKS® 2019 Installation Manager uses new download methods that can deliver up to twice the download speed compared to SOLIDWORKS 2018 and earlier.

The new download methods also provide a solution in cases where the Installation Manager failed to download installation files.

Detailing and Drawings

Performance when creating, opening, and editing hole tables has improved for large numbers of holes and for the combination of circular and noncircular holes.

The time it takes to switch from a model to its drawing under the following conditions is improved:
  • Both the model and its drawing are open.
  • You make changes in the model that do not change geometry.
  • The drawing has multiple sheets.
  • Automatic view update is on.

Model Display

SOLIDWORKS 2019 uses a new graphics architecture for parts and assemblies. This architecture provides a more responsive, real-time display especially for large models. It takes advantage of modern OpenGL (4.5) and hardware-accelerated rendering to maintain a high level of detail and frame rate when you pan, zoom, or rotate large models. There are no new user interface controls or settings. These performance improvements scale up with the higher-end graphics cards not fully supported in previous versions of SOLIDWORKS. These changes do not apply to drawings.

Pack and Go

When you select Include drawings, an option in System Options improves performance by limiting the search for drawings to specific folders. In Tools > System Options > External References, Include subfolders for drawings search in Pack and Go searches all subfolders for drawings. If you clear this option, SOLIDWORKS limits its search for drawings to the folders of the packaged models and folders specified in Tools > Options > File Locations > Referenced Documents.

Routing

Improved Feature Description
Routing Component Wizard When you use the Routing Component Wizard of the Routing Library Manager, the creation of routing library components is more efficient. The wizard displays only the essential tabs that you use to create routing components for different types of routes. The wizard responds faster when you switch tabs.

In the Routing Library Manager > Routing Component Wizard > Design Table Check tab, all component-specific column headers are displayed. The design table information is locked. You can edit column headers in the wizard and click Next to apply the changes to the design table.

In the Routing Library Manager > Routing Component Wizard > Component Attributes tab, components with multiple configurations load only the active configuration parameters. Other configuration data is loaded only when you select the configuration in the tab, which accelerates the tab's performance.

Piping and Tubing Database

Removing Components

To remove components from the database, in Select Components, select Remove Components and click Save.

Scanning Components

To list components not present in the database, in Scan for library components which are not in the database, click Scan. To include scanned components in the database, select Add Components and click Save.

The saving and scanning operations are faster. In Routing Library Manager > Piping and Tubing Database > Select Components > Scan for library components which are not in the database, select Scan excluded folders, and click Scan to scan components in the excluded folders. After the scanning process completes, the table displays components that are not in the database. In the table, you can edit and save Type and Sub Type for components.

When you click Save, the SOLIDWORKS software opens and saves only selected components with modified Type or Sub Type, and adds them to the database.

Import Data Dialog Box In Routing Library Manager > Piping and Tubing Database > Import Data, Start and Synchronize are not available simultaneously, to improve workflow.
Select Route and Component Type In the Route Component Wizard, the Select Route Type and Select Component Type tabs are combined to improve access.
Design Table Check In the Routing Component Wizard, when no Design Library exists for a part, the Design Table Check node is available. A message prompts you to create a new design table.

Previously, if no design table existed for a part, the Design Table Check node was unavailable and there was no option to create a new design table.

Images for Connectors in the Routing Library Manager The Routing Library Manager includes images in Route and Component Types, Routing Geometry, and Routing Functionality Points nodes of the Routing Component Wizard tab.

The images help you identify the components.

Toolbox

You can temporarily disable the automatic update of mates between a Toolbox component and a non-Toolbox component by clearing Automatic Update for Toolbox Mates. By disabling the automatic update, you can improve performance by making it quicker to edit mates, add mates, and manipulate components.

When you disable automatic mate updates:
  • Toolbox fasteners do not move if you move the components to which they are mated. Non-Toolbox components do move.
  • Performance improves when working in assemblies with several Toolbox components inserted and mated at the top level. For example, in assemblies with hundreds of fastener stacks at the top level, updating these mates can impact assembly performance when performing actions like solving mates, adding mates, and dragging components.
Performance improvements do not occur when Toolbox components are:
  • In subassemblies because the option affects solving mates at the top level only.
  • Patterned, because patterned instances do not use mates.

You must disable Automatic Update for Toolbox Mates each time you open an assembly. See Disabling Automatic Mate Updates in Toolbox.

SOLIDWORKS Electrical 3D

The performance is improved for Route Cables and Route Harness tools. The performance is faster when you use the Route Wires tool for routing of a large number of wires in an assembly.

When you click Tools > SOLIDWORKS Electrical > Electrical Component Wizard, Route Library Manager starts quickly and you can define components faster for SOLIDWORKS Electrical 3D.

SOLIDWORKS PDM

SOLIDWORKS PDM has improved performance of loads for large assemblies and complex reference structures in the Contains and Where Used tabs.

You can more quickly complete operations such as moving, dragging, browsing, renaming files, and adding a large number of files to a folder that has many files. You can also check-in assemblies with virtual components much faster.

The elimination of unnecessary interface refreshes speeds up your browsing experience, including folders with many locally cached files.

SOLIDWORKS Manage

Performance is improved when you synchronize SOLIDWORKS PDM objects with a large number of files and folders. The Synchronization details dialog box displays the synchronization steps.

To open the Synchronization details dialog box:

  1. Edit a SOLIDWORKS PDM object.
  2. In the dialog box, navigate to the Connection page.
  3. Select Show synchronization steps.
  4. Click OK.

Simulation

The latest Intel® Parallel Studio XE 2018 Cluster Edition replaces the existing Intel Fortran compiler, the Intel Math Kernel Library (MKL), and Intel MPI libraries used by the solvers.

The latest Intel 2018 Fortran compiler is used for part of the code that prepares data for the FFEPlus, Direct Sparse, and Intel Direct Sparse solvers, and computes stresses and strains. The Direct Sparse and the Intel Direct Sparse solvers are using the latest Intel 2018 MKL.

Improvements in overall stability and performance are expected as part of this upgrade (including performance improvement for offloaded simulation).

In addition, the Intel Direct Sparse solver is reconfigured for optimized performance for Linear static studies with multiple Load Cases. Improvement in solution time is observed for up to 25 load cases.

These improvements apply to the optimized solver performance for linear static studies with multiple load cases:

  • Only the Intel Direct Sparse solver (IDS) is configured for highly optimized performance (although the FFE plus solver also exhibits performance benefits, but not as great as the IDS.) If you select the Direct Sparse or the Large Problem Direct Sparse solvers, the software switches internally to the IDS solver.
  • This improves solver performance for Pressure, Force, and Torque load types. All other load types, connectors, and non-zero prescribed displacements should be exactly the same in all load cases to observe performance benefit. Load cases in the Load Case Manager are grouped together internally in such a way that load cases with similar features (such as mentioned above) are run together with the optimized performance scheme. Load cases with dissimilar features are run without any such optimization.
  • The optimized solver performance is not activated when no-penetration contact or virtual wall contact are present in any load case, and also in a case of a distributed beam load, which varies across load cases.
  • For a typical linear static study solved by the IDS equation solver, the most time-consuming part of the solution is the factorization of the global stiffness matrix, which consumes more than 80% of the total solution. In the optimized performance scheme, this factorization is done only once as the stiffness matrix is exactly the same for every load case. During the non-optimized performance scheme, the same factorization is repeated for the solution of each load case.

eDrawings

View manipulations and assembly component selections are faster in eDrawings®.

To improve performance, click Tools > Options > General and select Graphics boost and Fastest speed.