Hide Table of Contents

Microsoft Visual Studio Tools for Applications (VSTA)

Prerequisite Software

  • Microsoft Visual Studio 2015 (Community, Professional, Premium or Enterprise version) must be installed in order to record, edit, or debug VB.NET and C# macros using VSTA (3.0) 2015 in SOLIDWORKS 2018.

    Notes:

    • If you install a version of Microsoft Visual Studio that is later than 2015, you must ensure that a runtime version of Microsoft Visual Studio 2015 is also installed.
    • If you do not install Microsoft Visual Studio 2015 before you install SOLIDWORKS 2018, you will not be able to record, edit, or debug VSTA 3.0 macros. You will only be able to run VSTA 3.0 DLLs.
    • If you install Microsoft Visual Studio 2015 after you install SOLIDWORKS 2018, you must also install the VSTA runtime to record, edit, or debug VSTA 3.0 macros.

Installing VSTA

SOLIDWORKS 2017 and earlier used VSTA 1.0 to create, edit, and run .NET macros. SOLIDWORKS 2018 supports both VSTA 1.0 and VSTA (3.0) 2015. SOLIDWORKS 2018 activates VSTA (3.0) 2015 by default on all Windows versions. If VSTA 3.0 is enabled, .NET macros created in previous releases are converted when they are edited in this release. If VSTA 3.0 is enabled, be sure to back up your VSTA 1.0 macros before editing them in SOLIDWORKS 2018. If you do not want to convert your .NET macros, you can still edit and run VSTA 1.0 macros in this release, provided you choose to install VSTA 1.0 during the SOLIDWORKS installation and then de-select Tools > Options > System Options > General > Enable VSTA VERSION 3.0.

If you need to edit or run VSTA 1.0 macros on:

Windows 8 or later machines:

  1. During SOLIDWORKS 2018 installation, click Change above the Products window on the Summary screen.
  2. Expand SOLIDWORKS in the Product Selection window.
  3. Select Visual Studio Tools for Applications (VSTA).
  4. On the Summary screen, click Install Now.
  5. During installation, a message box appears with "An app on your PC needs the following Windows feature: .NET Framework 3.5 (includes .NET 2.0 and 3.0)." Click Download and install this feature. If you do not select to download and install this feature, then VSTA 1.0 will not work.
  6. Visual Studio Tools (1.0), Visual Studio Tools 2015, and other components are installed.

Windows 7 machines:

  1. During SOLIDWORKS 2018 installation, click Change above the Products window on the Summary page.
  2. Expand SOLIDWORKS in the Product Selection window.
  3. Visual Studio Tools for Applications (VSTA) is selected by default to install VSTA 2015 and VSTA 1.0. After installing .NET Framework 4.6.2, a system reboot occurs. When the system comes back up, Visual Studio Tools 2015 and the remaining components are installed. If VSTA is de-selected in the installer, then VSTA 1.0 is not installed.

After installing SOLIDWORKS 2018:

  • Select Tools > Options > System Options > General > Enable VSTA VERSION 3.0 to configure VSTA (3.0) 2015. When opened, .NET macros created in previous releases are converted to VSTA 2015, and an instance of Visual Studio 2015 opens the converted .NET macro for editing. See Prerequisite Software.
     
  • If you prefer to use VSTA 1.0 to edit or run VSTA 1.0 macros created in previous releases, you must first activate VSTA 1.0 by de-selecting Tools > Options > System Options > General > Enable VSTA VERSION 3.0.
    Note: You  must have installed VSTA during SOLIDWORKS 2018 installation.
     
  • Tools > Macro > Edit > Open > File name dropdown contains:
     
    • SW VBA Macros (*.swp)
    • SW VSTA VB Macro (*.vbproj)
    • SW VSTA C# Macro (*.csproj)
    • SW Macros (*.swp, *.swb, *.csproj, *.vbproj)
       
  • Tools > Macro > New > Save As > Save as type dropdown contains:
     
    • SW VBA Macros (*.swp)
    • SW VSTA VB Macro (*.vbproj)
    • SW VSTA C# Macro (*.csproj)
       
  • If you did not select to install VSTA when you installed SOLIDWORKS, then all of the SOLIDWORKS macro dialog dropdowns contain only:

        SW VBA Macros (*.swp)

  • You cannot modify or repair your SOLIDWORKS installation to add VSTA. You must uninstall and re-install SOLIDWORKS, selecting to install Visual Studio Tools for Applications (VSTA) during the installation.

Creating a .NET macro in SOLIDWORKS 2018 using VSTA 3.0

  1. Read Installing VSTA.
  2. In SOLIDWORKS, select Tools > Macro > New.
  3. In the Save As dialog, navigate to the directory where to save the project.
  4. Specify File name.
  5. In Save as type select SW VSTA VB Macro (*.vbproj) or SW VSTA C# Macro (*.csproj).
  6. Click Save.
  7. A new instance of Visual Studio 2015 opens. See Prerequisite Software.
  8. Solution Explorer shows:
    • The solution, VstaProjects.
    • The project name.
    • My Project
    • References (sldworks and swconst interop assemblies added from install_dir\api\redist\)
    • SolidWorksMacro.vb or SolidWorksMacro.cs.
  9. The SolidWorksMacro class is assigned a GUID attribute. If you change this attribute, the macro will not run.
  10. When you compile the macro, the project's configuration (Debug or Release) and output directory are not read. Only a release DLL is saved in project_folder/bin.

Editing a .NET macro created in SOLIDWORKS 2018 using VSTA 3.0

  1. Read Installing VSTA.
  2. In SOLIDWORKS, select Tools > Macro > Edit.
  3. In the Open dialog, navigate to the project folder.
  4. Select SW Macros in the project type dropdown.
  5. Select the *.vbproj or *.csproj project file.
  6. Click Open.
  7. A new instance of Visual Studio 2015 opens the project you selected. See Prerequisite Software.

Upgrading a .NET macro created in SOLIDWORKS 2017 or earlier

  1. Read Installing VSTA.
  2. If VSTA 3.0 is enabled, be sure to back up your VSTA 1.0 .NET macro files before editing them in SOLIDWORKS 2018.
  3. In order to successfully upgrade a .NET macro, the class name, "SolidWorksMacro", and the method name, "Execute", must be preserved. If you renamed those entities in your VSTA 1.0 macro, the macro cannot be upgraded to VSTA 2015.
  4. In SOLIDWORKS, select Tools > Macro > Edit.
  5. In the Open dialog, navigate to the SwMacro directory of the project folder created in a previous release.
  6. Select SW Macros in the project type dropdown.
  7. Select the *.vbproj or *.csproj project file.
  8. Click Open.
  9. A new project is created in project_folder/SwMacro/upgradedmacro.
  10. A new instance of Visual Studio 2015 opens the upgraded project. See Prerequisite Software.
  11. When you compile the macro, the project's configuration (Debug or Release) and output directory are not read. Only a release DLL is saved in project_folder/SwMacro/upgradedmacro/bin.
  12. The original macro is not modified or moved.

Running a .NET DLL created in SOLIDWORKS 2017 or earlier

Read Installing VSTA. If you selected to install VSTA 1.0, and de-selected Tools > Options > System Options > General > Enable VSTA VERSION 3.0, you can edit or run VSTA 1.0 macros. If you did not install VSTA 1.0, then VSTA 2015 is active by default, and you must upgrade VSTA 1.0 macros to VSTA 2015:

  1. Follow the instructions in Upgrading a .NET macro created in SOLIDWORKS 2017 or earlier.
  2. Select Tools > Macro > Run.
  3. Select SW VSTA Macros (*.dll) in the file type dropdown.
  4. Navigate to project_folder\SwMacro\upgradedmacro\bin.
  5. Select the DLL.
  6. Click Open to run the macro.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Microsoft Visual Studio Tools for Applications (VSTA)
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: API Help (English only) 2020 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.