Hide Table of Contents

Skipping Rebuild After Editing Components

A new system option lets you skip the rebuilding of large assemblies after editing a component in a separate window.

As in previous releases, when you switch back to the assembly window after editing a component in a separate window, a message asks if you want to rebuild the assembly. If you have selected the new option and the assembly is in Large Assembly Mode, then the message no longer appears, the assembly is not rebuilt, and a yellow warning triangle appears on Rebuild (Standard toolbar) to indicate that the assembly is out of date.

To set the option, click Tools > Options > System Options > Assemblies. Under Large Assembly Mode, select Do not rebuild when switching to assembly window.

As in previous releases, in the rebuild message, you can select to not be asked again and click Yes to rebuild. Subsequently, whenever you switch back to an assembly, it rebuilds automatically without asking, regardless of the assembly size. Now, with the new option selected, this automatic rebuild is skipped for assemblies in Large Assembly Mode.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Skipping Rebuild After Editing Components
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.