Hide Table of Contents

CircuitWorks Options - ProStep EDMD

From the CircuitWorks Options - ProStep EDMD dialog box, you can set ProStep EDMD file sharing and communication options.

To display CircuitWorks Options - ProStep EDMD:

From the CircuitWorks Options dialog box, click ProStep EDMD circuitworks_edmdfileicon_options.gif.

To display the CircuitWorks Options dialog box, do one of the following:

  • From CircuitWorks, click the CircuitWorks application menu , then click Options .
  • From SOLIDWORKS, click Tools > CircuitWorks > CircuitWorks Options.

Default file format

  *.idx(uncompressed) Exports file updates as uncompressed .idx files.
  *.idz (uncompressed) Exports file updates as compressed .idz files.

Change files

  Create new file for each change Creates new change files when you sync.
  Add new changes to the existing file Updates existing ProStep EDMD change files with the changes when you sync.

Options

  Use ProStep EDMD Enables ProStep EDMD file synchronization.
  Write ProStep files in these units Specifies units of measurement for ProStep EDMD files.
  Using this decimal delimiter Specifies the symbol used to separate the decimal portion for measurements:

. (Period)

, (Comma)

  Read and write ProStep version Specifies the ProStep EDMD version used by your ECAD designer.
sw_prostep_sharedfile.gif Shared folder Specifies the folder where ProStep EDMD files are shared between the CircuitWorks software and the ECAD application.
  Open all ProStep files in folder automatically

When selected, loads all ProStep EDMD file changes when you select a ProStep EDMD file to open.

When cleared, opens only the selected ProStep EDMD file.

  Sync with ECAD automatically on build Automatically saves processed ProStep EDMD file changes in the shared folder when you click Build Model (SOLIDWORKS pane of the Tools tab) or when you update the model in CircuitWorks. For new ProStep EDMD models, the model is placed in the shared folder when you export the SOLIDWORKS model to the CircuitWorks application as a ProStep EDMD model. In addition, the ECAD system is notified of these changes.
When cleared, you can notify the ECAD system of file changes by clicking Sync with ECAD (EDMD tab).
  Use email-based communication When syncing ProStep EDMD file updates with the ECAD designer, launches your default email program with an outgoing message ready for sending. The updated ProStep EDMD file information is attached to the email, and the software updates the files in the shared folder.
  Default recipient email For email-based communication, the outgoing email is addressed to the recipients.
You can separate recipient email addresses by a semicolon.
  Animate change in preview image on tree selection Displays a selected change as an animation when you select a proposed change in the Changes tree.
  Reverse rotation direction of components on the underside of the board When you rotate the board, rotates components on the underside of the board in the reverse direction.
  Check for changes made in SOLIDWORKS before applying changes from ECAD Prompts you to sync unsynced SOLIDWORKS model changes with the ECAD system.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   CircuitWorks Options - ProStep EDMD
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2016 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.