Hide Table of Contents

Performing Modal Time History Analysis

To perform modal time history analysis:

  1. Create a linear dynamic study by clicking the down arrow on Study Advisor and clicking New Study. You can define a solid, shell, or mixed mesh study. Beams are not supported. Select Linear Dynamic, and under Options, click Modal Time History . Define the frequency and dynamic properties of the study.
    You can create a linear dynamic study from an existing frequency study. Right-click the frequency study icon and select Copy to New Dynamic Study.
  2. Define material for each solid and shell. To define a material for a solid or shell right-click its icon in the Simulation study tree and select Apply/Edit Material.
  3. Define restraints. Right-click the Fixtures icon in the Simulation study tree and select from the options. You can also apply spring-damper connectors.
  4. Define damping. Right-click the Damping folder in the Simulation study tree and select Edit/Define. You can define modal, composite modal or Rayleigh damping.
  5. Define loads. You can define time-dependent force, and pressure loads, uniform and selected base excitations, and initial conditions. It is recommended to enter time curve data that cover the whole time range for the solution defined in the Modal Time History - Dynamic Options tab.
    For example, if you define a uniform base excitation curve that starts at a point that is not at the beginning of the solution range defined in study properties, the initial value is linearly interpolated. It the last point on the curve is smaller than the end time of the solution range, the solution time range is truncated.
  6. Define Result Options. Right-click the Result Options folder in the Simulation study tree and select Edit/Define.
  7. Mesh the model and run the study. First the program calculates the natural frequencies (if not available), and then it proceeds to the modal time history solution.
    You can request to run the study only for frequencies. Right-click the study icon and select Run frequency.
  8. View the results:
    • Double-click an icon in the Results folder to display the associated plot.
    • To define a new plot, right-click the Results folder and select the desired option. You can plot displacements, accelerations, velocities, stresses, strains, and deformations for a specified solution step or extreme values across all solution steps.
    • To define a time history plot at a specified node, right-click the Results folder and select Define Response Graph.
    • To list results, right-click the Results folder, and select the desired option. You can list , natural frequencies, mass participation factors, stresses, displacements, accelerations, velocities, strains, and reaction forces.

Modal Time History - Dynamics Options

The Dynamics Options tab in the Modal Time History dialog box sets solution related options:

Time range

Start time Starting solution time in seconds.
End time Ending solution time in seconds
Time increment Solution time increment. The limit on the total number of solution steps is 15000.

Dead load effects

Dead loads from static study When checked, you can superimpose the results of a static study to the dynamic study. Select one of the following:
Multiplication factor The factor that the dead loads are multiplied by.
For example, if you enter 2 for the multiplication factor, the results from the selected static study are multiplied by 2, and added to the dynamic study results at every solution step.
The results are valid only if they are within the linear stress range.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Performing Modal Time History Analysis
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2016 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.