Hide Table of Contents

Renaming Components in the FeatureManager Design Tree

You can change component file names directly from the FeatureManager design tree.

You can update references to the renamed files in unopened documents at the same time.

Before you begin:

To enable renaming, click Tools > Options > System Options > FeatureManager > Allow component files to be renamed from FeatureManager tree.

To change a component file name:

  1. In an assembly, in the FeatureManager design tree, do one of the following for the component whose file name you want to change:
    • Click-pause-click the component.
    • Right-click the component and select Rename Assembly or Rename Part.
    • Select the component and press F2.
  2. Type a new name and press Enter.
  3. In the dialog box, select Temporarily rename document and, if prompted to rebuild, click Yes.
    The file name of the component changes in the SOLIDWORKS software, but is not yet changed in the Windows file system. Any currently open documents that reference the renamed file are updated in the SOLIDWORKS software to reference the new file name.
  4. Save the assembly.
    The Rename Documents dialog box opens. It warns you of the following:
    • Files that have been temporarily renamed in the SOLIDWORKS software will now be renamed permanently in the Windows file system.
    • Other currently open documents that reference the files being renamed will be updated in the Windows file system.
    • References will be broken in currently closed documents that reference the renamed files unless you select Update where used references and specify which documents to update.
  5. (Optional.) To avoid broken references in documents that are not currently open:
    1. Select Update where used references.
      The dialog box expands.
    2. Specify folders in which to search for documents to update.
      Option Description
      File locations Lists the folders to search. Click Add Folder to browse for folders to add to the search. To remove a folder from the list, select it and click Remove.
      Include file locations - Referenced Document folders Specifies to search the folders listed under Referenced Documents in Tools > Options > File Locations.
    3. Click Search.
      Results are listed under Update where used references. By default, all items are selected.
    4. Clear items that you do not want to update.
        State Description
      Selected Items update to reference the new file name.
      Cleared Items continue to reference the old file name.
  6. Click OK.
    The component file is permanently renamed.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Renaming Components in the FeatureManager Design Tree
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2016 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.