Hide Table of Contents

Attaching Drawings as References

You can attach an external drawing to the current drawing. This creates a link between the external drawing and the current drawing.

The software periodically checks whether the attached referenced drawings have changed since the last time the referenced drawings were loaded.

When you open a drawing that has one or more externally referenced files, the External Reference icon () appears in the status bar. Clicking the External Reference icon displays the References palette.

To attach drawings as References:

  1. Click Insert > Reference Drawing (or type AttachDrawing).
  2. In the dialog box, select a drawing to attach, and click Open.
  3. In the Attach Reference: Drawing dialog box, Name displays the name of the file you selected, or you can select a previously attached drawing. Click Browse to select a different drawing.
  4. Specify File information:
    • Path type: Specifies how to display the path to the drawing.
      • Full: Shows the complete path to the drawing.
      • None: Shows only the file name.
      • Relative: Shows the relative path to the drawing. If both drawings are in the same folder, only the file name of the drawing is displayed.
    • Reference type: Indicates whether to include the Referenced drawing when the current drawing is attached to another drawing.
      • Attachment: Includes the Referenced drawing.
      • Overlay: Does not include the Referenced drawing.
  5. Specify the Insertion point:
    • Specify later: Lets you specify the insertion point in the graphics area after the dialog box closes.
    • X, Y, Z: Specifies the X, Y, and Z coordinates for the drawing location.
  6. Specify the Scale:
    • Specify later: Lets you specify the scale in the graphics area after the dialog box closes.
    • X, Y, Z: Specifies the X, Y, and Z coordinates of each axis independently.
    • Lock aspect ratio: Lets you enter the X axis and fixes the other coordinates.
  7. Specify the Rotation:
    • Specify later: Lets you specify the angle in the graphics area after the dialog box closes.
    • Angle: Sets the angle of rotation for the drawing.
  8. Verify Block units information (read-only):
    • Units: Shows the unit system of the specified drawing.
    • Scale: Shows the scale factor of the specified drawing.
  9. Click OK.

Access

Command: AttachDrawing

Menu: Insert > Reference Drawing



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Attaching Drawings as References
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.