Hide Table of Contents

Clipping References and Blocks

You can display only part of a Reference (a Referenced drawing file) or a Block. The entity is clipped at a boundary you create or specify.

You can create one clipping boundary per Reference or Block.

To clip References or Blocks:

  1. Click Modify > Clip > Reference (or type ClipReference).
  2. Specify the References or Blocks to which you want to apply a clipping boundary, and press Enter.
  3. Specify an option:
    • Boundary: Creates a new clipping boundary. If a clipping boundary already exists for the Reference or Block, you are prompted to delete the old boundary. Specify options:
      • Invert clip: Lets you invert the display of the clipping boundary. Use the option to display the entities outside the boundary or to return to the previous mode.
      • Polygonal: Lets you define an irregular polygonal shape as clipping boundary by specifying points.
      • Rectangular: Lets you define a rectangular clipping boundary by specifying two opposite points.
      • Select polyline: Lets you select an existing PolyLine to serve as clipping boundary. Arc segments are decurved.
    • Clip depth (used for 3D clipped References or Blocks): Sets the front and back planes parallel to the clipping boundary. You select the planes by specifying clip points. Use inferencing to select geometry. Specify options:
      • Distance: Uses specified distances from the clipping boundary to create the front and back planes.
      • Remove: Removes the clipping planes.
    • Delete: Removes the clipping boundary.
    • Off: Turns the clipping boundary off to display the Reference or Block entirely. The clipping boundary is retained so you can activate it again.
    • On: Turns the clipping boundary on to display only the portion of the Reference or Block inside the clipping boundary.
    • Polyline: Creates a PolyLine from the clipping boundary you created before (using the Rectangle and Polygonal options).

Access

Command: ClipReference

Menu: Modify > Clip > Reference



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Clipping References and Blocks
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.