Hide Table of Contents

Using the References Palette

The References command accesses the References palette which manages Referenced drawings or image files. When you open a drawing with Referenced files, the References display in the current states. When collaborating over a network, you might need to update the References. The program reloads the specified drawings in the most recently saved states.

After you attach drawings as References you can manage them with the References palette.

This topic discusses:

Attaching and Updating Drawings as References

To attach drawings using the References palette:

  1. Click Tools > References (or type References).
  2. Click Attach Drawing.

    If Attach Drawing does not display, click the arrow next to Attach Image and click Attach Drawing.

  3. In the dialog box, browse to a drawing and click Open.
  4. Set options in the Attach Reference: Drawing dialog box. See Attaching Drawings as References.

To attach images using the References palette:

  1. Click Tools > References.
  2. Click Attach Image.

    If Attach Image does not display, click the arrow next to Attach Drawing and click Attach Image.

  3. In the dialog box, browse to an image and click Open.
  4. Set options in the Attach Reference: Image dialog box. See Attaching Image Files.

To update References:

  1. Click Tools > References.
  2. Click Refresh to redraw the References.

    If Refresh does not display, click the arrow next to Reload All and click Refresh.

  3. Click Reload All to update the References with subsequent modifications made to the external file.

    If Reload All does not display, click the arrow next to Refresh and click Reload All.

^ Top of Page

Managing References

To open referenced drawings:

You can modify a drawing that is referenced in a drawing.

  • In the References palette, right-click a Reference and click Open.

    The drawing opens in another drawing window. When you edit the drawing your modifications are reflected in the drawings where they are attached as References.

To unload References:

  • In the References palette, right-click a Reference and click Unload.

    The Reference you unloaded is no longer visible in the drawing, but the link to the file is maintained. To redisplay an unloaded Reference, specify the Reload option.

To reload References:

  • In the References palette, right-click a Reference and click Reload.

    Drawings that contain referenced drawings are displayed in their current states. When working on a project in a workgroup, you might need to update References while you work on a drawing. The option reloads the specified drawing in the form in which it was most recently saved.

To detach References:

  • In the References palette, right-click a Reference and click Detach.

    The referenced drawing is removed from the current drawing, which erases dependent symbols such as Layer, LineStyle, and Block definitions from the drawing file.

    Note: Although you can erase References with the Delete command, specify the Detach option to remove the dependent symbols from the drawing file, as well.

To bind References permanently:

The Bind option makes a referenced drawing a permanent part of a drawing, for example, if you want to email a drawing or archive a finalized drawing. Bind the referenced drawing to the current drawing to avoid including an assembly of drawings in an archive or email.

  1. In the References palette, right-click a Reference and click Bind.
  2. In the dialog box, specify the Bind Type:
    • Bind. Converts the Reference into a Block and uses unique symbol names for Layers and style definitions in the drawing using the blockname$n$symbolname syntax.
    • Insert. Detaches the Reference and inserts the referenced drawing as a Block.

    See Using the Insert Reference - Bind Type dialog box.

  3. Click OK.

To change the Reference type:

  1. In the References palette, select a Reference.
  2. In the File information area, select the Reference Type:
    • Attach. Creates a link to a drawing and references it in the current drawing. The attached drawing is the most recently saved version. The Attach option includes the external drawing.
    • Overlay. Creates a link to a drawing and references it in the current drawing. The Overlay option does not include the external drawing.

To reset the path to a Reference:

Occasionally, the location of a referenced drawing changes or a referenced file is renamed. The Path option reestablishes the path to the Reference, reattaches a renamed Reference file, or replaces a Reference file with another file.

  1. In the References palette, select a Reference.
  2. In the File information area, click Browse  behind the Found in path box that contains the path and name of the Reference whose path needs updating.
  3. Navigate to the new location and select the Reference file, then click Open.

To change the saved path specification for a Reference:

You can modify the path specifications for References. The specifications are saved in the drawing.

  1. In the References palette, right-click a Reference (drawing or image) and click Path.
  2. Specify an option:
    • Make absolute. Changes the relative path of the Reference to an absolute path.
    • Make relative. Changes the absolute path of the Reference to a relative path.
    • Remove path. Removes the path specification for the Reference. Use this option only, if the Reference is located in the same folder as the drawing.

    In the File information area, in Saved path, the path specification changes accordingly.

^ Top of Page

Access

Command: References

Menu: Tools > References



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Using the References Palette
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.