Hide Table of Contents

Setting System Options

The System Options page of the Options dialog box lets you define general operating options.

To set general options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand General to set:
    • Merge Zoom and Pan for Undo: Groups consecutive Zoom and Pan commands as a single action for Undo and Redo commands.
    • Show Page Layout dialog box on creation of new Sheets: Lets you set up a PageLayout when you activate a new Sheet.
    • Show Print Configuration Manager dialog box on creation of new Sheets: Lets you set up a Print Configuration when you activate a new Sheet.
    • Show Print Configuration Manager dialog box on creation of new Sheets: Lets you set up a Print Configuration when you activate a new Sheet.
    • Maximum command history output lines: Specifies the maximum number of lines displayed on the Command History Window before you are prompted to press Enter to continue. Applies to commands that display long lists.
    • Show notification balloon on updates: Displays a balloon in the notification area of the taskbar to indicate that a new update of the application is available.
    • Show notification for missing external references: Displays a pop-up alert when you open a drawing and one or more externally referenced files are missing or cannot be loaded because they are corrupted.
    • Single document interface mode: Specifies that one instance of the application can open only a one drawing at a time.
    • File thumbnail size: Specifies the size of file thumbnail preview images which display when you select a drawing in the operating system's file manager or in the Open dialog box. The setting applies to drawing files when you save them. The thumbnail size influences the drawing file size. You can set a value from 0 (very small thumbnails) to 8 (very large thumbnails).
  3. In Reference notification, specify how to display the notifications when one or more externally referenced files are changed. Select an option:
    • Hide notification. Does not display notifications.
    • Show notification. Displays the External Reference icon in the status bar when externally referenced files are attached to the current drawing. When you open a drawing and one or more externally referenced files are missing, an alert symbol appears near the icon ().
    • Show notification with balloon. Displays the External Reference icon as above. Additionally, displays a balloon message when externally referenced files are modified.
  4. In Customer Involvement Program, select or clear Participate and help to improve this program to determine whether you want to participate in the Customer Involvement Program.
  5. Expand License to set a timeout for the license (Enterprise & Enterprise Plus):
    • Return license if idle for more than [x] minutes: Sets the idle time until the application returns the license to the License Manager application, so that it can be available to other users (Timeout Setting).
  6. Expand Coordinate input override to set:
    • Use ESnaps: EntitySnaps input overrides coordinate input.
    • Coordinate input overrides ESnaps: Keyboard input overrides EntitySnaps coordinate input.
    • Coordinate input when running scripts (keyboard): Keyboard input overrides EntitySnaps coordinate input except in scripts.
  7. Expand Proxy server settings to set specifications if your system is part of a network using a proxy server:
    • Type: Sets the type of the proxy server (Socks5, HTTP, HTTP Caching, or FTP Caching).
    • Host: Sets the IP address of the host to which you are connected.
    • Port: Sets the port for the proxy server.
    • User: Sets the user name to identify you in the network environment.
    • Password: Sets your login password.
  8. Expand Application language to set the language used by the application in the user interface, command entry, and Help files. The language can also be set by using the Language command.

To set display options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Display.
  3. Expand User Interface Style to set the color theme of the ribbon, menu, toolbars, and palettes interface elements to Dark or Light.
  4. Expand User Interface Style to set the color theme of interface elements to Dark or Light.
  5. Expand User Interface Style to set the color theme of interface elements to Dark or Light.
  6. Expand Screen options to set:
    • Show scroll bars: Turns on and off the display of scroll bars in the drawing window.
    • Use large icons: Uses large buttons for toolbars.
  7. Expand Screen options to set:
    • Show scroll bars: Turns on and off the display of scroll bars in the drawing window.
    • Use large icons: Uses large buttons for toolbars.
  8. Expand Command window text to set:
    • Font: Sets the font for the command window prompt and messages.
    • Size: Sets the text size for the command window.
    • Command line text: Sets the text to display as the prompt in the command line.
  9. Expand AutoCompletion to set options for auto-completion of command entries:

    Expand AutoCompletion (Professional, Premium, Enterprise & Enterprise Plus) to set options for auto-completion of command entries:

    • Auto selection of closest suggestion. Automatically selects the command or variable name that is closest to what you entered when you press Enter. Otherwise you need to enter the complete name or select an entry from the suggestion list.
    • Auto selection of closest suggestion. Automatically selects the command name that is closest to what you entered when you press Enter. Otherwise you need to enter the complete name or select an entry from the suggestion list.
    • Auto selection of closest suggestion. Automatically selects the command or variable name that is closest to what you entered when you press Enter. Otherwise you need to enter the complete name or select an entry from the suggestion list.
    • Display suggestion list. Specifies whether a suggestion list displays as you type a command name.

      If you display the suggestion list, you can set:

      • Suggestion list delay time. Sets a delay time (in milliseconds) before the command names suggestion list displays.
      • Include aliases in list. Includes alias command names in the suggestion list.
        • Display commands with aliases. Displays the command name in brackets after the alias name in the suggestion list.
      • Include system variables. Includes system variable names in the suggestion list.
      • Include command variables. Includes command variable names in the suggestion list.
      • Include mid-string search. Browses command names for occurences of the string you type not only for initial characters, but also among whole command names.
      • Mid-string search characters. Specifies the number of characters of the mid-string.

      Note: When you enter a command and the suggestion list displays, right-click the list to set options described above.

  10. Expand Element Colors to set display colors of user interface elements such as the Model and Sheet background, cursors, and crosshairs.

    You can also change the color for entity selection highlighting. Entities are highlighted when you move the cursor over them (preview highlighting) or when you select them (selection highlighting). By default the color of the entities changes in both situations (see Previewing and Highlighting of Entity Selections).

    You can use the following options:

    • Use dashed entity selection highlight: Changes the selection highlighting behavior back to legacy dashed-style entity highlighting. In this case, you cannot access the Dynamic Highlight and Selected Entity items in the list of elements.

      Note: If your computer does not support colored highlighting, the software uses dashed-style entity highlighting.

    • Color: Applies the selected color to the selected display element.
    • Reset All: Sets all user interface elements to the default colors.
    • Reset Selected Item: Sets the selected display element to its default color.
  11. Expand Drawing tabs to set the following:
    • Show drawing tabs. Controls drawing tab display at the top of the drawing windows area.
    • Display settings. Select one of the following:
      • List view. Displays non-graphical lists of workspaces.
      • Panel preview. Displays thumbnails for each drawing workspace (model and layout sheets) below tabs (default).
  12. Expand Auto hiding palettes to set a delay time (in milliseconds) before the palettes hide or show.

To set graphics area options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Graphics Area to set:
    • Display cursor as crosshair: Displays the pointer in form of crosshairs, even if no command is active.
    • Pointer size: Specifies the size of the crosshairs that act as the pointer. Set a value between 1 and 100. If you type 100, the crosshairs pass over the full screen.
    • Display ESnap tooltips: Determines whether tooltips are displayed when the pointer passes over a point where an entity snap mode can be applied.
    • Show background: Determines whether to display colors in the background of user-defined Views.
    • Show hyperlink pointers, tooltips, and shortcut menus: Determines whether to show hyperlinks, tooltips, and shortcut menus whenever the pointer passes over an entity.
    • Display entity transparency: Determines whether to display the transparency of entities. The option does not affect print output transparency.
    • Locked layer fading: Determines whether to fade entities on locked layers to contrast them with entities on unlocked layers and reduce the display complexity of the drawing. Set a value between 0 and 90% where 0% means no fading.
    • External reference fading: Determines whether to fade entities on external references to contrast them with entities on the drawing and reduce the display complexity. Set a value between 0 and 90% where 0% means no fading.

To set Open and Save As options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Open / Save As.
  3. Expand Default file types to set:
    • Open documents of type: Sets the default file type (.dwg, .dxf, .dwt) used when you open or insert drawings, or attach Referenced drawings.
    • Save documents as type: Sets the default file type (.dwg or .dxf) and version when you save drawings.
    • Preserve the original file: Specifies whether the backup file is saved in its original drawing file version.
  4. Expand Template file name for SmartNew to set the path and name of a drawing template file (.dwt). Click Browse to browse for the template file.
  5. Expand Open with encoding to specify how to open drawings if the drawing’s codepage differs from the computer’s operating system codepage. Codepages determine character encoding. Select an option:
    • Open file as usual: Maintains the drawing’s codepage.
    • Open file with system codepage: Switches to the computer’s operating system codepage.
    • Check file codepage and prompt: Lets you specify the codepage to use when you open a drawing with a codepage that differs from the OS codepage.
  6. Expand Open print style type to specify the PrintStyle to use when you open an existing drawing:
    • Force converting to CTB print style type after open: Determines whether drawings using named PrintStyles (.stb file) are automatically converted to use color-dependent PrintStyles (.ctb files) subsequently when opening.
  7. Expand Open file to specify whether the title bar displays the full path of the active drawing or only the name.

To set printing options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Printing.
  3. Expand Print log files to set:
    • Location: Sets the path for the print and publish log files. Click Browse to browse for the log file folder.
    • Save print logs: Creates print job log files which are saved in the comma separated value format (.csv).
    • Log style (available if you selected Save print logs): One log per print stores information about all print jobs in a single log file. When cleared, information is stored about each print job in separate log files.
  4. Expand Print style file location to set the path for PrintStyle definition files. Click Browse to browse for the PrintStyle file folder.
  5. Expand Default settings to set:
    • Default type (determines the behavior for new drawings, not for the current drawing):
      • Use named print styles: Uses user-defined PrintStyles.
      • Use color-dependent print styles: Uses color-dependent PrintStyles.
    • Default PrintStyle: Sets the default PrintStyle file.
    • Override print style for entities (available if you selected Use named print styles): Overrides the Default PrintStyle table for entities. The settings available depend on the Default PrintStyle setting.
    • Override print style for layer 0 (available if you selected Use named print styles): Overrides the Default PrintStyle table for entities or Layer 0. The settings available depend on the Default PrintStyle setting.
  6. Expand General options to set:
    • Keep paper size when changing printer: When you change the printer in the Print dialog box, the paper size is maintained if it is supported by the specified printer. When cleared, the default format displays for paper size.
    • Display paper background: On Sheet tabs, the Sheet extents are visualized by a gray background.
    • Display printable area: On Sheet tabs, a dashed rectangle visualizes the printable area and the non-printable margins of the selected printer associated with the Sheet.
    • Specify print offset relative to: Specifies how to set the print offset:
      • Printable area: Sets the offset relative to the lower-left corner of the printable area.
      • Paper edge: Sets the offset relative to the lower-left corner of the paper edge.
    • Use layers in PDF file (PDF v1.5 or higher): Creates layers in the PDF file according to the layers in the drawing. Increases the PDF file size.

To set auto-save and backup options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Auto-save & Backup.
  3. Expand Automatic save file location to set the folder for automatically generated saved files. Click Browse to browse for the folder.
  4. Expand Auto-save/backups to set:
    • Enable auto-save: Automatically saves the drawing. You can specify the interval for auto-save in minutes.
    • Save backup at each save: Sets whether you want to create a backup copy each time the document is saved.
    • Use original format: Specifies whether the backup file is saved in its original drawing file version or in the current file version.

To set drawing file defaults:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Drawing File Defaults.
  3. Expand Block insertion units to set preferences to determine the default scale when you insert Blocks or drawings into a drawing:
    • Units for inserting entities: Sets the source contents units. If you select Unitless, the entity is not scaled when inserted.
    • Active drawing units: Sets the target drawing units.

Customizing the Default Scale List

Lists of scales are available when you print, manage PageLayouts, or scale Viewports on layout Sheets.

Lists of scales are available when you print, manage Print Configurations, or scale Viewports on layout Sheets.

Lists of scales are available when you print, manage Print Configurations, or scale Viewports on layout Sheets.

The Default Scale List determines the Drawing Scale List for new drawings, which are created without template drawings.

To change the scale list in an existing drawing template file, open the drawing template file (*.dwt), and customize the Drawing Scale List of the template file.

To customize the Default Scale List:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Default Scale List.
  3. In File, the path and name of the scale list file, an .xml file, is displayed.

    If necessary, change the file setting. Click Browse to navigate to the scale list file.

  4. Click Metric or Imperial to display to the corresponding scale list.
  5. Click Add to add a new scale to the list:
    1. In the Scale Name column of the new list item, type a name for the new scale.
    2. In Paper Units, type a number.
    3. In Drawing Units, type a number.

      The ratio between between paper units and drawing units determines the scale applied when selecting the scale name in a scale list.

  6. Click Move up to move the selected item up in the list.
  7. Click Move down to move the selected item down in the list.
  8. Click Delete to remove the selected item from the list.
  9. Click Reset to replace the settings of the custom Default Scale List with the default software settings.
  10. Click Export to save the scale list file with a different name.
  11. Click Apply to save the scale list customization.

  You can redefine existing scale specifications in the Default Scale List. You can also reset the custom Drawing Scale List to the custom Default Scale List settings.

To customize macro recording defaults:

To customize macro recording defaults (Professional, Premium, Enterprise & Enterprise Plus):

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click System Options .

    • Type SystemOptions.
  2. Expand Macro Recording.

    In Location, the path and name of the macro file are displayed.

  3. If necessary, change the macro path and name, and click Browse to navigate to the macro file location.
  4. In Level of detail, set how detailed should be the code:
    • Low. Displays minimum code.
    • High. Code includes intermediate steps.
  5. In Language, select the default API language.

  Use the Find option to search for items in the Options dialog box.

Access

Commands: SystemOptions, or Options

Menu: Tools > Options

Menu: Application menu > Preferences



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Setting System Options
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.