Hide Table of Contents

Loading Applications

Use the LoadApplication command to locate and load applications for use in the program.

Typically, the application sends a message that it has been loaded successfully. You can then use the commands and functions provided by the application.

Supported formats include:

  • Lisp files (*.lsp)
  • Menu Lisp files (*.mnl)
  • Dynamic Link Libraries provided by application vendors (*.dll)
  • Teigha eXtension files provided by application vendors (*.tx)

You can load Dynamic Link Libraries (*.dll) provided for the software.

To load applications:

  1. Do one of the following:
    • On the menu, click Tools > Load Application.
    • On the ribbon, click Manage > Applications > Load Application.
    • Type LoadApplication.
  2. In the dialog box, navigate to the application file to load and click Open.

    Make sure to load application files that were created for the software.

Use the AddIns command to display loaded applications.

Use the Add-Ins tab of the Options dialog box to integrate applications that are loaded each time you start the program (see Managing Add-Ins).

Access

Command: LoadApplication

Menu: Tools > Load Application

Ribbon: Manage > Applications > Load Application



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Loading Applications
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.