Hide Table of Contents

Saving and Retrieving User-defined Views

A view is a display of the drawing on the screen. You can give any view a name and save it to display later.

The Views command lets you save, restore, and control named views.

To manage views:

  • Click View > Named Views (or type Views).

    The Views dialog box distinguishes between three view types: Model, Sheet, and Defaults. Each type displays a list of named views.

To save named views:

  1. Click View > Named Views (or type Views).
  2. Click New.
  3. In the View dialog box:
    1. In Name, type a view name.
    2. In Class, type a new class name or select a class. Or, you can leave Class set to <None>.
    3. Under Boundaries, set options:
      • As displayed. Uses the boundaries of the current display.
      • Specify later. Allows you to define a windowed area of the current view. Click Specify later  and define a rectangular area in the graphics area, then press Enter.
    4. Under Background:
      • Ignore default. Specifies whether to display a background with the named view.
      • Format background . Defines type and properties of the background for named Model views whose ShadeView mode is not set to 2D (see Defining the Background for Named Views).
  4. Click OK twice.

To restore named views:

  1. Click View > Named Views (or type Views).
  2. Under View names, select a view to restore.
  3. Click OK.

To edit view boundaries:

  1. Click View > Named Views (or type Views).
  2. Under View names, select the view whose boundaries you want to edit.
  3. Click Edit.
  4. In the graphics area, specify new boundaries, and press Enter.
  5. Click OK.

To delete named views:

  1. Click View > Named Views (or type Views).
  2. Under View names, select the view to delete.
  3. Click Delete.

  You cannot delete the view Current, or preset Defaults views.

Defining the Background for Named Views

In the View command, use the Format Background dialog box to define the type and properties of the background for named Model views.

View backgrounds display only in Model Viewports and require that ShadeView mode is not set to 2D.

To define a background for named views:

  1. In the Format Background dialog box, specify a Type (Solid, Gradient, or Image).
  2. If you selected Solid,
    1. Under Options, click Select color.
    2. In the Color dialog box, specify a Standard color or Custom color.

    If you selected Gradient,

    1. Under Options, select or clear Two colors to specify whether to compose the gradient fill from two or three colors.
    2. Click Top color to specify a standard color or custom color in the Color dialog box for the top of the gradient fill.
    3. Click Middle color to specify a color for the middle of the gradient fill (not available if you selected Two colors).
    4. Click Bottom color to specify a color for the bottom of the gradient fill.
    5. In Angle, specify an angle to rotate the gradient background.

    If you selected Image,

    1. Under Options, specify an image filename (*.bmp, *.png, or *.jpg). Click Browse to browse to an image file.
    2. Click Modify to adjust the image.
    3. In the dialog box, specify the Position of the background image:
      • Center. Centers the image without changing its aspect ratio or scale.
      • Stretch. Stretches the image so it fills the view background.
      • Tile. Positions the image at the top left corner of the view and repeats the image to fill the background without changing its aspect ratio or scale.
    4. Select or clear Lock aspect ratio to specify whether to lock X/Y scaling of the image to the same value.
    5. Click Adjust scale to specify the image scale in the range of 0.1 to 100 (not available if you selected Stretch).
    6. Click Adjust offset to specify the X and Y offsets relative to the center or top left position of the image (not available if you selected Stretch). You can specify positive, negative, or zero values.
    7. Click Reset to change the scale and offset values to their default values.
    8. Click OK.
  3. In Preview, view the specified background for the named view.
  4. Type ShadeView to set the ShadeView to a mode other than 2D.

  To delete the background of a named view, run the View command and select the named view. In the Properties tree view, expand General and set Background override to <None>.

Access

Command: Views

Menu: View > Named Views



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Saving and Retrieving User-defined Views
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.