Expand WelcomeWelcome
Legal Notices
Expand The User InterfaceThe User Interface
Expand Getting StartedGetting Started
Expand Drawing with PrecisionDrawing with Precision
Expand Working with Drawing FilesWorking with Drawing Files
Expand Viewing the DrawingViewing the Drawing
Expand 3D Viewing and Presentation3D Viewing and Presentation
Expand Formatting the DrawingFormatting the Drawing
Expand Drawing EntitiesDrawing Entities
Collapse Modifying EntitiesModifying Entities
Collapse Selecting Entities for ModificationSelecting Entities for Modification
Selecting Entities
Applying Entity Selection Methods
Previewing and Highlighting Entity Selections
Preselecting Entities
Preselecting All Entities
Cycling Through Entities During Selection
Selecting Entities of the Same Type and Shared Properties
Creating Entity Selections Based on Filtering Criteria
Creating and Applying Filters for Entity Selection
Expand Using EntityGripsUsing EntityGrips
Expand Correcting MistakesCorrecting Mistakes
Expand Using the ClipboardUsing the Clipboard
Expand Editing PropertiesEditing Properties
Copy, Move, Rotate, and Scale in One Operation
Copying Entities
Moving Entities
Rotating Entities
Scaling Entities
Mirroring Entities
Flipping Entities
Creating Offsets of Entities
Creating Patterns of Entities
Stretching Entities
Changing the Length of Entities
Trimming Entities
Extending Entities
Splitting Entities
Welding Entities
Applying Chamfers
Applying Fillets
Aligning Entities
Editing PolyLines
Converting PolyLines
Editing Splines
Modifying RichLines
Expand Exploding Complex ObjectsExploding Complex Objects
Discarding Duplicate Entities
Expand Working with Blocks, BlockAttributes, EntityGroups, and ReferencesWorking with Blocks, BlockAttributes, EntityGroups, and References
Expand Working with Hatches, Color Fills, Text, and TablesWorking with Hatches, Color Fills, Text, and Tables
Expand Creating and Modifying DimensionsCreating and Modifying Dimensions
Expand Creating and Modifying 3D EntitiesCreating and Modifying 3D Entities
Expand Creating Layout Sheets and Printing DrawingsCreating Layout Sheets and Printing Drawings
Expand Arranging Drawing WindowsArranging Drawing Windows
Expand CustomizingCustomizing
Expand Command ReferenceCommand Reference
Expand DraftSight ProfessionalDraftSight Professional
Expand Constraints (Premium & Enterprise Plus)Constraints (Premium & Enterprise Plus)
Expand 3D Modeling (Premium & Enterprise Plus)3D Modeling (Premium & Enterprise Plus)
Hide Table of Contents

Previewing and Highlighting Entity Selections

Entities are highlighted when you move the cursor over them (preview highlighting) or when you select them (selection highlighting).

By default, the color of the entities changes in both situations.

Highlighting helps you recognize whether the entities are elementary ones (such as Lines or Arcs) or compound ones (such as Blocks, Dimensions, Polylines, RichLines, or Tables) before and during entity selection.

You can customize preview highlighting and selection highlighting by:

  • Using legacy dashed-style entity highlighting instead of colors
  • Changing the highlighting colors
  • Controlling preview highlighting independently when a command is active or inactive
  • Excluding certain command types from highlighting: entities on locked layers, References, Tables, Notes, Hatches, and entities which are part of EntityGroups

Use the Options command to customize the settings.

  Note: If your computer does not support colored highlighting, the software uses dashed-style entity highlighting.

To set the color for preview highlighting and selection highlighting:

  1. In the Options dialog box, click System Options.
  2. Expand Display > Element Colors.
  3. To change the highlighting behavior back to legacy dashed-style entity highlighting, select Use dashed entity selection.

    In this case, you cannot access the Dynamic Highlight and Selected Entity items in the list of elements and the following steps are obsolete.

    If you deactivated Use dashed entity selection:

    • Specify a value for the Selection highlight effect opacity between 0.10 and 1.00.
    • Specify a value for the Selection highlight effect thickness between 2.00 and 8.00.
  4. In the list, click Dynamic Highlight.
  5. In Color, specify the color for preview highlighting.

    The default color is Orange.

    The default color is Orange.

  6. In the list, click Selected Entity.
  7. In Color, specify the color for selection highlighting.

    The default color is Blue.

    The default color is Light Blue.

  8. Click Apply.

To set preview highlighting options:

  1. In the Options dialog box, click User Preferences.
  2. Expand Drafting Options > Entity Selection > Pre-selected Highlighting and set:
    1. When prompted to specify entities: Highlights entities when you are prompted to specify entities during command execution and you move the cursor over the entities.
    2. Between commands: Highlights entities when you move the cursor over them if no command is active.
  3. Click Apply.

To exclude entities from highlighting:

  1. In the Options dialog box, click User Preferences.
  2. Expand Drafting Options > Entity Selection > Preview Filter.
  3. In Exclude, select entity types to exclude from highlighting:
    • Entities on locked layers: Excludes entities on locked layers.
    • Notes: Excludes Notes.
    • References: Excludes entities in externally referenced drawings (References).
    • Hatches: Excludes Hatches and gradient color fills.
    • Tables: Excludes Tables.
    • Groups: Excludes entities in EntityGroups.
  4. Click Apply.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Previewing and Highlighting Entity Selections
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.