Hide Table of Contents

Command Reference: Commands in Alphabetical Order

#

Command Description Menu
3D Creates a 3D PolygonMesh object (box, cone, cylinder, dish, dome, pyramid, sphere, torus, wedge, or mesh)
3PointAngleDimension Creates an angular Dimension based on three points
4PointAngleDimension Creates an angular Dimension based on four points

A

Command Description Menu
About Displays information about the program Help
About Displays information about the program Application Menu
ActivateLayer Activates the Layer of a specified entity Format > Layer Tools
ActivateTableStyle Sets the name of a TableStyle, applied when you create a new Table
ActivateViewport Activates a specified tiled view on the Model tab or a Viewport on a Sheet tab
Align Aligns entities with other entities in 2D and 3D space
Align3D Aligns entities with respect to other entities or other target points in 3D space Modify > 3D Operations
AngleDimension Creates an angle Dimension Dimension
AnnEntityScale Adds and removes annotation scales for specified annotative entities (dialog box variant) Modify > Annotation Scaling
-AnnEntityScale Adds and removes annotation scales for specified annotative entities (command window variant)
AnnEntityScaleAdd Updates annotative entities to support the drawing's active annotation scale Modify > Annotation Scaling
AnnEntityScaleRemove Updates annotative entities to remove the drawing's active annotation scale from the entities' annotation scales Modify > Annotation Scaling
AnnReset Resets all scale representations of specified annotative entities to their original positions Modify > Annotation Scaling
AnnUpdate Updates existing annotative entities to match updated TextStyle or DimensionStyle settings
Arc Creates an Arc Draw
ArcLengthDimension Creates an Arc length Dimension Dimension
AreaBoundary Creates a PolyLine or Region entity from an enclosed area (dialog box variant) Draw
-AreaBoundary Creates a PolyLine or Region entity from an enclosed area (command window variant)
ARender Displays the rendered drawing in a separate window
AttachDrawing Attaches a Referenced drawing to the current drawing Insert
AttachImage Attaches an image to the current drawing Insert
AttachLink Attaches hyperlinks to entities or areas
AttachPDF Attaches one or multiple pages of a PDF document to your drawing (dialog box variant) Insert
-AttachPDF Attaches one or multiple pages of a PDF document to your drawing (command window variant)
AttachPDF Attaches one or multiple pages of a PDF document to your drawing (dialog box variant) Insert
-AttachPDF Attaches one or multiple pages of a PDF document to your drawing (command window variant)
AutoRebuild Controls automatic drawing rebuilds

 

    ^ Top of Page

B

Command Description Menu
BaselineDimension Continues a linear, angular, or ordinate Dimension from the baseline of the previous or selected Dimension Dimension
BlockAttributeOutput Writes BlockAttribute values of selected Blocks to text files
BlockAttributePositionOutput Writes BlockAttribute values of selected Blocks including the Block positions to text files
BigFontAlt Sets the replacement BigFont file to use in the current drawing if the original font is not found.
BoxText Turns boxed text display and print mode on and off

 

    ^ Top of Page

C

Command Description Menu
CCS Sets, saves, and restores custom coordinate systems (CCS) Tools > New CCS
CenterLine Creates CenterLines between pairs of Lines, Arcs, and PolyLine segments Draw
CenterMark Creates a center mark or center lines of Circles and Arcs Dimension
Chamfer Bevels the edges of drawing entities Modify
ChangeElements Adds or removes entities to Block definitions or References (so called Components) Modify > Component
ChangeSpace Transfers entities from Model workspace to Sheet workspace and vice versa
Check Evaluates the integrity of a drawing and can correct errors File
Circle Creates a Circle Draw
CircularPattern Creates copies of specified entities in a circular pattern (command window variant of the Pattern command, Circular option)
Clean Removes unused named References such as Blocks or Layers from the drawing (dialog box variant) Format
Clean Removes unused named References such as Blocks or Layers from the drawing (dialog box variant) File
-Clean Removes unused named References such as Blocks or Layers from the drawing (command window variant)
ClipboardCopy Copies entities to the clipboard Edit
ClipImage Defines a clipping boundary to hide portions of a referenced image Modify > Clip
ClipPDF Clips a PDF Underlay at a specified boundary Modify > Clip
ClipPDF Clips a PDF Underlay at a specified boundary Modify > Clip
ClipReference Defines a clipping boundary to suppress display of portions of a Block or Reference Modify > Clip
ClipViewport Clips the display of Viewports on the active Sheet at irregular shapes Modify > Clip
Close Exits the drawing but not the program File
CloseAll Exits all open drawings but not the program Window
CloseComponent Terminates in-place editing of a Block definition or a Reference Modify > Component
Cloud Creates revision clouds to indicate that certain areas require or contain revisions (dialog box variant) Draw
-Cloud Creates revision clouds to indicate that certain areas require or contain revisions (command window variant)
CommandHistory Opens the separate command history window View > Display
CommandWindow Displays the command prompt area
Commands Displays the list of all commands
ContinueDimension Continues a linear, angular, or ordinate Dimension from the second extension line of the previous or a selected Dimension Dimension
ConvertOLE Converts the data of embedded OLE objects to a different type or format
ConvertPolyLine Converts lightweight PolyLines to old-format, heavyweight PolyLines and vice versa Modify > Entity
Copy Duplicates entities Modify
Copy@ Copies entities with a specified reference point to the clipboard Edit
CopyHistory Copies the command history to the clipboard
CopyLink Copies the current view of the drawing to the clipboard and establishes a link to it in the target application
CopyNested Duplicates drawing entities that are contained in a Block or a Reference and places copies of them at a specified location Modify
CSIcon Sets the visibility and position of the coordinate symbol (CS icon) View > Display > CCS Icon
CSStyle Manages custom coordinate systems (CCS) Tools
Customize Customizes user interface elements such as menus, toolbars, and workspaces Tools
CustomPaperSize Manages custom paper sizes for built-in printers (PDF, PNG, JPG, SVG, or DWF).
Cut Copies entities to the clipboard and deletes the entities Edit

 

    ^ Top of Page

D

Command Description Menu
Delete Removes entities from the drawing Edit
DeleteLayer Deletes entities and the layer of selected entities Format > Layer Tools
DetachDrawing Detaches referenced drawings that were attached to the current drawing
DetachImage Detaches referenced images attached to the drawing
DetachLink Detaches hyperlinks from specified entities
DetachPDF Detaches PDF Underlays that were attached to the current drawing
DetachPDF Detaches PDF Underlays that were attached to the current drawing
DiameterDimension Creates diameter Dimensions for Circles and Arcs Dimension
Dimensioning Click here for Dimensioning Commands
DimensionStyle Creates and modifies DimensionStyles (dialog box variant) Format
-DimensionStyle Creates and modifies DimensionStyles (command window variant) Format
DirectionalLight Inserts a directional, distant light for subsequent rendering
DiscardDuplicates Removes duplicate entities or overlapping parts of entities from the drawing (dialog box variant) Modify
-DiscardDuplicates Removes duplicate entities or overlapping parts of entities from the drawing (command window variant)
DisplayBlockAttributes Defines visibility of BlockAttributes View > Display
DisplayCoords Tracks pointer movements on the status bar
DisplayDialogs Determines whether to display dialog boxes when you need to specify a file name
DisplayFills Controls fills visibility for wide PolyLines, Solids, Traces, Hatches, and Gradients
DisplayImageFrame Determines whether frames are displayed at the borders of Referenced images
DisplayOrder Changes the display order of drawing entities and inserted images in the drawings Tools
DisplayQuality Controls the resolution of circular and curved entities
DraftingOptions Sets drafting options like Snap, Grid, Ortho mode, Polar Guides, EntitySnaps (ESnaps), and EntityTracking (ETrack) Tools
DraftingStyles Manages TextStyles, DimensionStyles, RichLineStyles, and TableStyles, and sets styles for use with subsequent commands
DrawingBounds Sets and controls the drawing bounds
DrawingProperties Displays and edits the standard properties of the current drawing file and creates custom properties for the file File
DrawingSettings Sets the behavior of drawing commands, the appearance of certain drawing entities, the unit system of the current drawing, and manages Custom Coordinate Systems (CCSs)
DrawingStandards Associates drawing standards to the current drawing, determines the drawing categories to check, and sets notification and audit options Tools > Standards
DrawingTabs Shows drawing tabs at the top of the drawing window area

 

    ^ Top of Page

E

Command Description Menu
EdgeMesh Creates a 3D PolygonMesh based on four adjoining edges Draw > Mesh
EditAnnotation Edits items such as single-line Text, Dimension text, Leader annotation, and BlockAttribute definitions Modify > Entity
EditBasePoint Sets new insertion base points for Block definitions Modify > Component
EditBlockAttribute Modifies BlockAttributes (dialog box variant) Modify > Entity
-EditBlockAttribute Modifies BlockAttributes (command window variant)
EditBlockAttributeDefinition Modifies an existing BlockAttribute definition (dialog box variant) Modify > Entity
-EditBlockAttributeDefinition Modifies an existing BlockAttribute definition (command window variant)
EditComponent Edits in-place individual entities within Blocks or References Modify > Component
EditDimension Edits Dimension text or Dimension extension lines
EditDimensionText Moves and rotates Dimension text Dimension > Align Text
EditEntityGroup Adds and removes entities to or from EntityGroups, or renames EntityGroups Tools > Entity Groups
EditHatch Modifies an existing Hatch or Fill (dialog box variant) Modify > Entity
-EditHatch Modifies an existing Hatch or Fill (command window variant)
EditImage Attaches and detaches images to and from the drawing and manages image References
EditIpBlockAttribute Edits in-place BlockAttribute values
EditLength Lengthens or shortens an entity Modify
EditMultiLeader Adds leader lines to, or removes leader lines from MultiLeaders Modify > Entity
EditPattern Modifies the shape and appearance of associative pattern (dialog box variant) Modify
-EditPattern Modifies the shape and appearance of associative pattern (command window variant)
EditNote Edits Notes (multiline text)
EditPolyLine Edits PolyLines, PolyLine vertices, and 3D PolygonMeshes Modify > Entity
EditRichLine Edits intersecting and adjoining RichLines, breaks and welds RichLines, and adds or deletes vertices to or from existing RichLines (dialog box variant) Modify > Entity
-EditRichLine Edits intersecting and adjoining RichLines, breaks and welds RichLines, and adds or deletes vertices to or from existing RichLines (command window variant)
EditScaleList Customizes the list of scales for printing, managing Print Configurations, and scaling Viewports in layout Sheets (dialog box variant) Format
-EditScaleList Customizes the list of scales for printing, managing Print Configurations, and scaling Viewports in layout Sheets (command window variant)
EditSpline Modifies the parameters of a specified spline or converts a spline-fit Polyline to a Spline Modify > Entity
EditTable Changes text in a Table cell Modify > Entity
EditTableCell Inserts, deletes, merges, or resizes cells, rows, and columns in Tables Modify > Entity
EditTolerance Modifies Tolerances (datum indicators and basic dimension notation) Modify > Entity
EditVertex Edits 2D PolyLine vertices
eDrawings Starts the eDrawings® application to create, view, and share 3D models and 2D drawings File
Ellipse Creates an Ellipse or an Elliptical Arc Draw
-EmbedDrawing Embeds dependent objects and styles of Referenced drawings in the drawing
EntityGrips Sets preferences for editing with EntityGrips
EntityGroup Creates a user-defined selection set of entities (dialog box variant)
-EntityGroup Creates a user-defined selection set of entities (command window variant)
EntityGroupDisplayMode Sets options for EntityGroup selection
EntitySnap Sets running EntitySnap modes (dialog box variant)
-EntitySnap Sets running EntitySnap modes (command window variant)
Exit Exits the software File
Exit Exits the software Application Menu
Explode Breaks complex objects into their component entities Modify
ExplodeText Converts annotations into Polylines, which represent the text outline
ExplodeX Converts Ellipses and Splines into Polylines
Export Saves entities to other file formats File > Export
ExportBMP Saves the drawing display to a file in a device-independent bitmap format
ExportDrawing Writes entities, Blocks, or the entire drawing to a new drawing file (dialog box variant) File > Export
-ExportDrawing Writes entities, Blocks, or the entire drawing to a new drawing file (command window variant)
ExportDXF Exports the drawing as a DXF file
ExportEMF Saves specified entities to an EMF file (Windows Enhanced Metafile)
ExportEPS Saves the current view of the graphics display to an EPS file (Encapsulated PostScript)
ExportJPG Saves specified entities to a JPEG file
ExportPDF Saves the current view of the graphics display to a PDF file (Portable Document Format) File > Export
ExportPNG Saves specified entities to a PNG file (Portable Network Graphics)
ExportSAT Exports solid modeling objects from the drawing to an ACIS SAT file
ExportSLD Stores the current view to a slide file
ExportSVG Stores the current view to an SVG file
ExportWMF Saves specified entities to an WMF file (Windows Metafile)
Extend Extends entities to bounding edges defined by other entities Modify
ExtractBlockAttribute Extracts BlockAttribute values of selected Blocks to text files based on a template file defining the data to write (dialog box variant)
-ExtractBlockAttribute Extracts BlockAttribute values of selected Blocks to text files based on a template file defining the data to write (command window variant)

 

    ^ Top of Page

F

Command Description Menu
Face Creates a 3D face Draw > Mesh
Field Creates Fields for annotations that are used to update information such as modification date, drawing name, and author Insert
FileLocations Lets you view, set, and edit default paths and/or file names
FileManager Displays the operating system's file manager
FillArea Fills an area with a solid color or color gradient Draw
Fillet Rounds and fillets the edges of entities Modify
Find Finds and replaces Text in Notes, Annotations, and Dimension Text Edit
Flip Mirrors and deletes the original entity
FlipArrows Changes the position of dimension arrows
FontAlt Sets an alternate font to use if the original font is not found
FreezeLayer Freezes the Layers of selected entities Format > Layer Tools
FullScreen Displays the graphics area as a full screen (without toolbars and palettes) View

 

    ^ Top of Page

G

Command Description Menu
Gesture Customizes mouse gestures Tools
GetAngle Measures angles between two line or polyline segments Tools > Inquiry
GetArea Calculates the area and perimeter of entities or of defined areas Tools > Inquiry
GetDistance Measures the distance and angle between two points Tools > Inquiry
GetProperties Displays information about selected entities Tools > Inquiry
GetStatus Displays status information about settings and memory usage of the drawing
GetTime Displays time related statistics about the drawing and lets you turn on or off, or reset a timer
GetXY Displays the coordinate values of a location Tools > Inquiry
Gravity Determines the size of the EntitySnap target box
Grid Turns the grid display on or off and sets other grid options

 

    ^ Top of Page

H

Command Description Menu
Hatch Fills a selected boundary with a pattern (dialog box variant) Draw
-Hatch Fills a selected boundary with a pattern (command window variant)
Help Displays online help Help
HideCommandHistory Closes the command history window
HideCommandWindow Hides the command prompt area
HideDrawingTabs Hides drawing tabs at the top of the drawing window area
HideEntities Hides specified entities
HideFullScreen Returns from full screen display mode (without toolbars and palettes) to normal display mode
HideLayer Turns off the Layer of the selected entity Format > Layer Tools
HideLightlist Hides the Lighting palette
HideProperties Hides the Properties palette
HideReferences Hides the References palette
HideToolMatrix Hides the Tool Matrix
HideView Creates a hidden line view View
HorizontalDimension Creates horizontal linear Dimensions
Home Displays a palette that contains centralized links to online tutorials and webinars, community resources, support, and news
Hyperlink Attaches a hyperlink to entities or modifies an existing hyperlink (dialog box variant) Insert
-Hyperlink Attaches a hyperlink to entities or modifies an existing hyperlink (command window variant)

 

    ^ Top of Page

I

Command Description Menu
ImageMenu Displays custom image menus for command sequences to execute
ImageQuality Determines the display quality of images attached to the drawing
Import Imports drawing files created by other applications or CAD programs
ImportDXF Opens the selected DXF file in a separate drawing window
ImportPDF Inserts content from Adobe® PDF files as Blocks into the drawing (all or selected pages from multiple page PDF documents) Insert
ImportSAT Reads an .sat file and inserts the contained ACIS solid objects into the drawing
InfiniteLine Draws an infinite construction line Draw
InsertBlock Inserts a Block or another drawing (dialog box variant) Insert
-InsertBlock Inserts a Block or another drawing (command window variant)
InsertBlockN Inserts multiple copies of a Block or Reference in a pattern, arranged in rows and columns
InsertObject Displays data from other programs in drawings (such as text documents, spreadsheets, or images) Insert
-InsertReference Inserts dependent objects and styles of referenced drawings into the drawing
InsertShape Inserts a shape from a shape file into the drawing Draw > Shape
IsolateEntities Isolates specified entities by hiding all other entities
IsolateLayer Isolates the Layers of selected entities Format > Layer Tools
IsometricGrid Controls the isometric plane (Left, Right, or Top) when using isometric snap

 

    ^ Top of Page

J

Command Description Menu
JoggedDimension Creates jogged radius Dimensions for Circles and Arcs Dimension

 

    ^ Top of Page

L

Command Description Menu
Language Sets the language to communicate with the software
Layer Controls Layers and Layer properties (dialog box variant) Format
-Layer Controls Layers and Layer properties (command window variant)
LayerPreview Previews the content of layers one by one for a set of specified layers Format > Layer Tools
LayersPDF Controls the layer visibility of a PDF Underlay Format
LayersPDF Controls the layer visibility of a PDF Underlay Format
LayerState Saves, restores, and manages configurations of Layer properties and states Format > Layer Tools
Leader Draws Leader lines which connect annotations to drawing entities
Light Creates a Light in the drawing
Lightlist Displays the Lighting palette
Line Creates straight line segments Draw
LinearDimension Creates a linear Dimension Dimension
LinearPattern Creates copies of specified entities in a linear matrix (command window variant of the Pattern command, Linear option)
LineColor Sets the LineColor for new entities (dialog box variant) Format
-LineColor Sets the LineColor for new entities (command window variant)
LineScale Sets the global LineStyle scale factor
LineStyle Creates, loads, and sets LineStyles (dialog box variant) Format
-LineStyle Creates, loads, and sets LineStyles (command window variant)
LineWeight Sets LineWeight options (dialog box variant) Format
-LineWeight Sets LineWeight options (command window variant)
LoadApplication Loads applications for use in the program Tools
LoadCustomization Adds or removes partial customization files to or from the main customization file
LoadMenu Changes the main customization file
LoadScript Executes a sequence of commands from a script Tools
LoadShape Loads shape files for use by the Shape command Draw > Shape
LockInterface Locks the location of docked and floating toolbars
LockLayer Locks the Layers of selected entities Format > Layer Tools
LogFileOff Deactivates recording command executions
LogFileOn Activates recording command executions

 

    ^ Top of Page

M

Command Description Menu
MakeBlock Creates a Block from selected entities (dialog box variant) Draw > Block
-MakeBlock Creates a Block from selected entities (command window variant)
MakeBlockAttribute Creates a BlockAttribute definition (dialog box variant) Draw > Block
-MakeBlockAttribute Creates a BlockAttribute definition (command window variant)
MakeSlideLibrary Creates a catalog of slide files in a slide library file for use in image menus
MarkDivisions Places evenly spaced point entities or Blocks along the length or perimeter of an entity Draw > Point
MarkLengths Places point entities or Blocks at measured intervals on an entity Draw > Point
Mask Covers existing entities with a blank area Draw
MatchLayer Changes the Layer of selected entities to match a destination Layer Format > Layer Tools
Mesh Creates a 3D PolygonMesh Draw > Mesh
Migration Migrates profiles, preferences, file location settings, and UI customizations from a previous version of the software
Mirror Creates a mirror image copy of entities Modify
Mirror3D Creates a mirror image of entities about a plane in 3D space Modify > 3D Operations
MirrorHatch Determines whether hatches and gradient fills are reflected or retain their pattern direction when you apply Mirror and Flip commands
Model Toggles from a Sheet tab to the Model tab
ModelBackgroundColor Sets the background color for the graphics area
ModelMode Toggles from sheet workspace to a model workspace on Sheets
Modify Changes the properties of drawing entities
ModifyProperties Changes the Layer, LineColor, LineStyle, LineScale, transparency, and thickness of entities
Move Displaces entities a specified distance in a specified direction Modify
MoveDimensionText Moves Dimension text
MultiLeader Creates MultiLeaders based on MultiLeaderStyles Dimension
MultiLeaderStyle Creates and manages MultiLeaderStyles Format

 

    ^ Top of Page

N

Command Description Menu
New Creates a new drawing file File
NewDimensionStyle Creates a new dimension style from a specified dimension
Nontargetlight Creates a free Nontargetlight (a light without a target)
Note Creates Text entities (dialog box variant) Draw > Text
-Note Creates Text entities (command window variant)
NoteOptions Sets preferences for text editing with the Note and SimpleNote commands

 

    ^ Top of Page

O

Command Description Menu
ObliqueDimension Modifies the orientation of existing linear Dimensions
Offset Offsets linear entities in parallel orientation Modify
Open Opens an existing drawing file File
OpenOLE Opens OLE objects for modification
OpenReference Opens a Referenced drawing in a new drawing window Tools
OpenWebpage Displays the specified Web site
Options Configures program operating parameters Tools
Options Configures program operating parameters Application Menu
OrdinateDimension Creates ordinate point Dimensions Dimension
Ortho Constrains the pointer so it moves parallel to the axes of the current coordinate system
OSCalc Opens the standard calculator of the operating system you use
OverrideDimensionStyle Overrides DimensionStyle variables Dimension

 

    ^ Top of Page

P

Command Description Menu
PackAndGo Creates a package containing the current drawing and its dependent files such as References, referenced images, referenced PDF files, font files, font mapping files, PrintStyle files, and Print Configuration files (dialog box variant). File > Export
-PackAndGo Creates a package containing the current drawing and its dependent files such as References, referenced images, referenced PDF files, font files, font mapping files, PrintStyle files, and Print Configuration files (command window variant).
PageLayoutIn Imports user-defined PageLayouts contained in other drawing files into the current drawing (dialog box variant)
-PageLayoutIn Imports user-defined PageLayouts contained in other drawing files into the current drawing (command window variant)
Pan Moves the drawing display in the active ViewTile (dynamic pan) View > Pan
-Pan Moves the drawing display in the active ViewTile by pointing a displacement View > Pan
PanDown Pans down View > Pan
PanLeft Pans left View > Pan
PanRight Pans right View > Pan
PanUp Pans up View > Pan
ParallelDimension Creates an aligned linear Dimension Dimension
Paste Inserts data from the clipboard Edit
PasteAsBlock Inserts entities from the clipboard as Block Edit
Paste@SourcePosition Pastes entities from the OS clipboard using the coordinates of the source drawing
PasteSelected Pastes entities from the OS clipboard by specifying a format Edit
PathPattern Command window variant of the Pattern command, Path option
Pattern Creates multiple copies of entities in a pattern (dialog box variant) Modify
-Pattern Creates multiple copies of entities in a pattern (command window variant)
Pattern3D Creates a linear or circular pattern of entities in 3D space Modify > 3D Operations
PauseScript Causes a timed pause within a script
PDFUnderlayOptions Controls EntitySnap access and frame visibility for PDF Underlays
PDFUnderlayOptions Controls EntitySnap access and frame visibility for PDF Underlays
PlanView Sets plan view to construction plane
Point Creates a point entity Draw
PointFormat Defines the type and size of point entities Format
PointLight Creates a pointlight
PolyFace Creates a 3D polyface mesh vertex by vertex
Polygon Creates an equilateral closed PolyLine Draw
PolyLine Creates 2D PolyLines Draw
PolyLine3D Creates a 3D PolyLine of straight line segments in 3D space Draw
Preview Shows a preview for printing the drawing (dialog box variant). File
-Preview Shows a preview for printing the drawing (command window variant).
Print Plots the drawing to a plotter, printer, or file (dialog box variant) File
-Print Plots the drawing to a plotter, printer, or file (command window variant)
PrintConfiguration Defines Print Configurations to use as printing defaults for the Model and for Sheets File
PrintStamp Prints or plots a printstamp with the drawing output
PrintStyle Manages named PrintStyles (dialog box variant) Format
-PrintStyle Manages named PrintStyles (command window variant)
Profiles Stores individual profiles based on specified settings and manages profiles
Properties Displays the Properties palette to change drawing entity properties
PropertyPainter Applies properties from one entity to selected entities Modify

 

    ^ Top of Page

Q

Command Description Menu
QuickGroup Quickly creates EntityGroups Tools > Enitity Groups
QuickModify Copies, moves, rotates, and scales entities in one operation Modify
QuickPrint Prints the current view of a drawing to the printer that is set as the default output device
QuickUngroup Quickly ungroups EntityGroups Tools > Enitity Groups

 

    ^ Top of Page

R

Command Description Menu
RadiusDimension Creates radial Dimensions for Circles and Arcs Dimension
Ray Draws semi-infinite construction lines Draw
Rebuild Rebuilds the drawing and refreshes the active ViewTile View
RebuildAll Rebuilds the drawing and refreshes all ViewTiles View
RebuildDimension Updates Dimensions with the active DimensionStyle Dimension
RebuildField Manually updates Fields in specified annotations Insert
Recent Browses recent documents and opens them from the Recent Documents preview list File
Recover Repairs damaged drawings File
Rectangle Creates a rectangular PolyLine Draw
Redefine Restores built-in commands that have been undefined using the Undefine command
Redo Reverses the effects of a previous U or UndoN command Edit
RedoN Reverses last or all previous U and UndoN commands
References Displays the References palette Tools
-References Controls and manages Referenced drawings
Refresh Refreshes the display of the active ViewTile
RefreshAll Refreshes the display of all currently open ViewTiles View
Region Converts an entity enclosing an area into a Region Draw
RelateDimension Reestablishes the relation of specified Dimensions to entities Dimension
Rename Changes the names of objects (dialog box variant) Format
-Rename Changes the names of objects (command window variant)
Repeat Repeats a specified command
ReplaceDimensionText Modifies the Dimension text value
ReplaceNew Replaces the current drawing with an empty one
ReplaceOpen Replaces the current drawing with a specified one
ReplaceRecover Replaces the current drawing with a recovered one
ResetDimensionText Undoes the movement of Dimension text
ResetOLE Resets OLE objects to their original size
ResumeScript Resumes an interrupted script execution
RevolvedMesh Creates a rotated surface about a specified axis Draw > Mesh
RichLine Creates RichLines Draw
RichLineStyle Creates and manages RichLineStyles Format
Ring Creates a filled Circle or Ring Draw
RollView Rotates the view in 3D space View > 3D Orbit
RollViewAutoTarget Controls RollView AutoTarget Mode
RollViewCenter Sets the center of rotation for constraint orbit view and starts rotation View > 3D Orbit
RollViewContinuous Rotates the view in 3D space with continuous motion about a specified pivot point View > 3D Orbit
RollViewFree Rotates the view in 3D space without constraining roll View > 3D Orbit
RollViewHorizontal Swivels the view in 3D space horizontally (left and right) about an imaginary vertical axis View > 3D Orbit
RollViewVertical Tilts the view in 3D space vertically (up and down) about an imaginary horizontal axis View > 3D Orbit
Rotate Rotates entities about a base point Modify
Rotate3D Moves entities about a 3D axis Modify > 3D Operations
RotatedDimension Creates rotated linear Dimensions
RotateDimensionText Rotates Dimension text
RuledMesh Creates a ruled surface between two curves Draw > Mesh

 

    ^ Top of Page

S

Command Description Menu
Save Saves the drawing under the current file name or a specified name File
SaveAll Saves all open drawings
SaveAs Saves an unnamed drawing with a file name or renames the current drawing File
SaveComponent Saves modifications done during in-place editing of Block defintions or References and exits Component editing mode Modify > Component
Scale Enlarges or reduces specified entities equally in the X, Y, and Z directions Modify
ScriptN Repeats script execution
Select Places selected entities in the 'Previous' selection set
SelectAll Selects all drawing entities for subsequent modification commands Edit
SelectionFilter Determines a list of requirements that drawing entities must meet to be included in a selection set
SelectMatching Selects drawing entities of the same type and with shared properties for subsequent commands
SetByLayer Changes property overrides of specified entities to ByLayer
SetFieldDisplay Specifies whether Fields display with a gray background in annotations
SetVariable Lists or sets the values of command variables
Shade Shades the drawing model
ShadeView Determines the ShadeView mode View
Sheet Create, copy, rename, or delete Sheet tabs (layout mode to set up a printout) File
SheetMode Toggles from a model workspace to sheet workspace on Sheets
Shell Executes utility programs or accesses normal operating system (OS) commands in the OS shell
ShowLayers Turns on all Layers Format > Layer Tools
ShowLicense Displays the license agreement Help
SimpleNote Creates single line text Draw > Text
-SimpleNote Displays Text on screen you enter it
SimplePolygon Creates an equilateral closed PolyLine
Sketch Creates freehand lines Draw
SmartBMP Saves a specified view of the drawing to a bitmap (BMP) file
SmartCalculator Performs mathematical and trigonometric computations and unit conversions
SmartDimension Creates Dimensions with a dimension type determined by the entity selected Dimension
SmartLeader Draws Leader lines and annotations Dimension
SmartNew Starts a new drawing with the default template drawing
SmartOpen Opens a drawing specified at the command prompt
SmartSelect Creates entity selections based on filtering criteria
Snap Restricts pointer movements and pointing to the drawing to specified intervals
Solid Creates solid-filled 2D faces Draw > Mesh
SpellCheck Checks the spelling of Text in the drawing
Spline Creates quadratic or cubic Spline (NURBS) curves Draw
Split Deletes parts of entities or splits entities in two Modify
SpotLight Inserts a spotlight into the drawing
StackOptions Sets the alignment and size for stacked text in annotations
Stretch Moves or stretches entities Modify
SwitchArea Switches Between Model and Sheet Tabs
SystemOptions Determines general operating options

 

    ^ Top of Page

T

Command Description Menu
Table Creates a Table in the drawing (dialog box variant) Draw
-Table Creates a Table in the drawing (command window variant)
TableStyle Creates and manages TableStyles Format
TabulatedMesh Creates a tabulated surface from a path curve and a direction vector Draw > Mesh
TargetpointLight Creates a targetpointlight
TextStyle Creates or modifies TextStyles and sets the active TextStyle (dialog box variant) Format
-TextStyle Creates or modifies TextStyles and sets the active TextStyle (command window variant)
ThawLayers Thaws all Layers Format > Layer Tools
ToActiveLayer Changes the Layers of specified entities to the active Layer Format > Layer Tools
Tolerance Creates Tolerances (datum indicators and basic dimension notation) Dimension
Toolbars Displays and hides toolbars (dialog box variant)
-Toolbars Displays and hides toolbars (command window variant)
ToolMatrix Displays the Tool Matrix
Trace Draws a Trace
Trapezoid Creates a trapezoid 2D PolyLine
Trim Trims entities at a cutting edge defined by other entities Modify

 

    ^ Top of Page

U

Command Description Menu
U Reverses the most recent command Edit
UIMode Specifies whether to use Mac-style floating user interface elements or the joint-style user interface elements in the program desktop
UIProfile Manages user interface profiles
Undefine Disables a built-in command
Undelete Restores deleted entities
UndoLayer Restores previous Layer settings Format > Layer Tools
UndoN Reverses the effect of commands
UnisolateEntities Shows entities that were hidden with the IsolateEntities or HideEntities commands
UnisolateLayer Undoes Layer isolation Format > Layer Tools
UnitSystem Sets coordinate and angle display formats and precision (dialog box variant) Format
-UnitSystem Sets coordinate and angle display formats and precision (command window variant)
UnloadCustomization Unloads partial customization files
UnlockLayer Unlocks locked Layers Format > Layer Tools
UnrelateDimension Dissolves the relation of specified Dimensions to entities
UpdateBlockAttributes Updates all instances of Blocks in the drawing with new or modified BlockAttributes
UserPreferences Defines drafting options, mouse options, and alias commands

 

    ^ Top of Page

V

Command Description Menu
VerifyDimensions Verifies all measurements of related Dimensions in the drawing
VerifyStandards Verifies that the drawing conforms to industry, corporate, and custom standards Tools > Standards
VerticalDimension Creates vertical linear Dimensions
ViewDirection Sets the viewing direction for a 3D view of the drawing
Viewport Creates and controls Viewports on Sheet tabs
-Viewport Creates and controls single or multiple Model ViewTiles or Sheet Viewports (command window variant)
ViewportLayer Controls Layer visibility in Viewports on Sheets
Views Saves, restores and manages user-defined model and Sheet views, and preset views (dialog box variant) View
-Views Saves, restores and manages user-defined model and Sheet views, and preset views (command window variant)
ViewSlide Displays a slide file in the graphics area
ViewTiles Creates and controls single or multiple Model ViewTiles or Sheet Viewports (dialog box variant) View > View Tiles

 

    ^ Top of Page

W

Command Description Menu
Weld Joins two entities into a single entity Modify
Windows Lets you cascade and tile windows Window

 

    ^ Top of Page

Z

Command Description Menu
Zoom Increases or decreases the visible part of the drawing View
ZoomBack Zooms to previous view View > Zoom
ZoomDynamic Zooms the drawing at realtime (dynamic zoom) View > Zoom
ZoomFactor Zooms by a factor View > Zoom
ZoomFit Zooms to the drawing extents View > Zoom
ZoomIn Zooms in to the drawing View > Zoom
ZoomOut Zooms out from the drawing View > Zoom
ZoomWindow Zooms to a region of the drawing specified by a box View > Zoom
ZPlane Sets elevation and thickness of new drawing entities

 

    ^ Top of Page

DIMENSIONING COMMANDS

Command Description Menu
3PointAngleDimension Creates an angular Dimension based on three points
4PointAngleDimension Creates an angular Dimension based on four points
AngleDimension Creates an angle Dimension Dimension
ArcLengthDimension Creates an arc length Dimension Dimension
BaselineDimension Continues a linear, angular, or ordinate Dimension from the baseline of the previous or specified Dimension Dimension
CenterMark Creates a center mark or center lines for Circles and Arcs Dimension
ContinueDimension Continues a linear, angular, or ordinate Dimension from the second extension line of the previous or a specified Dimension Dimension
DiameterDimension Creates diameter Dimensions for Circles and Arcs Dimension
DimensionStyle Creates and modifies DimensionStyles (dialog box variant) Format
-DimensionStyle Creates and modifies DimensionStyles (command window variant)
EditDimension Edits Dimension text or Dimension extension lines
EditDimensionText Moves and rotates Dimension text Dimension > Align Text
FlipArrows Changes the position of dimension arrows
HorizontalDimension Creates horizontal linear Dimensions
JoggedDimension Creates jogged radius Dimensions for Circles and Arcs Dimension
Leader Draws Leader lines which connect annotations to drawing entities
LinearDimension Creates a linear Dimension Dimension
MoveDimensionText Moves Dimension text
NewDimensionStyle Creates a new dimension style from a specified dimension
ObliqueDimension Modifies the orientation of existing linear Dimensions
OrdinateDimension Creates ordinate point Dimensions Dimension
OverrideDimensionStyle Overrides DimensionStyle variables Dimension
ParallelDimension Creates an aligned linear Dimension Dimension
RadiusDimension Creates radial Dimensions for Circles and Arcs Dimension
RebuildDimension Updates Dimensions with the active DimensionStyle Dimension
RelateDimension Reestablishes the relation of specified Dimensions to entities Dimension
ReplaceDimensionText Modifies Dimension text value
ResetDimensionText Undoes the movement of Dimension text
RotatedDimension Creates rotated linear Dimensions
RotateDimensionText Rotates Dimension text
SmartDimension Creates Dimensions with a dimension type determined by the entity selected Dimension
SmartLeader Draws Leader lines and annotations Dimension
UnrelateDimension Dissolves the relation of specified Dimensions to entities
VerifyDimensions Verifies all measurements of related Dimensions in the drawing
VerticalDimension Creates vertical linear Dimensions

 

    ^ Top of Page



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Command Reference: Commands in Alphabetical Order
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2022 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.