Hide Table of Contents

Managing Layers

Use the Layer command to create new Layers, set the active Layer, and specify Layer properties and behavior.

The command opens the Layers Manager dialog box.

For basic information on Layers, see Organizing the Drawing with Layers.

To access the Layers Manager dialog box:

  • Do one of the following:
    • Click Format > Layer on the menu.
    • Click Home > Layer > Layer Manager  on the ribbon.
    • Type Layer.

Creating Layers

You can create a new Layer any time. For efficiency, it is recommended that you plan Layers in advance.

You can also create Layers which will be initially freezed in all existing Viewports on layout Sheets. This option is available from the Model and on layout Sheets.

To create a new Layer:

  1. In the Layers Manager dialog box, click New.
  2. Type a Layer Name and press Enter.

Note: If you want to create a new Layer with properties similar to that of an existing Layer, select that Layer in the Layers Manager, then click New. You have to change only those properties that you want be different.

To create a Layer initially freezed in all existing Viewports on layout Sheets:

  1. In the Layers Manager dialog box, click New - VP Freeze.
  2. Type a Layer Name and press Enter.

Note: It is advisable to create a new Layer frozen in all existing Viewports if you want to thaw it selectively in only some Viewports, or if you want to use the Layer only in the Model.

Deleting Layers

You can delete unused Layers.

To delete Layers:

  1. In the Layers Manager dialog box, select a Layer.
  2. Click Delete.

    The Layer is marked for deletion when the Status changes to .

  3. Repeat step 2 to delete other Layers.
  4. Click OK.

    The Layers marked for deletion are erased.

Note: You cannot delete Layers containing entities, the active Layer, Layer 0, or dependent Layers of referenced drawings.

Setting the Active Layer

One of the Layers must be the active one.

To set the active Layer:

  1. In the Layers Manager dialog box, select a Layer.
  2. Click Activate.

    - or -

    Double-click the Status cell of the Layer you want active.

    The Status changes to .

Applying Layer States

You can save, restore and manage Layer States. Layer States are snapshots of current Layer settings.

To apply Layer States:

  1. In the Layers Manager dialog box, click Layer States.
  2. In the Layer States dialog box, save, restore and manage Layer States.

Searching for Layers

In drawings with many Layers you can search for a specific Layer if you know a portion of the name.

To search for Layers:

  • In the Filter expression box, type wildcards (? for a single character, or * for a string of characters) to list the matching Layer names.

    For example, type "e*" to display all Layers starting with "e", or "*detail" to display all Layers ending with "detail" in the name.

You can use the following wildcards:

Wildcard Meaning Examples
* (asterisk) Matches any string and can be used anywhere in the search string 2D* lists all Layer`names starting with 2D
? (question mark) Matches any single character ?BC matches ABC, BBC, CBC, etc.
~ (tilde) Matches anything but the pattern ~*XY* matches all Layer names that do not contain XY
# (pound) Matches any numeric digit #D matches 2D, 3D, 4D, etc.
@ (at) Matches any alphabetic character  
. (period) Matches any non-alphanumeric character  
` (reverse quote) Reads the next character literally `~XY matches ~XY
[] Matches any one of the characters enclosed  [AB]C matches AC and BC
[~] Matches any character not enclosed [~AB]C matches XC but not AC

Renaming Layers

You can change the names of existing Layers.

To rename Layers:

  1. In the Layers Manager dialog box, double-click the Name cell of the Layer to rename.
  2. Type the new name and press Enter.

Setting Layer Properties

You can set the following properties for Layers: LineColor, LineStyle, LineWeight, transparency, PrintStyle, and a description.

LineColor

When you start a new drawing, new Layers are automatically assigned the color white. When you create a new Layer, the Layer adopts the color of the selected Layer.

Entities you draw on the Layer appear in the assigned Layer color except those to which you assign a LineColor directly (see: Setting LineColors).

To set Layer LineColors:

  1. In the Layers Manager dialog box, double-click the LineColor cell you want to change.
  2. Select a LineColor or select Specify Color for more colors.

    The LineColor for the Layer is set. When you change the color, all entities on the Layer that were sketched with the color designated as ByLayer appear with the changed color. Entities on the Layer that were sketched with a color other than the ByLayer color are not affected.

LineStyle

When you start a new drawing, new Layers are automatically assigned the continuous LineStyle. When you create a new Layer, the Layer adopts the LineStyle of the selected Layer.

Entities you draw on the Layer appear in the assigned LineStyle except those to which you assign a LineStyle directly (see: Loading and Setting LineStyles).

To set Layer LineStyles:

  1. In the Layers Manager dialog box, double-click the LineStyle cell you want to change.
  2. Select a LineStyle or select Other to load a new LineStyle in the Line Style dialog box.

    The LineStyle for the Layer is set. When you change the LineStyle, all entities on the Layer that were sketched with the LineStyle designated as ByLayer appear with the changed LineStyle. Entities on the Layer that were sketched with a LineStyle other than the ByLayer LineStyle are not affected.

LineWeight

When you start a new drawing, new Layers are automatically assigned the default LineWeight. When you create a new Layer, the Layer adopts the LineWeight of the selected Layer.

Entities you draw on the Layer appear with the assigned LineWeight except those to which you assign a LineWeight directly (see: Setting the Active LineWeight).

To set Layer LineWeights:

  1. In the Layers Manager dialog box, double-click the LineWeight cell you want to change.
  2. Select a LineWeight.

    The LineWeight for this Layer is set. When you change the LineWeight, all entities on this Layer that were sketched with the LineWeight designated as ByLayer appear with the changed LineWeight. Entities on the Layer that were sketched with a LineWeight other than the ByLayer LineWeight are not affected.

Transparency

You can specify the transparency level for specific Layers. When you start a new drawing, new Layers automatically have no transparency. When you create a new Layer, the Layer adopts the transparency of the selected Layer.

Entities you draw on the Layer appear with the assigned transparency except those to which you assign a transparency directly.

To set Layer transparency:

  1. In the Layers Manager dialog box, double-click the Transparency cell to change.
  2. Specify a value between 0 and 90% where 0% means no transparency (opaque).

    The transparency for the Layer is set. When you change the transparency, all entities on the Layer that you created with the transparency designated as ByLayer appear with the specified transparency. Entities on the Layer that you created with a transparency other than ByLayer are unaffected.

PrintStyle

You can specify whether to print the content of specific Layers with indivual PrintStyles. When you create a new Layer, the Layer adopts the PrintStyle of the selected Layer.

Entities you draw on the Layer appear with the assigned PrintStyle except those to which you assign a PrintStyle directly.

To set Layer PrintStyles:

  PrintStyles are only valid if the drawing uses named PrintStyles (.stb files), not color-dependent PrintStyles (.ctb files). You can set named PrintStyles in Tools > Options > System Options > Printing > Default settings > Default type.

  1. In the Layers Manager dialog box, double-click the PrintStyle cell you want to change.
  2. Select a PrintStyle or select Other to load a new PrintStyle in the Print Styles dialog box.
Description

Optionally you can add a description for each Layer.

To add Layer descriptions:

  1. In the Layers Manager dialog box, double-click the Description cell you want to add.
  2. Type a description, then pressEnter.

Controlling Layer Behavior

You can show and hide, freeze and thaw, lock and unlock Layers. You can determine whether Layers are printed or plotted.

And you can predefine whether Layers are frozen or thawed in new Viewports on layout Sheets.

Showing and hiding Layers

When a Layer is shown, the entities on it are visible. Entities on hidden Layers are invisible.

To show or hide Layers:

  • In the Layers Manager dialog box, click the icon in the Show cell you want to change.

    A green dot  means show. A gray dot  means hide.

Freezing and thawing Layers

Freezing and thawing controls the visibility and the ability to edit Layers.

When a Layer is frozen, its entities are protected and invisible. Unlike entities on Layers that are turned off, entities on frozen Layers are ignored when the drawing rebuilds. Entities on thawed Layers are unprotected and visible.

  You cannot freeze the active Layer.

To freeze or thaw Layers:

  • In the Layers Manager dialog box, click the icon in the Frozen cell you want to change.

    A snow symbol means frozen. A water symbol  means thawed.

Locking and unlocking Layers

When a Layer is locked, you cannot edit the entities on that Layer. You can edit entities on unlocked Layers.

  When you lock the active Layer, you can create, but not modify entities on it.

To lock or unlock Layers:

  • In the Layers Manager dialog box, click the icon in the Lock cell you want to change.

    A closed lock  means locked. An open lock  means unlocked.

Printing Layers

You can determine whether Layers are printed or plotted. If you turn off printing for a Layer, the entities on the Layer are still displayed.

Hidden or frozen Layers are not printed regardless of the Print setting.

To specify whether a Layer is printed:

  • In the Layers Manager dialog box, click the icon in the Print cell you want to change.

    The printer icon  means print. A stroked out printer icon  means do not print.

Freezing Layers in new Viewports on layout Sheets

You can predefine whether Layers are frozen or thawed in new Viewports on layout Sheets.

Freezing specific Layers in all new Viewports restricts the display of the entities on those Layers in any newly created Viewports on layout Sheets but does not affect the Layer behavior and properties in existing Viewports. If you later create a Viewport that requires to display of the Layer, you can change the current setting for the Viewport.

To specify whether Layers are frozen in new Viewports:

  • In the Layers Manager dialog box, click the icon in the New Viewport cell you want to change.

    The symbol means frozen. The symbol  means thawed.

Specifying Layer Property Overrides for Viewport on Layout Sheets

In Viewports on layout Sheets, you can additionally use certain Layer settings.

These settings can also be specified for the layout Sheet itself. The Sheet itself is also considered as a Viewport in layout mode.

The changes in a specific Viewport override the settings for Layers in the Model.

On a layout Sheet, the following extra columns appear in the Layers Manager for the active Viewport:

  • Active Viewport: Freezes selected Layers only in the active layout Viewport. The symbol means frozen. The symbol  means thawed.
  • VP Color: In the active Viewport, the specified LineColor is used for the entities on the selected Layers.
  • VP LineStyle: In the active Viewport, the specified LineStyle is used for the entities on the selected Layers.
  • VP LineWeight: In the active Viewport, the specified LineWeight is used for the entities on the selected Layers.
  • VP Transparency: In the active Viewport, the specified level of Transparency is used for the entities on the selected Layers.
  • VP PrintStyle: In the active Viewport, the specified PrintStyle is used for the entities on the selected Layers.

Note: If settings in a Viewport differ from the default setting for a Layer in the Model, the corresponding cells are highlighted in the Layers list.

Setting Filtering Options

You can create filters that contain Layers you specify. Grouping Layers this way establishes group filters. Two Layer group filters are predefined: All and All Used Layers. For new Layer groups, drag Layers from the Layer list to the group name to add them.

To create Layer group filters and assign Layers to them:

  1. In the Layers Manager dialog box, click Edit Filters.
  2. In the tree view of the Edit Layer Filters dialog box, click the node in which you want to create a new filter.
  3. Click Add Group Filter.

    A new filter is added to the tree view. The filter is a level below the item selected in the tree view so you can create a hierarchical Layer filter structure.

  4. Double-click the new filter and type a name for it.
  5. Click Close.

    The new group filter is added to the filter tree view.

  6. Select one or more Layers from the Layer list and drag them into the filter tree view onto the filter name you created.

To delete filters:

  1. In the Layers Manager dialog box, click Edit Filters.
  2. Select the filter to delete and click Delete.
  3. Click Close.

To display the Layers matching the criteria of a filter:

  • In the filter tree view, select a Layer filter name.

    The Layers list of the Layers Manager is reduced to the Layers which meet the criteria of the selected filter.

Setting Layer Filter Display Options

You can set additional display options:

  • Reverse Filter: Displays all Layers that match the inverted criteria of the selected filter name.
  • Display "in use" status: Marks all unused Layers in the Status column with a white Layer icon. The icon changes from to . In large drawings with many Layers, clear this option to improve performance in the Layers Manager.
  • Apply current filter to Layers toolbar: Reflects the active filter of the Layers Manager in the Layers list of the Layers toolbar.

Access

Command: Layer

Menu: Format > Layer

Ribbon: Home > Layers > Layers Manager



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Managing Layers
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2022 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.