Hide Table of Contents

Setting PDF Publishing Options

You can publish multiple drawing sheets to the following formats:

  • A single DWF or PDF file
  • Multiple single-page PDF or DWF files

To publish the model workspace and specified sheets of a drawing or multiple drawing files to PDF use the BatchPrint command.

To publish a drawing sheet set to PDF use the Publish to PDF option from the Sheet Set Manager.

To publish a drawing sheet set to DWF use the Publish to DWF option from the Sheet Set Manager.

Before publishing your drawing sheets to PDF or DWF files, you can specify various options in the PDF/DWF Options dialog box:

Note: In the PDF/DWF Options dialog box, you can specify the publishing options for PDF files. The software uses these settings also when you publish the drawing sheets to DWF.

  • Publishing to a single, multi-sheet PDF or DWF file or multiple, single-sheet PDF or DWF files
  • File name and location. Additionally, you can choose whether to be prompted for a file name each time you publish a file
  • Resolution of the PDF or DWF file
  • Include or not layer information, hyperlinks, and bookmarks
  • Capture TrueType fonts of the drawing and include it in the PDF or DWF file

To display the PDF/DWF Options dialog box:

  1. Click File > Batch Print (or type BatchPrint).
  2. In the Batch Print dialog box, click PDF Options.
  • Do one of the following:
    • In the Batch Print dialog box, click PDF Options.

      Note: PDF Options are available only when the Sheets use PageLayouts with the built-in PDF printer specified as output device.

    • On the Sheet Set Manager, click Publish and select PDF Publish Options.

To specify the file name when publishing the PDF file:

  • In the PDF/DWF Options dialog box, in General, do the following:
    • Select Publish as Multi-sheet PDF to generate a single PDF file.
    • Select Specify PDF file name on file dialog.

To publish a list of drawings to PDF:

  1. Click File > Batch Print (or type BatchPrint).
  2. In the Batch Print dialog box, use functions and options to specify the list of drawings or drawing sheets.
  3. Click PDF Options.
  4. In the PDF/DWF Options dialog box, do the following:
    • In Path, specify the folder in which to save the PDF file. Click Browse to change the path.
    • In Publish as Multi-sheet PDF, specify whether you want to generate a single PDF file or one PDF file for each sheet.
  5. Specify additional PDF publish options.
  6. Click OK.

To publish a drawing sheet set to PDF:

  1. On the Sheet Set Manager, select a drawing sheet set from the drop-down list.
  2. Right-click the drawing sheet set or a subset and select Publish > PDF Options from the context menu.
  3. In the PDF/DWF Options dialog box, do the following:
    • In Path, specify the folder in which to save the PDF file.
    • In Publish as Multi-sheet PDF, specify whether you want to generate a single PDF file or one PDF file for each sheet.
  4. Specify additional PDF publish options.
  5. Click OK.

PDF/DWF Options Dialog Box

Note: In the PDF/DWF Options dialog box, you can specify the publishing options for PDF files. The software uses these settings also when you publish the drawing sheets to DWF.

Path

Specifies the path to the folder to store the PDF files. Click Browse to change the path.

Publish as Multi-sheet PDF

Prints all selected Sheets into a single multi-sheet PDF file. If not selected, the software generates one PFD file for each sheet.

Note: This option is available only when the Sheets use PageLayouts with the built-in PDF printer specified as output device.

Specify PDF file name on file dialog

If selected, you are prompted to specify location and name of the PDF file in a dialog box when you start the batch print job. If cleared, specify path and name of the PDF file. These will appear in the Batch Print dialog box.

Note: This option is available only if you selected Publish as Multi-sheet PDF.

PDF file name

Specifies the PDF file name.

If you selected Specify PDF file name on file dialog, the PDF file name text box is not available. When you start the batch print job, you are prompted to specify location and name of the PDF file in a dialog box.

Quality Management

Groups the options for specifying the resolution of the PDF file.

Vector quality

Lets you specify the resolution of vector graphics within the PDF file. For printing from a viewer, use resolutions matching the printer output. For on-screen viewing, you can use resolutions above 2400 dpi.

Raster image quality

Lets you specify the resolution of raster images. For printing from a viewer, use resolutions matching the printer output. For on-screen viewing, you can use resolutions above 2400 dpi.

Merge control

Lets you specify whether overlapping lines overwrite or merge.

Data Management

Controls the data to include in the PDF file.

Use layers in PDF (PDF v1.5 or higher)

Lets you turn on and off layers when printing or viewing the PDF file.

Add hyperlinks

Lets you convert sheet links into hyperlinks in multi-sheet PDF files.

Font Management

Groups the options for managing TrueType fonts from the drawings.

Embed True Type fonts used in the drawing

Captures TrueType fonts used in the drawing's annotations and includes them in the PDF file. When viewing the PDF file, the fonts are read directly from the PDF file and the PDF viewer should not substitute them. This option increases the PDF file size.

Exceptions:

  • Fonts that are not TrueType fonts
  • Vertical Asian fonts
Optimized

Specifies whether to use True Type font-related optimization when creating the PDF file. This may influence the output performance, but reduces the file size.

Convert all True Type texts to geometry

Lets you convert all text to geometry during the export to PDF file when you cannot include your TrueType fonts in the PDF file. The text in the PDF file is identical to the text on the drawing.

The shape fonts are always printed as geometry regardless of the selection made.

Note: The Search tool from the PDF viewer can locate a specified text in the file.

SHX text as geometry

Lets you convert SHX fonts to geometry. Thus, annotations that use SHX fonts are represented using geometric entities, such as lines and arcs. Otherwise, the SHX-based annotations appear as text lines in the PDF file using a corresponding or similar TrueType font, which lets you select annotations in the PDF file as text objects.

Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Setting PDF Publishing Options
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2023 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.