Hide Table of Contents

Command Reference: DraftSight Premium

Premium Commands

Command Description Menu
3D Modeling Click here for 3D Modeling Commands
Constraints Click here for Constraint Commands
Custom Blocks Click here for Custom Block Commands
EditBlock Opens the Block Editor (dialog box variant) Modify > Entity
-EditBlock Opens the Block Editor (command window variant)
ExportSheet Hides the Sheet Set Manager palette
HideSheetSet Hides the Sheet Set Manager palette
ImportSTL Imports stereolithography files (STL) and inserts the contained ACIS solid objects into the drawing
ImportSTLasMesh Imports stereolithography files (STL) and inserts the contained geometry as subdivision mesh objects (SubDMeshes) into the drawing
MeasureGeometry Measures distances, radius, angles, and areas within a single command Tools > Inquiry
NewSheetSet Displays the Create Drawing Sheet Set wizard
OpenSheetSet Opens the specified drawing sheet set in the Sheet Set Manager File > Sheet
SheetSet Displays the Sheet Set Manager palette Tools

Custom Block Commands

Use the EditBlock command to open the CustomBlock Editor.

The following commands are available in the CustomBlock editor:

Command Description Menu
CBActivity Creates and applies an activity to a CustomBlock element.
CBActivityIcon Controls the visibility of the activity icons.
CBActivityTool Creates and applies activity to existing CustomBlock element.
CBClose Closes the Block Editor.
CBConvert Converts a dynamic block into CustomBlocks.
-CBConvert Converts a dynamic block into CustomBlocks.
CBCycleOrder Opens the BasePoint Cycling dialog box.
CBElement Creates a CustomBlock element.
CBElementSet Creates an element and the associated activity at once.
CBHide Sets hidden entities for the visibility state.
CBOptions Displays the Block Editor options.
CBSave Saves the CustomBlock definition under the current name.
CBSaveAs Saves the CustomBlock definition with a specified name.
CBShow Sets visible entities for the visibility state.
CBValueTable Displays the Property Value Table dialog box.
CBTestBlock Displays the current Block definition in a test window.
CBTestClose Closes the test window.
CBVisibility Displays the Visibility States dialog box (dialog box variant).
-CBVisibility Creates, sets, or deletes visibility states of a CustomBlock definition (command window variant).
CBWBlockAs Saves a CustomBlock as a separate drawing file.

 

    ^ Top of Page

Constraint Commands

Command Description Menu
ConstraintIcon Shows, hides, or resets Geometric Constraint icons Constraints
ConstraintOptions Sets options for Geometric and Dimensional Constraints Constraints
ConstraintType Sets the Dynamic or Annotation type for subsequent Dimensional Constraints
ConvertConstraint Converts associative dimensions to Dimensional Constraints Constraints > Dimensional Constraints
DcAligned Constrains the direct distance between two defining points on entities Constraints > Dimensional Constraints
DcAngular Constrains the angle between three constraint points on entities or between two Lines or PolyLine segments, or constrains the total angle of an Arc or curved PolyLine segment Constraints > Dimensional Constraints
DcDerived determine if the constraint or the geometry controls the other
DcDiameter Constrains the diameter of a Circle, Arc, or curved PolyLine segment Constraints > Dimensional Constraints
DcDisplay Shows or hides Dimensional Constraint entities Constraints
DcHorizontal Constrains the horizontal distance between two defining points on entities Constraints > Dimensional Constraints
DcLinear Constrains the horizontal or vertical distance between two defining points on entities
DcRadial Constrains the radius of a Circle, Arc, or curved PolyLine segment Constraints > Dimensional Constraints
DcSmart Quickly creates Dimensional Constraints by specifying entities
DcVertical Constrains the vertical distance between two defining points on entities Constraints > Dimensional Constraints
DeleteConstraint Removes all constraints from specified entities Constraints
DimensionalConstraint Defines Dimensional Constraints to entities or between constraint points on entities
GcCoincident Defines a coincident geometric constraint to two points on entities or constrains a point on an entity to an entity Constraints > Geometric Constraints
GcCollinear Causes collinear Lines Constraints > Geometric Constraints
GcConcentric Causes coincident center points of Arcs, Circles, Ellipses, or Elliptical Arcs Constraints > Geometric Constraints
GcEqual Constrains Lines to the same length, or Arcs and Circles to the same radius Constraints > Geometric Constraints
GcFix Causes points on entities and entities to maintain fixed positions Constraints > Geometric Constraints
GcHorizontal Causes Lines and linear PolyLine segments or pairs of points on entities to be parallel to the X-axis of the current coordinate system Constraints > Geometric Constraints
GcParallel Causes two Lines or linear PolyLine segments to be parallel to each other Constraints > Geometric Constraints
GcPerpendicular Causes two Lines or linear PolyLine segments to be perpendicular to each other Constraints > Geometric Constraints
GcSymmetric Causes two entities or points on entities to lie symmetrically with respect to a symmetry line Constraints > Geometric Constraints
GcSmooth Causes a Spline to constitute fluid geometric continuity with another Spline, Arc, Line, or PolyLine Constraints > Geometric Constraints
GcTangent Causes one entity to be tangent to another Constraints > Geometric Constraints
GcVertical Causes Lines and linear PolyLine segments or pairs of points on entities to be parallel to the Y-axis of the current coordinate system Constraints > Geometric Constraints
GeometricConstraint Defines Geometric Constraints for one or two entities
HideParameters Hides the Parameters palette
Parameters Shows the Parameters palette to create and edit Constraint expressions and values (dialog box variant) Constraints
-Parameters Creates and edits Constraint expressions and values (command window variant)
SetConstraintNameFormat Specifies how to display the information in the dimensional constraints

 

    ^ Top of Page

3D Modeling Commands

Command Description Menu
Box Creates a three-dimensional solid box Solids > Draw
ChamferEdges Bevels the edges of 3D solid objects Solids > Solid Editing
Cone Creates a three-dimensional solid cone Solids > Draw
ConvertEdges Creates wireframe geometry from the edges of a specified 3D Solid, Surface, Mesh, or Region Solids > Solid Editing
Cylinder Creates a three-dimensional solid cylinder Solids > Draw
EditSolid Edits bodies, faces and edges of three-dimensional solid objects Solids > Solid Editing
Extrude Creates a 3D solid or surface Solids > Draw
FilletEdges Rounds the edges of 3D solid objects Solids > Solid Editing
GetMassproperties Calculates and displays the mass properties of 3D solids and regions Tools > Inquiry
Interfere Checks interferences within a solid model Solids > Solid Editing
Intersect Creates regions or 3D solids from the intersection regions or of 3D solids Solids > Solid Editing
Loft Creates a three-dimensional solid by lofting between existing cross sections Solids > Draw
MakeFlatSnapshot Creates a flat representation of 3D solid objects, projected to the X-Y plane of the drawing (dialog box variant) Solids > Solid Editing
-MakeFlatSnapshot Creates a flat representation of 3D solid objects, projected to the X-Y plane of the drawing (command window variant)
OffsetEdges Creates 2D entities from the boundary of a 3D solid or surface Solids > Solid Editing
PlaneSurf Creates rectangular planar surfaces Solids > Draw
PolySolid Draws 3D solid objects in the shape of a polygonal walls Solids > Draw
PushPull Modifies 3D solid objects or bounded areas by extrusion Solids > Draw
Pyramid Creates a 3D solid pyramid Solids > Draw
Revolve Creates a 3D solid or surface by revolving a 2D object about an axis Solids > Draw
Slice Slices 3D solids with a plane or surface Solids > Solid Editing
Sphere Creates a three-dimensional solid sphere Solids > Draw
Subtract Creates a composite region or a 3D solid by subtraction Solids > Solid Editing
Sweep Creates unique solid primitives or surfaces by sweeping existing two-dimensional entities along a path Solids > Draw
Thicken Create a 3D solid from a surface by thickening it Solids > Solid Editing
Torus Creates a three-dimensional toroid solid Solids > Draw
Union Creates a composite region or solid by addition Solids > Solid Editing
Wedge Creates a three-dimensional solid with a sloped face tapering along the X axis Solids > Draw

 

    ^ Top of Page



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Command Reference: DraftSight Premium
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2023 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.