Hide Table of Contents

Managing Custom Coordinate Systems

Use the CSStyle command to manage coordinate systems. You can:

  • Manage coordinate systems by viewing, activating, renaming, or deleting them
  • Select an orthographic coordinate system
  • Adjust coordinate system settings

To create named Custom Coordinate Systems, use the CCS command.

To view saved coordinate systems:

  1. Click Tools > CCS Manager (or type CSStyle).

    In the Options dialog box, the Drawing Settings page opens and Coordinate System expands.

  2. Expand Named.
  3. Hover the pointer over a coordinate system to view the origin and X, Y, and Z coordinates.

To activate a coordinate system:

  1. Click Tools > CCS Manager (or type CSStyle).

    In the Options dialog box, the Drawing Settings page opens and Coordinate System expands.

  2. Expand Named.
  3. Select a coordinate system and click Activate.

    A displays beside the active coordinate system.

To delete or rename a coordinate system:

  1. Click Tools > CCS Manager (or type CSStyle).

    In the Options dialog box, the Drawing Settings page opens and Coordinate System expands.

  2. Expand Named.
  3. Select a coordinate system and click Delete or Rename.

    You can use Rename to name an unnamed coordinate system. You cannot delete or rename the World Coordinate System (WCS).

To set a temporary orthographic coordinate system on a face of a cube:

  1. Click Tools > CCS Manager (or type CSStyle).

    In the Options dialog box, the Drawing Settings page opens and Coordinate System expands.

  2. Expand Defaults.
  3. Select a face (Top, Bottom, Front, Back, Left, or Right) and click Activate.
  4. In Relative to, select the coordinate system to which the temporary coordinate system should be relative.

To set up coordinate systems:

  1. Click Tools > CCS Manager (or type CSStyle).

    In the Options dialog box, the Drawing Settings page opens and Coordinate System expands.

  2. Expand Options.
  3. Set options:
    • Update view when coordinate system changes: Automatically displays the plan view to the coordinate system in the active ViewTile when the coordinate system changes.
    • Save coordinate system with view tiles: Forces all ViewTiles to reflect its active coordinate system. Otherwise, the coordinate systems of other ViewTiles remain unchanged.

To set up the coordinate system icon:

  1. Click Tools > Options (or type Options).

    Click Application menu > Preferences (or type Options).

  2. In the Options dialog box, click Drawing Settings .
  3. Expand Display > Coordinate System Icon.
  4. Set options:
    • Display icons: Displays the coordinate system icon.
    • Display icons at origin: Displays the coordinate system icon at the origin (0,0,0) of the active coordinate system. If the origin is off the display, the coordinate system icon displays in the lower left of the view.
    • Apply changes to all actively displayed views: Determines whether the coordinate system icon settings apply to all active views or only the active one.

Access

Command: CSStyle

Menu: Tools > CCS Manager



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Managing Custom Coordinate Systems
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2023 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.