Hide Table of Contents

About Composer File Types

Composer has several native file types.

This page discusses:

Composer File Types

The table below describes the various file types used to handle and share Composer documents.

Composer File Type Description
SMG (.smg) The default file type. A single file that includes all property, geometry, view, and animation information.
Tip: .smg files are archive files containing .smgXml, .smgGeom, .smgOutlines, and other files required to render the scene. You can view and extract the file content with WinRAR ®. Rename the .smg file with a .rar extension.
Package (.exe)

An auto-executable file containing the following:

  • .smg file
  • Composer Player executable
Use packages to distribute models to users who might not have Composer or Composer Player installed. Opening the package file (.exe) runs Composer Player and loads the Composer data.
Note: The Composer Player documentation is not bundled in the package. It is accessed online.
Tip: You can view and extract the content of package files with WinRAR. Rename the .exe file to have a .rar extension.
Product (.smgXml) A multi-file format consisting of all the .smg components:
  • .smgXml - An XML file containing the assembly structure. It denotes the position of the actors, the properties of the viewport, and so on.

    Open the .smgXml file to load the entire model.

  • .smgGeom - A binary file containing the assembly geometry.
  • .smgView - An XML file containing view definitions.
  • .smgSce - An XML file containing scenario (animation) definitions.
  • View thumbnails - JPG images that appear in the Views pane.
The .smgGeom, .smgView, and .smgSce files must have the same name as the .smgXml file.
Tip: For greater flexibility, use Composer projects instead of Composer products alone.
Project (.smgProj) A multi-file format consisting of one or more Composer product files and a project (.smgProj) file. The .smgProj file is an XML file that references the top-level .smgXml, .smgView, and .smgSce files that comprise the project.
  • The .smgXml, .smgView, and .smgSce files can be any name and reside in any folder.
  • The .smgXml and .smgGeom files must be the same name and reside in the same folder.
Projects organize your Composer files into folders and let you share references. For example, two projects can share the same .smgXml, .smgGeom, and .smgView files but have different .smgSce files. Projects also let you import multiple subassemblies even when you do not have the main assembly file.
Fully Shattered A Composer product with multiple .smgXml and .smgGeom files.
Note: All other Composer formats contain geometry and structure information in one (.smg, .exe) or two (.smgXml, .smgGeom) files and are called monolithic file types. In the fully-shattered format:
  • The main assembly and each subassembly has a .smgXml file that includes the neutral properties, assembly hierarchy, and position of its parts. It also includes references to all the parts.
  • Each part has a .smgXml and .smgGeom file.
Fully-shattered assemblies have several advantages:
  • The assembly loads all its parts by reference. An assembly does not have geometry files. This keeps the file size of the main assembly small and lets you reuse parts in multiple assemblies.
  • You can load assembly parts as you need them instead of loading the entire assembly when you open it. For details, see the Project > Geometry options in the Open dialog box and the Load on Visibility command. To load a part, right-click the part in the Assembly tree and click Product > Load Products.
  • You can load parts with different levels of details. If you create your fully shattered assembly with more than one level of detail, you can choose the level of detail on the Open dialog box.
  • You can perform incremental updates. Because parts are loaded by reference, you can update only parts that have changed.
When using fully shattered assemblies, you must be aware of the following points:
  • You cannot create fully-shattered files from Composer. Use Sync.
  • Create projects with File > New Project , not Save As . Because Composer measurement actors, animation keys, and other authoring content is stored in the top-level project assembly, that content is lost if you create the project using Save As and then retranslate the top-level CAD assembly in Sync.
  • Fully shattered assemblies reference the last saved configuration of its parts. If your assembly uses multiple configurations of a part, then it displays the last saved configuration for all instances of the part. Therefore, you will get improper results when converting (from Sync) in fully shattered mode an assembly that contains multiple instances of the same part with different configurations.
  • You cannot change the neutral properties of a part in a fully shattered assembly because the part is loaded by reference into the assembly. To change the neutral properties of a part, open the part in its own window.
  • When you modify a subassembly such as adding/removing an assembly group or merging/exploding actors, you break the fully shattered structure. All the associated structure branches will be saved in the top assembly file.
  • Undoing an operation that breaks a fully shattered structure does not restore the fully shattered structure.

Benefits of Each File Type

The table below describes the benefits provided by each Composer file type.

Benefit SMG (.smg) Package (.exe) Product (.smgXml) Project (.smgProj)
Minimal number of files X X
Includes Composer Player X
Can edit XML X X
Separate product, scenario, and view files X X
Product, scenario, and view files can reside in different folders X


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   About Composer File Types
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS Composer 2024 SP01

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.