Hide Table of Contents

Advanced Properties

The Advanced Properties page lets you customize all the document settings available in the registry.

You can define some of these settings in the Application Preferences or (Default) Document Properties pages.

This page discusses:

Display Commands

The icons available at the top of the page let you configure how the properties list is displayed.

IconCommand NameDescription
CategorizedLists settings by category.
AlphabeticLists settings alphabetically.
Show Advanced Preferences OnlyDisplays advanced settings only. To list settings available from other (Default) Document Properties pages, clear this option.

Properties

Advanced properties let you customize all the document settings available in the registry.

Category Property Description
General CGMMetafileName Specifies the name of the Computer Graphics Metafile (CGM) metafile. For details, see CGM options in the Technical Illustration - Options page.
CalloutAutoSize Specifies a size for callouts automatically.
Primitive Offset (%)

Specifies the distance that disc and square primitives are shifted forward relative to other geometry actors to avoid color conflicts (Z-fighting). Specify the offset as a percentage of the disc radius and square half-diagonal length.





0% 3%

ShowCalloutExponentX1 Displays quantities of 1 as callout quantity exponents. For details, see the Quantity exponent callout property.
SelectionHighlightColorIntensityFactorSpecifies the amount of highlight shading. Accepted values range between 0.00 and 2.00. For details, see Selection: Color intensity highlight property.
HighlightHiddenEdgesDisplays hidden edges when an actor is highlighted. For details, see Selection: Show hidden edges highlight property.
SelectionColorIntensityFactorSpecifies the amount of selection shading. Accepted values range between 0.00 and 2.00. For details, see Selection: Color intensity selection property.
SelectionHiddenEdgesDisplays hidden edges when an actor is selected. For details, see Selection: Show hidden edges selection property.
Input - Import IO3dxmlImportOnlyLeafGeometries Imports only leaf geometry from 3DXML files. To also import geometry on intermediate groups, clear this option. Typically, intermediate geometry are navigational representations (NavReps), but they can also be real geometry.
IOIdentifierType Specifies how Composer generates GUIDs for geometry actors:
  • 0 - Generates random, unique 32-byte IDs (for example: "805fb301f8f12ca6").

    Important: Not recommended. GUIDs are regenerated during each import, so geometry updates are not possible.

  • 1 - Uses geometry names. IDs remain the same during subsequent imports as long as the names in the CAD system do not change. Unless required for backward compatibility, use 2 for better performance.
  • 2 - Uses geometry names, encrypting names longer than 16 characters. GUIDs are always 16 characters or fewer, resulting in smaller Composer files and improved performance.
IOImportCurvesStayOnTop Specifies that curves, wires,wireframe and construction geometries (construction lines, construction circles and construction threads) are imported as staying on top.
IOImportGeometriesAsTriangleStripSet Rearranges tessellation triangles during import to reduce tessellation size in memory and improve render performance. This optimization applies to SOLIDWORKS and 3DXML formats only. For 3DXML only, clear this option to disable the optimization, which can improve load times. Clearing this option has no effect on SOLIDWORKS files; the optimization is always performed.
IOImportPointsStayOnTop Specifies that points and construction points are imported as staying on top of the geometry.
Note: This option is not available as a default document property.
IOSWImportAppearance Imports all appearances in SOLIDWORKS files. You can also set this option in the File > Open dialog box. On the SOLIDWORKS tab, in the Options section, select Import SOLIDWORKS appearance. This option is selected by default.
IOSWImportBOM Imports part and assembly BOMs in SOLIDWORKS files. After import, you can access and edit all the BOM properties in Composer. You can also set this option in the File > Open dialog box. On the SOLIDWORKS tab, in the Options section, select Import SOLIDWORKS BOM. This option is selected by default.
IOSWImportCloneSamePartInstances When importing SOLIDWORKS files, all instances of a given part will be viewed and converted as clones.

Clear this option if you want independent geometries created for each instance of a given part. Note that this increases the file size.

IOSWImportConfigurationsSaves configurations with the Composer file.
IOSWImportDecalsImports decals from the SOLIDWORKS file to the Composer file.
IOSWImportEnvelope Imports all the SOLIDWORKS assembly envelopes.
IOSWImportExplodeViews Imports all exploded, saved, and named views in SOLIDWORKS files. This option is available for all three Open options: Open, Merge into the current document, and Merge into a new document. You can also set this option in the File > Open dialog box. On the SOLIDWORKS tab, in the Options section, select Import SOLIDWORKS Exploded Views and Saved Views. This option is selected by default. In the Views pane, the Views tab displays the saved and named views and the steps of the exploded views.

IOSWImportGraphicData Imports default model tessellations (graphic representations) from SOLIDWORKS files instead of performing complete translations, thereby improving load times. Because tessellations are not recomputed, Refinement settings are ignored.
Important: This option might not work for all SOLIDWORKS files. Enable this option only when importing very large assemblies to improve load times, or when tessellation fails for SOLIDWORKS parts originating from non-SOLIDWORKS formats (such as IGES or STEP).
Output IORemoveEmptyGroupsAfterOcclusion When empty groups exist in the assembly tree as a result of the occlusion process at import, removes these empty groups from the assembly tree.
Note: This option is useful only if you selected Remove Occluded Actors in the Occlusion section of the Repair/Refinement page of the conversion properties. See Occlusion.
Batch.IODeleteEmptyGroupsWhen empty groups exists in the assembly tree because they contain hidden elements, such as construction geometry or sensitive IP information, removes these empty groups from the assembly tree at import.
BOM table BOM.Filter Specifies the default state for Show Visible Actors Only on the BOM pane, 0=disabled and 1=enabled.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Advanced Properties
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS Composer 2024 SP02

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.