Hole Wizard/Toolbox Options

Use the options on the Hole Wizard/Toolbox page to create or edit standards that are used by Hole Wizard holes and SOLIDWORKS Toolbox components. You can disable or enable the Toolbox Favorites folder.

To access the Hole Wizard/Toolbox options:

  1. Click Options on the Standard toolbar, or click Tools > Options.
  2. On the System Options tab, click Hole Wizard/Toolbox.
Click Reset to restore defaults for all system options or only for options on this page.

Hole Wizard and Toolbox folder

Hole Wizard and Toolbox folder location Shows where Hole Wizard and Toolbox components are stored.
Make this folder the default search location for Toolbox components. Facilitates opening models whose Toolbox components do not reference your Toolbox folder. If you clear the system option, SOLIDWORKS does not automatically search the Toolbox folder for references to Toolbox components.

If you are a SOLIDWORKS Connected user but do not have a SOLIDWORKS Toolbox license, you can still open assemblies that contain SOLIDWORKS Toolbox parts. Clear Make this folder the default search location for Toolbox components. When cleared, you can open an assembly from your computer with the Toolbox parts that are shared outside of the Toolbox library. If the SOLIDWORKS Toolbox license is available, this option is always selected and you cannot change it.

Configure Opens the Toolbox configuration tool, where you can specify options on the Smart Fasteners page.

Toolbox Task Pane

Display Toolbox Favorites folder Displays the Toolbox Favorites folder under Toolbox in the Design Library Task Pane.

Toolbox Mates

Lock rotation of new concentric mates to Toolbox components Automatically locks rotation for new concentric mates to Toolbox components. You can lock this option in the Settings Administrator Tool.
This option applies when you create concentric mates in the following ways:
  • Insert a Toolbox component onto another component.
  • Create a SmartMate by using ALT + drag on a cylindrical face or a circular edge of a Toolbox component that is in the assembly.
  • Use the Smart Fasteners tool.
  • Define Smart Fasteners in a new Hole Series.
  • Manually create a concentric mate to a Toolbox component.

Hole Wizard settings

Preserve settings for each Hole Wizard hole type Uses legacy behavior to save settings for each hole type. For example, if the size for tapped holes is M6, that size is not affected by the sizes of other hole types. This behavior is used by SOLIDWORKS version 2015 and earlier releases.
Transfer settings when changing Hole Wizard Hole type Attempts to match the sizes of the last hole type used and the sizes available for the new hole type. Matching is done based on string comparison. This behavior is set by default for all new (version 2018 and later) and upgrade installations to preserve the existing SOLIDWORKS version 2017 behavior.

Examples of size matching:

  • Example 1: If you create a counterbore hole and set the size at M6, and then create a countersink hole, the M6 setting carries over to the new hole type.
  • Example 2: If you create a counterbore hole and set the size at M6, and then change it to a tapped hole, the M6 setting carries over to the new hole type setting it to M6x1.0. If multiple M6 tapped holes are listed (for example, M6x0.75 and M6x1.0), the first one listed (M6x0.75) is matched.
Include data for DELMIA applications Generates and saves information for the following machining features:
  • Hole Wizard
  • Simple Hole
  • Advanced Hole
  • Thread
  • Cosmetic Thread

Only DELMIA machining applications can use this data through the 3DEXPERIENCE platform.

Creating Hole Wizard Standards

You can create new standards or edit existing standards used by Hole Wizard holes and SOLIDWORKS Toolbox components. You can add administrative access to these standards and the options of the SOLIDWORKS Toolbox add-in.

You do not need to have SOLIDWORKS Toolbox installed on your system to create or edit standards for Hole Wizard holes.

To create your own Hole Wizard standards:

  1. Click Options on the Standard toolbar, or click Tools > Options.
  2. On the System Options tab, click Hole Wizard/Toolbox.
  3. Browse to the Hole Wizard and Toolbox folder location.
    You can select Make this folder the default search location for Toolbox components to facilitate opening models whose Toolbox components do not reference your Toolbox folder. If you clear the system option, SOLIDWORKS does not automatically search the Toolbox folder for references to Toolbox components.
  4. Click Configure.
  5. In the Toolbox configuration tool, set options on the Smart Fasteners page.
    For details, see Configuring Toolbox.
  6. Click Save, then close Toolbox.
  7. Click OK to close the System Options - Hole Wizard/Toolbox dialog box.

Toolbox Favorites

The Toolbox Favorites folder is a local folder where you can store shortcuts to frequently used Toolbox components.

In the SOLIDWORKS software, the Favorites folder appears under Toolbox in the Design Library Task Pane. The content you add to the folder is stored as Windows shortcut files on your local computer.

The Toolbox Favorites folder is visible by default. To hide the folder, click Tools > Options > System Options > Hole Wizard/Toolbox and clear Display Toolbox Favorites. This does not remove your favorites - it just hides them on the Design Library Task Pane.

You can add content directly to the Favorites folder or create subfolders to organize the content. You then drag components from a Toolbox standard folder in the lower part of the Task Pane to the Favorites folder or subfolder.

You should not share favorites with other users.

To save and use Toolbox favorites:

  1. In the Task Pane, on the Design Library tab, expand Toolbox.
  2. Select the Favorites folder and click Create New Folder .
  3. Type a name for the subfolder.
    If you use standard Toolbox folder names such as Bearings or Bolts and Screws, the software displays the names with the appropriate icons. Otherwise a generic folder icon represents the folder.
    The new folder appears under the Favorites folder and is created on your local computer in C:\Users\username\AppData\Roaming\SOLIDWORKS\SOLIDWORKSrelease\Toolbox\Favorites.
  4. Using the Toolbox library of components, expand the standard, category, and type of component to save as a favorite.
  5. Select the component and drag it to the subfolder.
    Each favorite you save appears as a shortcut in the Favorites subfolder and in the Favorites directory on your local computer.

    If a Toolbox component is moved, deleted, or disabled, a warning flag appears on the shortcut.

    Hover over the favorite to display a tooltip that describes the problem.

  6. To use a favorite, select it in the Favorites subfolder and drag it to the graphics area, just as you would a component in one of the other Toolbox folders.

Toolbox Options

You can set up Toolbox for a single user or set up a shared Toolbox for multiple users.

For information about configuring Toolbox, see Toolbox Help.

Shared Toolbox Data

You can install Toolbox data on a local computer, in a shared network location, or in a SOLIDWORKS PDM vault. Using a shared network location or SOLIDWORKS PDM vault is recommended. By using a common location, all SOLIDWORKS users share a consistent set of component information.

For information about using SOLIDWORKS PDM to manage Toolbox, including migrating your existing Toolbox library to a SOLIDWORKS PDM vault, see the SOLIDWORKS PDM Administration Guide.

Toolbox Configuration

The best practice is to configure Toolbox before using it. Setting up Toolbox consists of:
  • Selecting the standards and hardware you use.
  • Selecting component sizes, adding custom properties, and adding part numbers.
  • Setting permissions and preferences.

Protecting Toolbox

When using a shared Toolbox, an administrator can create a password for Toolbox and set permissions and preferences for the workgroup. Restricting access and setting common preferences ensures consistent Toolbox data for a workgroup.