Inhaltsverzeichnis ausblenden

Import-Diagnose - Übersicht

Bei der Import-Diagnose werden fehlerhafte Oberflächen repariert, reparierte Oberflächen zu geschlossenen Körpern zusammengefügt und geschlossene Körper in Volumenkörper umgewandelt.

Import-Diagnose starten:

  • Wenn Sie ein Modell mit Fehlern importieren, werden Sie in einer Meldung gefragt, ob die Import-Diagnose ausgeführt werden soll. Klicken Sie auf Ja.
  • Klicken Sie in einem geöffneten Modell auf Import-Diagnose (Extras-Symbolleiste) oder auf Extras > Evaluieren > Import-Diagnose.

    Der PropertyManager Import-Diagnose wird eingeblendet.

Diese Reparatur ist notwendig, da es bei importierten Oberflächendaten häufig zu Problemen kommt, die eine Umwandlung der Oberflächen in gültige Volumenkörper verhindern. Zu diesen Problemen zählen:
  • Fehlerhafte Oberflächengeometrie
  • Fehlerhafte Oberflächentopologie (Trimmkurven)
  • Angrenzende Oberflächen, deren Kanten eng beieinander liegen, sich jedoch nicht berühren, so dass Lücken zwischen den Oberflächen entstehen.
Während der Import-Diagnose werden die Probleme anhand folgender Verfahren identifiziert:
  • Ausführen der Prüfung unter Extras > Evaluieren > Prüfen.
  • Ausführen zusätzlicher Prüfungen, zum Beispiel auf überlappende Oberflächen.
  • Suchen nach genauen, nicht vereinfachten Oberflächen, die planare, zylindrische B-Splines usw. sind und daher durch äquivalente analytische Oberflächen ersetzt werden können, wodurch die Leistung verbessert wird und das Modell leichter referenziert werden kann.
    Genau ist durch eine Toleranz von < 10-8 definiert. Die Suche nach ungenaueren Flächen (zwischen 10-5 und 10-8) verläuft extrem langsam. Sie können jedoch manuell Flächen auswählen und auf Korrigieren klicken, um die Flächen, falls möglich, in analytische Oberflächen umzuwandeln. Das System ersetzt außerdem die beiden ausgewählten Zylinderhälften durch den äquivalenten vollständigen Zylinder.

    Obwohl B-Splines nicht unbedingt ein Problem darstellen (da B-Spline-Oberflächen gültig sind), wird das Modell durch Ersetzen der B-Splines durch äquivalente analytische Oberflächen für die Arbeit in SOLIDWORKS geeigneter. So können Sie zum Beispiel konzentrische Verknüpfungen ausschließlich zu analytischen Zylindern erstellen, jedoch nicht zu zylindrischen B-Splines.

Während der Import-Diagnose werden Fehler in der Geometrie (der zugrundeliegenden Oberfläche) und der Topologie (der Begrenzungen) anhand mindestens einem der folgenden Vorgänge repariert:
  • Neuaufbau der Trimmbegrenzungen einer Fläche basierend auf der umgebenden Geometrie (dadurch werden oft überlappende Flächen korrigiert).
  • Trimmen fehlerhafter Teile von Flächen (wenn der fehlerhafte Teil nicht im Modell verwendet wird).
  • Entfernen der Fläche und Verwenden des Algorithmus zum Reparieren von Lücken, um die resultierende Bohrung zu füllen (letzter Ausweg).
Während der Import-Diagnose werden Lücken zwischen angrenzenden Flächen anhand mindestens einem der folgenden Vorgänge geschlossen:
  • Ersetzen zweier eng aneinander liegenden Kanten, die sich jedoch nicht schneiden, durch eine „tolerante“ Kante.
  • Erstellen einer Oberflächenausfüllung oder einer ausgeformten Oberfläche zum Füllen der Lücke.
  • Verlängern zweier angrenzender Flächen zum Schließen der Lücke.
Zusätzliche Funktionen:
  • Nicht vereinfachte Oberflächen werden in analytische Oberflächen umgewandelt.
  • Reparierte Flächen werden, falls möglich, zu einem Oberflächenkörper zusammengefügt.
  • Der Körper wird in einen Volumenkörper umgewandelt, wenn der Oberflächenkörper geschlossen ist (ohne Lücken). Dies geschieht automatisch, wenn Sie im Dialogfeld auf OK klicken.


Feedback zu diesem Thema geben

SOLIDWORKS ist dankbar für Ihr Feedback zur Präsentation, Genauigkeit und Vollständigkeit der Dokumentation. Verwenden Sie das nachstehende Formular, um Ihre Kommentare und Vorschläge zu diesem Thema direkt an unser Dokumentations-Team zu senden. Das Dokumentations-Team kann keine Fragen für den technischen Support beantworten. Klicken Sie hier für Informationen zum technischen Support.

* Erforderlich

 
*E-Mail:  
Betreff:   Feedback zu Hilfethemen
Seite:   Import-Diagnose - Übersicht
*Kommentar:  
*   Ich bestätige, dass ich die Datenschutzerklärung, unter der meine personenbezogenen Daten durch Dassault Systèmes verarbeitet werden, gelesen habe und akzeptiere.

Thema drucken

Wählen Sie aus, was gedruckt werden soll:



x

Sie verwenden einen Browser, der älter als Internet Explorer 7 ist. Für eine optimierte Anzeige sollten Sie Ihren Browser auf Internet Explorer 7 oder höher aktualisieren.

 Diese Meldung nicht mehr anzeigen
x

Web-Hilfe Inhaltsversion: SOLIDWORKS 2016 SP05

Um die Web-Hilfe in SOLIDWORKS zu deaktivieren und stattdessen die lokale Hilfe zu verwenden, klicken Sie auf Help > SOLIDWORKS Web-Hilfe verwenden.

Um Probleme mit der Oberfläche und der Suche der Web-Hilfe zu melden, wenden Sie sich an Ihren Support vor Ort. Um Feedback zu einzelnen Hilfethemen zu geben, verwenden Sie den Link “Feedback zu diesem Thema” auf der entsprechenden Themenseite.