Hide Table of Contents

Constructing Splines

Use the Spline command to create open or closed Splines. Splines are smooth curves that are fit to a set of points.

The Splines you create are called non-uniform rational B-splines (NURBS).

Splines are defined either with fit points, or with control vertices. Accordingly, you can apply two methods with the command:

  • Fit points method. Fit points coincide with the Spline. You can fit the Spline to the specified points within a specified tolerance value.

  • Control vertices method. Control vertices (CV) define a control frame. Control frames provide an efficient method for shaping the Splines.

Depending on the selected method, the command prompts differ.

The following procedures describe specific command sequences:

Spline creation without applying specific options

The following command sequence is valid regardless of the method you selected.

To construct Splines:

  1. Do one of the following:
    • On the menu, click Draw > Spline.
    • On the ribbon, click Home > Draw > Spline.
    • Type Spline at the command prompt.
  2. In the graphics area, specify the start point of the Spline.
  3. Specify successive points to continue the Spline.

    Use the Undo option to cancel the previous point specification.

  4. Do one of the following:
    • Specify Close to close the Spline curve. This ends the command.

      When applying the Fit Points method, specify a closing tangency of the Spline.

    • When applying the Fit Points method, press Enter to specify the Start Tangency of the Spline, then specify the End Tangency to complete the Spline.

    • When applying the Control vertices method, press Enter to exit the command. The Spline curve remains open.

Spline creation using fit points

Running the Spline command using the Fit Points method creates degree 3 (cubic) B-splines. You specify control points through which the Spline passes.

To construct Splines using fit points:

  1. Run the Spline command.
  2. Specify the Method option, then specify Fit.

    The Fit Points method is the default method unless you change it.

  3. Do one of the following:
    • In the graphics area, specify the start fit point of the Spline.
    • Specify options:
      • Knots. Specifies the knot computational method.
        • Chord. Sets the knots connecting each component curve so that they are proportional to the distances between each associated pair of fit points. This type of knot parameterization is known as chord length method. Chord is the default option.
        • Square root. Sets the knots connecting each component curve so that they are proportional to the square root of the distance between each associated pair of fit points. This type of knot parameterization is known as centripetal method.
        • Uniform. Sets the distances of the knots of each component curve so that they are equal, regardless of the distance of the fit points. This type of knot parameterization is known as equidistant method method.

        Once you have set the option, specify the starting point for the Spline.

      • Entity. Converts 2D or 3D quadratic or cubic spline-fit Polylines to equivalent Splines and ends the command.
  4. Specify the next fit point.
  5. Do one of the following:
    • Specify successive fit points to continue the Spline.
    • Specify options:
      • Fit tolerance. Specifies how closely the Spline matches its fit points.

        Setting the fit tolerance to zero forces the Spline to pass through the fit points (default). With a value greater than zero, the Spline passes further away from fit points.

        The fit tolerance value applies to all fit points until you change it.

      • Undo. Cancels the previous point specification.
      • Close. Closes the Spline curve and ends the command.
    • Press Enter to specify the Start Tangency of the Spline, then specify the End Tangency to complete the Spline.

      These point specifications determine the tangent conditions on the start point and on the endpoint of the Spline. Lines that are tangent to the Spline display dynamically from the start point and the endpoint of the Spline.

Spline creation using control vertices

Running the Spline command using the Control Vertices method creates Splines of degree 1 (linear), degree 2 (quadratic), degree 3 (cubic), and so on up to degree 5. You specify control points, not points through which the Spline passes.

To construct Splines using control vertices:

  1. Run the Spline command.
  2. Specify the Method option, then specify Control vertices (CV).
  3. Do one of the following:
    • Specify the start control point of the Spline.
    • Specify options:
      • Degree. Specifies the degree for subsequent Spline constructions.

        The default value is 3 for degree 3 (cubic) Splines. Specify a value between 1 and 5.

        Once you have set the option, specify the starting point for the Spline.

      • Entity. Converts 2D or 3D quadratic or cubic spline-fit Polylines to equivalent Splines and ends the command.

      Once you have set options, specify the starting point for the Spline.

  4. Specify the next control vertex.
  5. Do one of the following:
    • In the graphics area, specify successive points to continue the Spline.
    • Specify options as needed:
      • Undo. Cancels the previous point specification.
      • Close. Closes the Spline curve and ends the command.

Access

Command: Spline

Menu: Draw > Spline

Ribbon: Home > Draw > Spline



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Constructing Splines
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2022 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.