Hide Table of Contents

Defining Drawing Settings

The Drawing Settings page of the Options dialog box lets you set the behavior of certain drawing commands, the appearance of certain drawing entities, the unit system of the current drawing, manage Custom Coordinate Systems (CCSs), customize the Drawing Scale List, and set up drawing standards verification.

Behavior

To set the behavior of certain drawing commands and set line scale options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click Drawing Settings .

    • Type DrawingSettings.
  2. Expand Behavior and select or clear Enable relative dimensions. This specifies that dimensions you create are associated to the measured entities.
  3. Expand LineStyle Parameters and set:
    • Global line scale. Sets a scale factor for displaying LineStyles. This is helpful when zooming in and out.
    • Line scale for new entities. Sets the entity line scale for new entities. All entity line scales are displayed based on multiplying the Global line scale by the entity line scale.
    • Scale based on sheet's units. Multiplies the Viewport's custom scale by the evaluated value for Line scale for new entities.
  4. Expand Drawing Boundary and set:
    • Enable drawing boundary: Restricts you to drawing entities within the boundary set in Position.
    • Position: Sets the drawing boundary borders. Specify the coordinates or click Select in graphics area to set the boundaries in the graphics area.
  5. Expand Entity Frame Control. This lets you set the frame visibility for Images, OLE objects, PDF Underlays, and DGN Underlays.
    • Do not display and print frame: Hides the frame at the entity borders in the graphics area and on printouts.
    • Display but do not print frame: Shows the frame at the entity borders in the graphics area, but hides it on printouts.
    • Display and print frame: Shows the frame at the entity borders in the graphics area and on printouts.
  6. Click OK.

Display

To set display options:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click Drawing Settings .

    • Type DrawingSettings.
  2. Expand Display and set:
    • Show Model and Sheet tabs. Turns on and off the display of the Model and Sheet tabs.
    • Show block attributes:
      • Normal. Uses the setting defined in the BlockAttribute.
      • On. Shows BlockAttributes regardless of the setting defined in the BlockAttribute and regardless if they are hidden.
      • Off. Hides BlockAttributes.
    • Rendered entity smoothness. Specify the smoothness of curved surfaces for rendering and shading. The setting affects the visual appearance of 3D solid objects in the drawing. Specify a value between 0.1 and 10.0. The default value is 0.5.

      The specified smoothness also affects the resolution of 3D solid objects when exporting them to stereolithography files (.stl) with the ExportSTL command.

  3. Expand Coordinate System Icon and set:
    • Display icons. Displays coordinate system icons in the Model and Sheet tabs.
    • Display icons at origin. Always displays coordinate system icons at the origin location in the graphics area.
    • Apply changes to all actively displayed views. Applies the settings for Display icons and Display icons at origin to all views.
  4. Expand Thumbnail and specify when thumbnail previews are updated:
    • Model space views. Updates thumbnail previews for Model views.
    • Sheet views. Updates thumbnail previews for layout Sheet views.
    • Sheets. Updates thumbnail previews for layout Sheets.
    • Sheets or views created, modified or restored. Updates thumbnail previews when layout Sheets or views are created, modified, or restored.
    • When drawing is saved. Updates thumbnail previews when the drawing is saved.

    If you clear all options, thumbnail previews are not updated.

  5. Click OK.

More Options: Points, Unit System, Coordinate System, Drawing Scale List, Standards Configurtion

To set the format and size of Point entities:

  • See the PointFormat command which opens the corresponding section of the Options dialog box.

To set up the UnitSystem used in the drawing:

  • See the UnitSystem command which opens the corresponding section of the Options dialog box.

To manage CCSs:

  • See the CSStyle command which opens the corresponding section of the Options dialog box.

To customize the Drawing Scale List:

To set up Drawing Standards verification for the current drawing:

Dimension Snap Offset Distances

To set preferences for dimension location snap:

To set preferences for dimension location snap (Professional, Premium, Enterprise & Enterprise Plus):

You can force dimension lines to be placed at specified distances from measured linear entities and between successive dimension lines or at specified angles for radius and diameter dimensions.

You can also use dimension bounding boxes and the corresponding options from the context menu.

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click Drawing Settings .

    • Type DrawingSettings.
  2. Expand Dimension Snap Offset Distances.
  3. Specify whether to Enable offset distances.
  4. Under Offset Distances, set the:
    1. Offset of the first dimension line from a measured linear entity.
    2. Offset distance between successive dimension lines.

    The default offset distances are 0.40 inches (or 10 mm) between the entity and first dimension line and 0.25 inches (or 6 mm) between dimensions.

  5. In Radial/diameter snap angle, set the snap angle intervals to use when you drag radius and diameter dimensions along radial locations. The default snap angle is 15°.
  6. Under Bounding Box, set:
    • Enable dimension bounding box. Enables the use of tools for working with dimension bounding boxes. The corresponding options are available in the context menu.
    • Show dimension bounding box. Displays all bounding boxes in the drawing.
  7. In Thumbwheel offset spacing (Professional, Premium, Enterprise & Enterprise Plus) specify a value that is used as increment when you spin the thumbwheel in the Dimension palette.

    Use the thumbwheel to enlarge or reduce the offset distances between the first dimension lines from the geometry and
    between successive dimension lines.

    Depending on the standard drawing template file you use, the default thumbwheel spacing increments are 0.10 inches or 2.54 mm.

Centerline Settings

To set preferences for Centerlines:

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click Drawing Settings .

    • Type DrawingSettings.
  2. Expand Centerlines.
  3. In Extension, specify the extension for Centerlines to exceed the entities which define the contour.

Arrow Key Movement

To set preferences for Arrow Key Movement:

To set preferences for Arrow Key Movement (Professional, Premium, Enterprise & Enterprise Plus):

  1. Do one of the following:
    • Click Tools > Options (or type Options).

      Click Application menu > Preferences (or type Options).

      In the Options dialog box, click Drawing Settings .

    • Type DrawingSettings.
  2. Expand Arrow Key Movement and set:
    • Arrow Key Increment. Specifies a positive value to move entities using the arrow keys. Specifies the distance that the selected entities move (Shift + Arrow key)

      For example, if you set Arrow Key Increment to 2.5, pressing Shift + Arrow once moves the selected entities 2.5 units orthogonally, in the arrow direction.

    • Page up/down increment. Specifies a multiplication factor for the Arrow Key Increment.

      For example, if you set Arrow key increment to 2.5 and Page up/down increment to 2, pressing Shift + Arrow key once moves the selected entities 5 units orthogonally, in the arrow direction.

  Use the Find option to search for items in the Options dialog box.

Access

Command: DrawingSettings, or Options

Menu: Tools > Options

Menu: Application menu > Preferences



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Defining Drawing Settings
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2023 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.