Importing STEP, IGES, and ACIS Files in SOLIDWORKS

SOLIDWORKS 3D Interconnect can read STEP, IGES, and ACIS file formats.

SOLIDWORKS 3D Interconnect can read reference planes and user-defined attributes or custom properties from these neutral formats.

To open STEP, IGES, and ACIS files in SOLIDWORKS:

  1. Click File > Open.
  2. Optional: 3DEXPERIENCE Users: If the Open from 3DEXPERIENCE dialog box appears, click This PC.
  3. In the dialog box, in Files of type, select the desired file format:
    • STEP AP203/214/242 (*.step; *.stp).
    • IGES (*.igs; *.iges)
    • ACIS (*.sat)
  4. In the dialog box, browse to the desired file.
  5. For STEP files, you can select Enable Filter option to apply filters before import. This lets you import only selected components of the file or model from the customized FeatureManager design tree.For more information, see
  6. Click Options.
  7. In the System Options dialog box, set options including:
    Option Description
    Entities to Import

    Solids and Surfaces

    Imports the data as solid and surface entities. Select one of the following options:

    • Try forming solid(s). Tries to form solids.
    • Do not knit. Imports as surfaces and prevents surfaces from knitting.

    Free Curves and Points as Sketch

    Imports data as 2D or 3D sketch data with free curves and points.

    Reference Planes

    Imports all the reference planes from the file.

    User Define Attributes

    Reads user-defined attributes and writes them into SOLIDWORKS custom properties.

    Options

    Assembly Structure Mapping

    Select one of these options:

    • Default (As per the file). Keeps the assembly structure of the file and does not postprocess the data.
    • Import multiple bodies as parts. Creates an assembly if a multibody part is imported in SOLIDWORKS.
    • Import assembly as multiple body part. Ignores the assembly structure and creates a multibody part if an assembly is imported in SOLIDWORKS.

    Automatically run Import Diagnostics (Healing)

    When importing a file, Import Diagnostics runs automatically. When cleared, a prompt appears for each import action prompting you to run Import Diagnostics.

    Import Diagnostics options such as Heal Gap, Repair Face, Delete Face, or Remove Gap is available only after you apply Dissolve Feature to neutral CAD files or Break Link feature to the third-party CAD files.

    Create analytic faces (slower)

    Converts the faces with a complex geometric surface to a matching analytical form.

    This option is more accurate since it creates exact analytical faces. The result is more compact but requires additional processing for all geometry.

    Unit of Import

    Select the unit of measure for the imported file:

    • File specified unit. Uses the unit of the imported file.
    • Document template specified unit. Uses the unit specified in the SOLIDWORKS template files under Tools > Options > System Options > Default Templates.

  8. Click OK.
    The 3D Interconnect references for assemblies dissolve and corresponding SOLIDWORKS assembly and part files are created for each component reference. The SOLIDWORKS part files contain the 3D Interconnect feature link to the neutral CAD part file.
    A STEP file containing FACETEDBREP data is imported as a graphics body by default. Select Load Geometry to import it as BREP data.