Hide Table of Contents

Sketch Driven Patterns

Using sketch points within a sketch, you can specify a feature pattern. The seed feature propagates throughout the pattern to each point in the sketch. You can use sketch driven patterns for holes or other feature instances.

To build a sketch driven pattern:

  1. Open a sketch on the face of a part.
  2. Create a seed feature on the model.

  3. Click Point or Tools > Sketch Entity > Point , and add multiple sketch points to represent the pattern you want to create, based on the seed feature.

  4. Close the sketch.
  5. Click Sketch Driven Pattern (Features toolbar) or Insert > Pattern/Mirror > Sketch Driven Pattern.
  6. Under Selections, do the following:
    • If necessary, use the flyout FeatureManager design tree to select a Reference Sketch to use as the pattern.
    • Click either Centroid to use the centroid of the seed feature, or Selected point to use another point as the reference point.
      Depending on what you select as your Reference point, the position of the features you propagate will change.
      Origin used as the Reference point
      Selected Vertex used as the Reference point
      You can also alter the relative position of the features you propagate when using a table driven pattern.
    • If you chose Selected point as the reference point, select a Reference Vertex in the graphics area.
      You can use the centroid of the seed feature, the sketch origin, a vertex, or another sketch point as a reference point in a sketch driven pattern.
  7. Do one of the following:
    • To create the pattern based on the feature, under Features to Pattern , select the feature in the graphics area.
      If the feature to pattern includes fillets or other additions, use the flyout FeatureManager design tree to select these features.
    • To create the pattern based on the faces that make up the feature, under Faces to Pattern select_face_planar.png, select all the faces in the graphics area. This is useful with models that import only the faces that make up the feature, and not the feature itself.
      When using Faces to Pattern, the pattern must remain within the same face or boundary. It cannot cross boundaries . For example, a cut across the entire face or different levels (such as a raised edge) would create a boundary and separate faces, preventing the pattern from propagating.
    • To create a pattern based on multibody parts, under Bodies to Pattern , select the body to pattern in the graphics area.
      Multibody part with Body to Pattern and sketch points Sketch driven pattern applied
  8. Under Options, set these options:
    Option Description
    Geometry pattern Creates the pattern using only the geometry (faces and edges) of the features, rather than patterning and solving each instance of the features. The Geometry Pattern option speeds up the creation and rebuilding of the pattern. You cannot create geometry patterns of features that have faces merged with the rest of the part.
    Geometry pattern is not available with Bodies to Pattern.
    Propagate Visual Properties Propagates SolidWorks colors, textures, and cosmetic thread data to all pattern instances.
  9. Click .

    Sketch pattern with Centroid as the reference point Sketch pattern with Selected point as the reference point



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Sketch Driven Patterns
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.