Hide Table of Contents

Editing PolyLines

Use the EditPolyLine command to edit PolyLines, PolyLine vertices, and 3D PolygonMeshes by:

  • Opening a closed PolyLine or closing an open PolyLine
  • Joining a PolyLine with other drawing entities such as Lines, Arcs, or PolyLines
  • Changing the width of the whole PolyLine and tapering the entire PolyLine
  • Editing the control points (vertices) of individual PolyLine segments

  You can perform many edits of one or more PolyLines with a single EditPolyLine command. If you revert PolyLine editing with a subsequent Undo command, all the working steps are reverted.

To edit PolyLines:

  1. Do one of the following:
    • On the ribbon, click Home > Modify > Edit PolyLine.
    • On the menu, click Modify > Entity > PolyLine.
    • Type EditPolyLine.
  2. In the graphics area, select a PolyLine, or specify the Multiple option to select a group of PolyLines and press Enter.

    If a selected Line or Arc is not a PolyLine, you have the option to convert it to one. You can also use this method to turn a series of individual but connected Lines, Arcs, and PolyLines into a single PolyLine. In a single EditPolyLine command, you can first convert a Line or Arc into a PolyLine. Then use the Join option to add other entities to the PolyLine.

  3. Specify an option:
    • Close / Open. The option displays Close if the PolyLine is open and Open if the PolyLine is closed. The option Back is also available after a polyedit operation. Specify Close to join the start and end points of the PolyLine with a straight PolyLine segment. The width of this segment is the width of the end point of the last drawn PolyLine. Specify Open to delete the PolyLine segment between the start and end points.
    • Decurve. Reverts a PolyLine curve created using Fit or Spline to its original vertices.
    • Edit vertex. Lets you edit the marked vertex by using a vertex editing option. You can also use EntityGrips for some of the options, such as Move. If you specified the Multiple option, you cannot use the Edit vertex option.
      • Add vertex to midpoint. Inserts an additional vertex at the midpoint of the next segment.
      • Convert to arc / Convert to line. Converts the next PolyLine segment to an arc if it is a linear segment or to a line if it is a curved segment. If you convert a linear segment to an arc segment, specify a point to force the arc to pass through.
      • Insert. Inserts a new vertex. Specify the location.
      • Move. Moves the current vertex. Specify the position.
      • Next. Proceeds to the next vertex and makes it active.
      • Previous. Returns to the previous vertex and makes it active.
      • Regen. Regenerates the PolyLine.
      • Split. Divides the PolyLine into two parts, similar to the Split command.
      • Straighten. Deletes vertices.
      • Tangent. Specifies a tangent direction for the vertex when you specify the Fit option during PolyLine editing.
      • Width. Specifies a start and end width for the PolyLine segments that start at the active vertex. To see the effect, use the Regen option.
      • Exit. Exits Edit vertex mode.
    • Fit. Turns the PolyLine into a smooth curve consisting of arcs joining each pair of vertices, resulting in an arc-fit PolyLine. Unlike the Spline option, the curve passes through all vertices of the PolyLine.
    • Join. Merges Lines, Arcs, and other PolyLines with the selected PolyLine. Select the drawing entity to join. The PolyLine to edit and the entity to join must meet exactly at one end point.

      If you specified the Multiple option initially, specify the gap tolerance to join PolyLines that do not touch. Use the Join type sub-option to specify how the gap is closed:

      • Extend. Extends or trims the PolyLine segments to the nearest endpoints that lie within the gap tolerance.
      • Add. Adds a straight segment between the two nearest endpoints that lie within the gap tolerance.
      • Both. Extends or trims the PolyLine segments, if possible. Otherwise, adds a straight segment between the two nearest endpoints.
    • Linegen (line generation). Specifies whether to use a continuous or dashed LineStyle around the vertices for PolyLines with noncontinuous LineStyles. Specify No to place breaks between dashes in LineStyles so they are positioned properly at corners. Specify Yes to set the LineStyle to a fluent pattern around the vertices of the PolyLine.
    • Reverse. Reverses the direction of the PolyLine. The end point is now the starting point, the second to last vertex the second vertex, and so on.
    • Spline. Turns the PolyLine into a curve using the vertices as control points. Unlike the Fit option, the curve usually does not pass through the vertices. Note: Curves created with the Spline option are not true splines in the mathematical sense. To create genuine splines, use the Spline command.
    • Taper. Tapers the width of the PolyLine from the start point to the end point. Specify the width at the starting point, then the width at the endpoint of the PolyLine.
    • Undo. Reverses the most recent operation without exiting the command.
    • Width. Specifies one width to make PolyLines uniform for all segments, including those with different start and end widths. Specify the width by typing a value or using the pointer.
    • Exit. Exits the EditPolyLine command.

  To fillet a PolyLine, use the Fillet command. To chamfer a PolyLine, use the Chamfer command.

Access

Command: EditPolyLine

Ribbon: Home > Modify > Edit PolyLine

Menu: Modify > Entity > PolyLine



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Editing PolyLines
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.