Hide Table of Contents

Defining Blocks

A Block is a collection of entities bound together as a single entity. After you create a Block, you can insert it whenever you need it in a drawing.

When you use the MakeBlock command, the Block is recognized in the current drawing only. The ExportDrawing command lets you write a Block to an external drawing file for use in any drawing.

To define Blocks:

  1. Click Draw > Block > Define (or type MakeBlock).
  2. In the dialog box, for Name, type a name for the Block, or select an existing Block to overwrite a Block. Names may have up to 255 characters, and may contain letters, numbers, blank spaces, and special characters such as $, #, _. The name is case-sensitive.
  3. For Description, type a Block description.
  4. Under Settings, select options:
    • Annotative scaling. Specifies whether annotative scaling is applied when you insert the Block.
    • Orient block to match scale. Specifies that in Viewports Block orientation matches layout Sheet orientation.

      This option is available only if you selected Annotative Scaling for Block insertions.

    • Apply uniform scale. Restricts the Block to a uniform scale when inserting the Block. Otherwise you can specify different X, Y, and Z scaling factors when inserting the Block.
    • Allow block to explode. Lets the Block explode on insertion.
    • Units. Lets you select different units from those in the current drawing.
    • Attach Hyperlink. Lets you specify a hyperlink for the Block.
  5. Optionally, select Edit in Block Editor to modify the Block definition or to create a CustomBlock.
  6. Under Base Point, set the base point that serves as the insertion point when inserting the Block. It is also the base point for changing the scale and serves as a rotation point during the insertion.

    Do one of the following:

    • Click Select in graphics area to specify the base point of the Block in the drawing.
    • For X, Y, and Z, type coordinate values.
  7. Under Block entities:
    1. Click Select in graphics area to specify the entities to form the Block.
    2. Set options:
      • Preserve as separate entities. Leaves the source entities as they are.
      • Convert to block. Replaces the source entities with a Reference of the Block definition.
      • Remove from drawing. Removes the source entities from the drawing.
  8. Click OK.

    If you selected an existing Block in Name, you are asked to redefine the Block.

Access

Command: MakeBlock

Menu: Draw > Block > Define



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Defining Blocks
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.