Hide Table of Contents

Saving Blocks to File

You can write entities, a Block, or an entire drawing to a new drawing file.

You can save a Block or entities as a separate drawing file that you can insert into other drawings.

The ExportDrawing command is similar to the MakeBlock command, but is mainly used to export Blocks, not to define them in the drawing.

To save Blocks to file:

  1. Click File > Export > Export Drawing (or type ExportDrawing).
  2. In the dialog box, under Source, select a source to write to file:
    • Block. Lets you select an existing Block in the drawing to write to file.
    • All entities. Writes the entire drawing to file.
    • Selected entities. Writes the entities you select to file.
  3. Under Block UnitSystem, in UnitSystem, select the units to use for automatic scaling when the file is inserted in a drawing that uses different units (see the UnitSystem command, Block units format option).
  4. Under Entities:
    1. Click Specify entities  and select entities in the graphics area to make up the Block.
    2. Select an option:
      • Convert to Block. Replaces the source entities with a Reference of the Block definition.
      • Do not convert to Block. Leaves the source entities in the drawing as they are.
      • Delete. Removes the source entities from the drawing.
  5. Under Insertion point, for X, Y, and Z, type coordinate values or click Specify in graphics area  to specify an insertion base point in the graphics area.

    The insertion base point is also used as the base for changing the Block's scale and rotation.

  6. Under Destination, select a file name and path where the Block or entities are saved, or click Browse to locate a destination folder and type a File name.
  7. Click OK.

Access

Command: ExportDrawing

Menu: File > Export > Export Drawing



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Saving Blocks to File
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.