Hide Table of Contents

Copying Nested Entities

Use the CopyNested command to duplicate drawing entities that are contained in a Block or a Reference and place a copy of them at a specified location.

Based on one selection, you can create multiple copies. In addition, you can create a specified number of copies in a linear pattern (see Copying Entities in a Linear Pattern).

Optionally, you can force the copied entities onto the active layer.

To copy nested entities:

  1. Do one of the following:
    • On the ribbon, click Home > Modify > Copy Nested.
    • On the menu, click Modify > Copy Nested.
    • Type CopyNested at the command prompt.
  2. Do one of the following:
    • Specify nested entities you want to duplicate and press Enter.
    • Before you specify the nested entities, use the Settings option to decide whether you want to bind or insert the entities. This option determines whether dependent symbols such as Layers, LineStyles, TextStyles, DimensionStyles, and Block definitions associated with the specified entities are added to the drawing:
      • Insert. Similar to the Copy command, the specified entities are copied to the current Layer without regard to dependent symbols.
      • Bind. Includes the dependent symbols associated with the specified entities into the drawing.
  3. Do one of the following:
    • Specify a source base point for the copy.
    • Specify the Displacement option and provide the relative location of the copy by specifying the X, Y, and Z displacements, for example, 3,5,5. If you want to make the copy in the X and Y directions only, do not specify a Z delta. In this case, for example, specify 3,5.

      This option exits the command after you specify the displacement.

    • Specify the Active Layer option to force the entities onto the active layer, then specify the destination point.

      This setting is preserved during the current application session until you reset it.

    • Specify the Multiple option to create more than one copy, then specify the source base point.
  4. Do one of the following:
    • Specify a destination point to displace the copy.
    • Specify the Pattern option to create a specified number of copies in a linear pattern.

      See Copying Entities in a Linear Pattern).

  5. If you specified to create multiple copies, specify subsequent destination points.

    The copies are placed in the specified positions. If the result of a multiple copy is unexpected, specify the Undo option.

  6. To finish duplicating entities, press Enter.

  The Pattern command is an effective tool to create multiple copies in a linear or circular pattern.

Access

Command: CopyNested

Menu: Modify > Copy Nested

Ribbon: Home > Modify > Copy Nested



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Copying Nested Entities
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2023 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.