Hide Table of Contents

Mid Surface

The Mid-Surface tool enables you to create mid surfaces between suitable selected face pairs on solid bodies. Suitable face pairs should be offset from each other.

The faces must belong to the same body. Examples of suitable face pairs include two parallel planes, or two concentric cylindrical faces. Mid surface is useful for generating meshes of two-dimensional elements in finite element modeling.

You can create any of the following mid surfaces:

Single Select a single pair of offset faces from the graphics area.
Multiple Select multiple pairs of offset faces from the graphics area.
All Click Find Face Pairs to have the system select all suitable offset faces on the model.

The resulting surface includes all the same attributes as any surface created in SOLIDWORKS.

To create a mid surface:

  1. Click Mid-Surface on the Surfaces toolbar, or click Insert > Surface > Mid Surface.
  2. Under Selections, choose one of the following:
    • From the graphics area an individual set of face pairs, multiple sets of face pairs
    • From the PropertyManager, click Find Face Pairs to have the system scan the model for all suitable face pairs. Find Face Pairs automatically filters out any unsuitable face pairs.

    Individual face pair selected All face pairs selected (Find Face Pairs)

  3. Use Position to place the mid surface between the face pair. The default is 50%. The position is the distance between the faces that appear in the Face 1 and Face 2 boxes, starting from Face 1.

    mid surface
    face 1
    face 2
      Position 50% Position 75%

  4. When you use Find Face Pairs, you can specify a Recognition threshold to filter the results. The Recognition threshold is based on combining the following:
    • The Threshold Operator function (= equal, < less than, <= less than or equal to, > greater than, >= greater than or equal to), is the mathematical operative.
    • The Threshold Thickness is the wall thickness.

    For example, you can set the system to recognize all suitable face pairs that have a wall thickness of less than or equal to (<=) 3 millimeters. Any face pair not meeting this criteria is not included in the results.

  5. Click Knit surfaces to create a knit surface, or clear this option to keep individual surfaces.
  6. Click OK .

Using the Mid Surface Tool

You can either add new face pairs, delete existing ones, or update face pairs.

To use the Mid Surface tool:

  1. Click Mid-Surface on the Surfaces toolbar, or click Insert > Surface > Mid Surface.
  2. Do one of the following:
    Option Description
    Delete face pairs Select a set in Face Pairs and press Delete.
    Add face pairs
    1. Select Face 1 in the PropertyManager, and choose a face in the graphics area.
    2. Choose an offset face as Face 2.

    The selected faces are highlighted in the graphics area, and listed under Face Pairs.

    Update face pairs
    1. Select a set in Face Pairs. The face pair is displayed in Face 1 and Face 2.
    2. Select another pair of offset faces in the graphics area.
      You can also amend one selection of the offset pair, provided the new face you select is offset to the first face.
    3. Click Update Pair to update Face pairs with the new set of faces.
  3. Click OK .


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Mid Surface
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.