Hide Table of Contents

Referencing Drawings - Basics

Differences between References and Block insertions

Referenced drawings are similar to Block insertions, but the differences are that:

  • Referencing a drawing establishes a link to another drawing file, but it does not become a permanent part of the current drawing, keeping the file size smaller.
  • You can move, scale, rotate, and copy Referenced drawings. You cannot explode a Reference as you can with Blocks.
Dependent symbol names

When attaching drawing files, Layers, LineStyles, TextStyles, DimensionStyles, Block definitions, and other symbols are loaded into the drawing.

The following scheme is used to name dependent symbols in the drawing:

Logical_Reference_Name| Dependent_Symbol_Name

For example, the layer names of a Referenced drawing with the name SHAFT are listed as:

SHAFT|CONSTRUCTION

SHAFT|DETAILS

SHAFT|DIMENSION

Other dependent symbols like LineStyles or Blocks use the same naming convention.

You cannot redefine or rename dependent symbols. Also, you cannot insert dependent Blocks and you cannot make a dependent Layer the current Layer.

The dependent symbol conventions allow you to control the visibility as well as the LineColors and LineStyles of Referenced drawings. The Layers Manager dialog box displays the names of the dependent Layers and you can apply various options.

The logical name prefix makes it easy to distinguish the dependent Layers from the Layers originally defined in the drawing.

Updating References from the current drawing

All Referenced drawings update automatically when you open a drawing. If one or more externally referenced files are missing or cannot be loaded because they are corrupted a pop-up alert appears.

The software periodically checks whether the attached referenced drawings have changed since the last time the referenced drawings were loaded.

When you open a drawing that contains one or more externally referenced files the External Reference icon () appears in the status bar.

By default, if a referenced drawing is changed, an alert symbol appears and a balloon message displays at the External Reference icon () in the status bar. Clicking the links in the message reloads the changed referenced drawings. If you close the message without reloading the referenced drawings, the alert symbol remains.

You can display at any time the latest version of Referenced drawings used in your drawing using the Reload All tool from the References palette. Alternatively, use the options from the External References icon context menu to reload all changed files.

You can control the notification display from the Options dialog box: System Options > General > Reference notification.

Removing References from the current drawing

You should not remove Referenced drawings from the current drawing with the Delete command because it does not delete the dependent symbols from the drawing.

To remove References:

  1. If the References palette is not displayed, click Tools > References (or type References).
  2. Right-click the Referenced file on the list and click Detach.

    The Reference disappears and the link is removed.

You can also use the Detach option of the -References command.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Referencing Drawings - Basics
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.