Hide Table of Contents

Working with the Ribbon

The ribbon provides access to many commands thanks to a number of dedicated tabs.

This task shows you how to:

Access Ribbon Commands

You can access application features in the ribbon through dedicated menus and tabs.

  1. In the ribbon, click the appropriate menu or tab.

    Commands in the... Allow you to...
    File menu Manage your files, including publishing to many formats, and set application and document properties.
    Home tab
    • Copy, cut, and paste content.
    • Access commonly used workshops and entire animation mode.
    • Manage actor visibility in the scene.
    • Use the Digger tool as a magnifying glass to isolate areas of your scene.
    • Navigate the viewport by moving the position and orientation of the camera.
    Render tab Control scene lighting and rendering characteristics.
    Author tab Enhance models with 3D redlining, annotations, dimensions, and other collaborative actors.
    Styles tabView the style gallery, apply styles to actors, and subscribe actors to styles. Use the Styles workshop to create and manage styles.
    Transform tabTranslate and rotate alignments, and explode actors.
    Geometry tabManipulate geometry actors.
    Animate tab Animate your scenes.
    Workshops tabLaunch a specific workshop.
    Window tabManage Composer window panes and document windows.
    Help tabRegister the product, access product documentation, and manage your license.

    The dedicated commands appear.
  2. Click the command you want to use.

Minimize the Ribbon

You can minimize the ribbon interface to increase the space available for the viewport and other Composer panes.

To toggle between full and minimized ribbon, do one of the following:
  • Click Minimize the Ribbon in the upper-right corner of the Composer window.
  • Double-click the active ribbon tab.
  • Press Ctrl+F1.
  • Right-click in the ribbon and click Minimize the Ribbon.
The ribbon is now minimized.
Note: When the ribbon is minimized, you can access ribbon commands by clicking a ribbon tab. For example, click Transform to view transformation commands.

Search for Commands in the Ribbon

You can search for commands that appear in the ribbon and recently used documents.

  1. On the ribbon, click in the Start Search box.
  2. Type the name of the command or recent document you are looking for.
    Ribbon commands and recently accessed documents that contain the search string appear.
  3. Click a command to execute it or a document to open it.

Notes:
  • The search is limited to commands that appear on the ribbon.
  • If the command is on the current ribbon tab, the command is highlighted. If the command is on a different tab, the current tab does not change.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Working with the Ribbon
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS Composer 2024 SP01

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.