Hide Table of Contents

Setting Caching Behavior

You can edit user or group profiles to control how files in designated folders are cached and refreshed.

Automatically clearing the cache during logout reduces a user's cache size and increases security on machines that are used by multiple users. Automatically refreshing the cache during log in ensures that users have the latest version of items like CAD file templates and standard libraries each time they log in.

  1. Under Users, double-click a user.
  2. In the user's Properties dialog box, click Cache Options.
  3. On the Cache Options per Folder tab, in the folder list, select the folder for which you want to control caching.
  4. Under Cache Options, select one or both of the following:
    • Clear cache during log out

      When the user logs out, the software automatically clears the cache for the selected folder and its subfolders.

      The option to clear the cache during log out clears all files from the selected folder that are not checked out. It does not retain file that are referenced by checked out files.

      This is different from the behavior when users clear their caches manually. In that case, referenced files are retained.

    • Refresh cache during log in

      When the user logins in, the software automatically places copies of the files in the selected folder in the user's local cache.

  5. On the Assigned Cache Options tab, review folders where cache options have been assigned for this user.

    Folders with assigned options appear in the list at the top of the tab.

    When you select a folder, the options that have been assigned for it appear under Cache Options at the bottom of the tab. You can clear or select these options. Clearing the options does not remove the folder from the list.

  6. To remove a folder from the list, select it and click Remove.
  7. To add cache options using the Assigned Cache Options tab:
    1. Click Add.
    2. In the Add Cache Assignment dialog box, select a folder.

      Alternatively, you can click Make New Folder, type a name for the new folder in the dialog box that appears, and click OK.

    3. Click OK.
    4. Under Cache Options, select one or both of the following:

      • Clear cache during log out
      • Refresh cache during log in



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Setting Caching Behavior
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS PDM 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.