Hide Table of Contents

Overview

What's New?

Getting Started

Starting Composer

Loading Models

Using Views

Highlighting and Selecting Actors

Navigating the Viewport

Managing Properties

Creating and Updating Views

Moving Actors

Adding Collaborative Actors

Using Digger

Creating BOMs

Creating Technical Illustrations

Using Animations

Interface Concepts

Importing and Opening Files

Importing and Opening Files

About Supported Import Formats

About Composer File Types

Working with Actors

About Actors and Associativity

Translating and Rotating Actors

Placing and Aligning Actors

Aligning Actors

About Grids and Magnetic Lines

Using a Grid

Using Magnetic Lines

Transforming Actors

About Gizmos

About Explode Transformations

Copying Actor Translation and Rotation Changes

Copying Actor Translation and Rotation Changes

Copy Location and Copy Transformation Examples

Using Align Pivots

Creating Kinematic Links Between Actors

Working with Annotations

Using Styles

Adding Textures

Creating a Layer

Filtering

Applying Secure 3D Brush

Working with Cutting Planes

About Cutting Planes

Creating and Manipulating Cutting Planes

Using Two Cutting Planes to Create a Quarter Cross Section

Working with Views

About Views

Working with Views

Working with the Ribbon

Working with the Ribbon

Miscellaneous Background Information

About the Creation of PDF Templates

About Copy/Paste

About the Style Preview

File Menu

Home Tab

Render Tab

Author Tab

Styles Tab

Transform Tab

Geometry Tab

Animate Tab

Workshops Tab

Window Tab

SOLIDWORKS PDM Tab

Help Menu

Working with the Left Panes

Organizing the Left Panes

Assembly Pane

BOM Pane

Collaboration Pane

Configurations Pane

Layers Pane

Markers Pane

Views Pane

Properties Pane

Information Pane

Navigating the Viewport

About the Viewport

Navigating the Viewport

Displaying and Navigating the Paper Space

Working in Workshops

Working in Workshops

Animation Library Workshop

BOM Workshop

Clearance Checking Workshop

Filters Workshop

Getting Started Workshop

High Resolution Image Workshop

Image Library Workshop

Interactive Collision Detection Workshop

Model Browser Workshop

Simplification Workshop

Simplification Workshop

Clones Detection Example

Styles Workshop

Technical Illustration Workshop

Textures Workshop

Video Workshop

Views Workshop

Editing Actor Properties

About Actor Properties

Editing Actor Properties

Annotation Properties

BOM Table Properties

Camera Properties

Compass Properties

Cutting Plane Properties

Debug Properties

Geometry Actor Properties

Grid Properties

Ground Properties

Hotspot Properties

Light Properties

Magnetic Line Properties

Markup Properties

Measurement Properties

Panel Properties

Path Properties

Viewport Properties

Managing (Default) Document Properties

Accessing and Customizing (Default) Document Properties

Sharing (Default) Document Properties Across Teams

Security

Signature

Viewport

Viewport Background

Selection

Image Quality

Input

Update

Output

Animation

History

Right Manager

Project

Paper Space

Units

Advanced Properties

Miscellaneous Examples

Example - Input Settings

Publishing

Publishing to HTML

About the HTML Output

Publishing to HTML

Publishing to 3DVIA Studio

About Publishing to 3DVIA Studio

Publishing to 3DVIA Studio

Playing a Composer Experience in 3DVIA Studio

Creating Animations

About the Timeline

About the Animation Library

Custom Animation XML Example

About Scenarios

Creating Pre-defined Animations

Creating Animations by Animating Actors Individually

Creating and Using Animation Markers and Milestones

Using the Timeline

Using the Timeline

Timeline Commands

Customizing Application Preferences

Accessing and Customizing Application Preferences

General

Input

Viewport

Camera

Selection

Navigation

Hardware Support

Application Paths

Data Paths

Data Paths

About Data Paths

Advanced Settings

Licensing and System Requirements

Tools

About the Composer PMI Remover

Using the Composer PMI Remover

Reference Information: Regular Expression Syntax

Administration

Disabling Document Property and Application Preference Modifications

About Profiles for Workshop Settings

Defining Custom Import Profiles

Interface Description

Quick Access Toolbar

Customizing the Quick Access Toolbar

Status Bar

Keyboard Shortcuts

Dialog Boxes

Add Child Scenario

Configure Columns

Customize

Level of Detail

Meta-Properties

New Project

Open Files

Publish to 3DVIA Studio

Publish to HTML (Save As)

Publish to PDF

Save Package As

Scale Geometry

Search Pane

Secure 3D Brush

Select Pane

Select Language

Select a Link

Send by E-mail

Text Pane

Time Settings

Update Composer Document

Video Compression

Windows

Reporting a Problem

About APIs (Application Programming Interfaces)

Index



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Sitemap
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:




x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS Composer 2021 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.